diff mbox series

[05/29] package/gobject-introspection: really use host python for host variant

Message ID 20230101233653.487175-6-ricardo.martincoski@gmail.com
State Accepted
Headers show
Series check-package: warn about symbols not recognized by a package infra | expand

Commit Message

Ricardo Martincoski Jan. 1, 2023, 11:36 p.m. UTC
Commit "abc110e362 package/gobject-introspection: bump to version
1.68.0" renamed the define that makes sure g-ir-tool-template uses the
host python, but forgot to update its call on pre-configure hooks.

Update it now.

Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
---
Tested using this minimal config:
 BR2_x86_i686=y
 BR2_TOOLCHAIN_EXTERNAL=y
 BR2_PACKAGE_PYTHON3=y
 BR2_PACKAGE_GOBJECT_INTROSPECTION=y
and these commands:
$ make host-gobject-introspection-configure
$ head -n 1 output/build/host-gobject-introspection-*/tools/g-ir-tool-template.in

Before this patch:
 #!@PYTHON_CMD@
After this patch:
 (the shebang points to the correct absolute path to output/host/bin/python3)
---
 package/gobject-introspection/gobject-introspection.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Jan. 5, 2023, 10:28 p.m. UTC | #1
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > Commit "abc110e362 package/gobject-introspection: bump to version
 > 1.68.0" renamed the define that makes sure g-ir-tool-template uses the
 > host python, but forgot to update its call on pre-configure hooks.

 > Update it now.

 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>

Committed, thanks.
Peter Korsgaard Jan. 11, 2023, 9:51 a.m. UTC | #2
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > Commit "abc110e362 package/gobject-introspection: bump to version
 > 1.68.0" renamed the define that makes sure g-ir-tool-template uses the
 > host python, but forgot to update its call on pre-configure hooks.

 > Update it now.

 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>

Committed to 2022.11.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/gobject-introspection/gobject-introspection.mk b/package/gobject-introspection/gobject-introspection.mk
index c8ad9b3c72..70f4addeab 100644
--- a/package/gobject-introspection/gobject-introspection.mk
+++ b/package/gobject-introspection/gobject-introspection.mk
@@ -67,7 +67,7 @@  HOST_GOBJECT_INTROSPECTION_CONF_ENV = \
 define GOBJECT_INTROSPECTION_FIX_TOOLS_PYTHON_PATH
 	$(SED) '1s%#!.*%#!$(HOST_DIR)/bin/python3%' $(@D)/tools/g-ir-tool-template.in
 endef
-HOST_GOBJECT_INTROSPECTION_PRE_CONFIGURE_HOOKS += GOBJECT_INTROSPECTION_FIX_TOOLTEMPLATE_PYTHON_PATH
+HOST_GOBJECT_INTROSPECTION_PRE_CONFIGURE_HOOKS += GOBJECT_INTROSPECTION_FIX_TOOLS_PYTHON_PATH
 
 # Perform the following:
 # - Just as above, Ensure that g-ir-tool-template.in uses the host python.