diff mbox series

[10/29] Revert "pptp-linux: fix build with high BR2_JLEVEL settings"

Message ID 20230101233653.487175-11-ricardo.martincoski@gmail.com
State Accepted
Headers show
Series check-package: warn about symbols not recognized by a package infra | expand

Commit Message

Ricardo Martincoski Jan. 1, 2023, 11:36 p.m. UTC
This reverts commit ffc4afe084a76e7246bd373c73b706f512a86c2b.

Commit from 2012 "ffc4afe084 pptp-linux: fix build with high BR2_JLEVEL
settings" added <pkg>_MAKE to a generic package, but the generic infra
does not take this symbol into account.

The build issue was fixed in 2013 with commit "a5b8081b89 pptp-linux:
fix parallel build" by adding a patch file.

So drop the bogus PPTP_LINUX_MAKE.

Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
---
Using this defconfig:
 BR2_x86_i686=y
 BR2_TOOLCHAIN_EXTERNAL=y
 BR2_JLEVEL=3
 BR2_PACKAGE_PPTP_LINUX=y
one can see at the output of:
$ make V=1 pptp-linux

Before this patch:
... /usr/bin/make -j3 ...
After this patch:
... /usr/bin/make -j3 ...
---
 package/pptp-linux/pptp-linux.mk | 1 -
 1 file changed, 1 deletion(-)

Comments

Peter Korsgaard Jan. 4, 2023, 4:52 p.m. UTC | #1
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > This reverts commit ffc4afe084a76e7246bd373c73b706f512a86c2b.
 > Commit from 2012 "ffc4afe084 pptp-linux: fix build with high BR2_JLEVEL
 > settings" added <pkg>_MAKE to a generic package, but the generic infra
 > does not take this symbol into account.

 > The build issue was fixed in 2013 with commit "a5b8081b89 pptp-linux:
 > fix parallel build" by adding a patch file.

 > So drop the bogus PPTP_LINUX_MAKE.

 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>

Committed, thanks.
Peter Korsgaard Jan. 11, 2023, 9:14 a.m. UTC | #2
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > This reverts commit ffc4afe084a76e7246bd373c73b706f512a86c2b.
 > Commit from 2012 "ffc4afe084 pptp-linux: fix build with high BR2_JLEVEL
 > settings" added <pkg>_MAKE to a generic package, but the generic infra
 > does not take this symbol into account.

 > The build issue was fixed in 2013 with commit "a5b8081b89 pptp-linux:
 > fix parallel build" by adding a patch file.

 > So drop the bogus PPTP_LINUX_MAKE.

 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>

Committed to 2022.11.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/pptp-linux/pptp-linux.mk b/package/pptp-linux/pptp-linux.mk
index 7fd0733977..b6c740e710 100644
--- a/package/pptp-linux/pptp-linux.mk
+++ b/package/pptp-linux/pptp-linux.mk
@@ -7,7 +7,6 @@ 
 PPTP_LINUX_VERSION = 1.10.0
 PPTP_LINUX_SITE = http://downloads.sourceforge.net/project/pptpclient/pptp/pptp-$(PPTP_LINUX_VERSION)
 PPTP_LINUX_SOURCE = pptp-$(PPTP_LINUX_VERSION).tar.gz
-PPTP_LINUX_MAKE = $(MAKE1)
 PPTP_LINUX_LICENSE = GPL-2.0+
 PPTP_LINUX_LICENSE_FILES = COPYING