diff mbox series

[11/29] Revert "package/zip: install to staging"

Message ID 20230101233653.487175-12-ricardo.martincoski@gmail.com
State Accepted
Headers show
Series check-package: warn about symbols not recognized by a package infra | expand

Commit Message

Ricardo Martincoski Jan. 1, 2023, 11:36 p.m. UTC
This reverts commit c5b5b5ccabe35e11f0ca8db4361bb3f335fc59fb.

Commit "c5b5b5ccab package/zip: install to staging" contains a typo that
prevents installing to staging.
ZIP_INSTALLING_STAGING_CMDS -> ZIP_INSTALL_STAGING_CMDS

But the package does not install headers or libraries, only ELF and
manual files.
So instead of fixing the install to staging, revert the bogus commit.

Cc: Jan Pedersen <jp@jp-embedded.com>
Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
---
Even in the case we fix the typo:
-define ZIP_INSTALLING_STAGING_CMDS
+define ZIP_INSTALL_STAGING_CMDS
using this defconfig:
 BR2_x86_i686=y
 BR2_TOOLCHAIN_EXTERNAL=y
 BR2_PACKAGE_ZIP=y
one can confirm the package does not install libraries or headers:
|--- output.before/build/packages-file-list-staging.txt.sorted
|+++ output.after/build/packages-file-list-staging.txt.sorted
|@@ -2346,0 +2347,8 @@
|+zip,./usr/bin/zip
|+zip,./usr/bin/zipcloak
|+zip,./usr/bin/zipnote
|+zip,./usr/bin/zipsplit
|+zip,./usr/man/man1/zip.1
|+zip,./usr/man/man1/zipcloak.1
|+zip,./usr/man/man1/zipnote.1
|+zip,./usr/man/man1/zipsplit.1
---
 package/zip/zip.mk | 6 ------
 1 file changed, 6 deletions(-)

Comments

Peter Korsgaard Jan. 4, 2023, 4:53 p.m. UTC | #1
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > This reverts commit c5b5b5ccabe35e11f0ca8db4361bb3f335fc59fb.
 > Commit "c5b5b5ccab package/zip: install to staging" contains a typo that
 > prevents installing to staging.
 > ZIP_INSTALLING_STAGING_CMDS -> ZIP_INSTALL_STAGING_CMDS

 > But the package does not install headers or libraries, only ELF and
 > manual files.
 > So instead of fixing the install to staging, revert the bogus commit.

 > Cc: Jan Pedersen <jp@jp-embedded.com>
 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>

Committed, thanks.
Peter Korsgaard Jan. 11, 2023, 9:14 a.m. UTC | #2
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > This reverts commit c5b5b5ccabe35e11f0ca8db4361bb3f335fc59fb.
 > Commit "c5b5b5ccab package/zip: install to staging" contains a typo that
 > prevents installing to staging.
 > ZIP_INSTALLING_STAGING_CMDS -> ZIP_INSTALL_STAGING_CMDS

 > But the package does not install headers or libraries, only ELF and
 > manual files.
 > So instead of fixing the install to staging, revert the bogus commit.

 > Cc: Jan Pedersen <jp@jp-embedded.com>
 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>

Committed to 2022.11.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/zip/zip.mk b/package/zip/zip.mk
index 2d11e1c763..67958a4a66 100644
--- a/package/zip/zip.mk
+++ b/package/zip/zip.mk
@@ -11,7 +11,6 @@  ZIP_SITE = ftp://ftp.info-zip.org/pub/infozip/src
 ZIP_LICENSE = Info-ZIP
 ZIP_LICENSE_FILES = LICENSE
 ZIP_CPE_ID_VENDOR = info-zip_project
-ZIP_INSTALL_STAGING = YES
 
 ifeq ($(BR2_PACKAGE_BZIP2),y)
 ZIP_DEPENDENCIES += bzip2
@@ -41,11 +40,6 @@  define ZIP_INSTALL_TARGET_CMDS
 		prefix=$(TARGET_DIR)/usr
 endef
 
-define ZIP_INSTALLING_STAGING_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) -f unix/Makefile install \
-		prefix=$(STAGING_DIR)/usr
-endef
-
 define HOST_ZIP_BUILD_CMDS
 	$(HOST_MAKE_ENV) $(MAKE) $(HOST_CONFIGURE_OPTS) -C $(@D) \
 		CFLAGS="$(HOST_CFLAGS) $(ZIP_CFLAGS)" \