diff mbox series

[02/29] package/libmng: fix optional dependency to lcms2

Message ID 20230101233653.487175-3-ricardo.martincoski@gmail.com
State Accepted
Headers show
Series check-package: warn about symbols not recognized by a package infra | expand

Commit Message

Ricardo Martincoski Jan. 1, 2023, 11:36 p.m. UTC
"0ce9b533e3 libmng: new package" introduced a typo that makes the
optional dependency to lcms2 ineffective.

Fix the typo LIBMNG_DEPDENDENCIES -> LIBMNG_DEPENDENCIES.

Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
---
Tested using this minimal config:
 BR2_x86_i686=y
 BR2_TOOLCHAIN_EXTERNAL=y
 BR2_PACKAGE_LCMS2=y
 BR2_PACKAGE_LIBMNG=y

before this patch:
$ make libmng-show-depends
host-skeleton jpeg skeleton toolchain zlib

after this patch:
$ make libmng-show-depends
host-skeleton jpeg lcms2 skeleton toolchain zlib

build test:
44 builds, 0 skipped, 0 build failed, 0 legal-info failed, 0 show-info failed
https://gitlab.com/RicardoMartincoski/buildroot/-/pipelines/731769914

test-pkg config:
BR2_PACKAGE_LCMS2=y
BR2_PACKAGE_LIBMNG=y
---
 package/libmng/libmng.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Jan. 4, 2023, 4:45 p.m. UTC | #1
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > "0ce9b533e3 libmng: new package" introduced a typo that makes the
 > optional dependency to lcms2 ineffective.

 > Fix the typo LIBMNG_DEPDENDENCIES -> LIBMNG_DEPENDENCIES.

 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>

Committed, thanks.
Peter Korsgaard Jan. 11, 2023, 9:06 a.m. UTC | #2
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > "0ce9b533e3 libmng: new package" introduced a typo that makes the
 > optional dependency to lcms2 ineffective.

 > Fix the typo LIBMNG_DEPDENDENCIES -> LIBMNG_DEPENDENCIES.

 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>

Committed to 2022.11.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/libmng/libmng.mk b/package/libmng/libmng.mk
index 090fe18380..8ffd74c05b 100644
--- a/package/libmng/libmng.mk
+++ b/package/libmng/libmng.mk
@@ -14,7 +14,7 @@  LIBMNG_LICENSE = libmng license
 LIBMNG_LICENSE_FILES = LICENSE
 
 ifeq ($(BR2_PACKAGE_LCMS2),y)
-LIBMNG_DEPDENDENCIES += lcms2
+LIBMNG_DEPENDENCIES += lcms2
 else
 LIBMNG_CONF_OPTS += --without-lcms2
 endif