diff mbox series

[09/29] package/tekui: really disable parallel build

Message ID 20230101233653.487175-10-ricardo.martincoski@gmail.com
State Accepted
Headers show
Series check-package: warn about symbols not recognized by a package infra | expand

Commit Message

Ricardo Martincoski Jan. 1, 2023, 11:36 p.m. UTC
Commit "c80789c917 tekui: disable parallel build" added TEKUI_MAKE but
that is not a symbol used by the generic package infra.

Ensure -j1 is passed to the build and install commands by using
TEKUI_MAKE explicitly.

Fixes:
http://autobuild.buildroot.net/results/c6cd0d488581013a8b215b0ee2fd8f549a868d4b

Cc: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
---
NOTE: I was unable to reproduce the build issue locally, in current
master, using a few times:
$ make BR2_JLEVEL=99 tekui-dirclean tekui
either at the output of:
$ br-reproduce-build c6cd0d488581013a8b215b0ee2fd8f549a868d4b
or with this minimal defconfig:
 BR2_x86_i686=y
 BR2_TOOLCHAIN_EXTERNAL=y
 BR2_JLEVEL=99
 BR2_PACKAGE_TEKUI=y
 BR2_PACKAGE_LUA=y

Testing using this defconfig:
 BR2_x86_i686=y
 BR2_TOOLCHAIN_EXTERNAL=y
 BR2_JLEVEL=3
 BR2_PACKAGE_TEKUI=y
 BR2_PACKAGE_LUA=y
and the command:
$ make V=1 tekui-build

Before this patch:
... /usr/bin/make -j3 ...

After this patch:
... /usr/bin/make -j1 ...
---
 package/tekui/tekui.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard Jan. 4, 2023, 4:51 p.m. UTC | #1
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > Commit "c80789c917 tekui: disable parallel build" added TEKUI_MAKE but
 > that is not a symbol used by the generic package infra.

 > Ensure -j1 is passed to the build and install commands by using
 > TEKUI_MAKE explicitly.

 > Fixes:
 > http://autobuild.buildroot.net/results/c6cd0d488581013a8b215b0ee2fd8f549a868d4b

That build seems to use make -j1?

 > Cc: Francois Perrad <francois.perrad@gadz.org>
 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>

Committed, thanks.
Peter Korsgaard Jan. 11, 2023, 9:14 a.m. UTC | #2
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > Commit "c80789c917 tekui: disable parallel build" added TEKUI_MAKE but
 > that is not a symbol used by the generic package infra.

 > Ensure -j1 is passed to the build and install commands by using
 > TEKUI_MAKE explicitly.

 > Fixes:
 > http://autobuild.buildroot.net/results/c6cd0d488581013a8b215b0ee2fd8f549a868d4b

 > Cc: Francois Perrad <francois.perrad@gadz.org>
 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>

Committed to 2022.11.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/tekui/tekui.mk b/package/tekui/tekui.mk
index 13000edd3e..3cb7ff51e5 100644
--- a/package/tekui/tekui.mk
+++ b/package/tekui/tekui.mk
@@ -59,11 +59,11 @@  endif
 endif
 
 define TEKUI_BUILD_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) $(TEKUI_MAKE_OPTS) PREFIX="/usr" -C $(@D) all
+	$(TARGET_MAKE_ENV) $(TEKUI_MAKE) $(TEKUI_MAKE_OPTS) PREFIX="/usr" -C $(@D) all
 endef
 
 define TEKUI_INSTALL_TARGET_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) $(TEKUI_MAKE_OPTS) PREFIX="$(TARGET_DIR)/usr" -C $(@D) install
+	$(TARGET_MAKE_ENV) $(TEKUI_MAKE) $(TEKUI_MAKE_OPTS) PREFIX="$(TARGET_DIR)/usr" -C $(@D) install
 endef
 
 $(eval $(generic-package))