diff mbox series

[09/31] package/grep: disable busybox grep, egrep & fgrep

Message ID 20240313091412.20865-9-francois.perrad@gadz.org
State Rejected
Headers show
Series [01/31] package/busybox: move the hush config in a fragment | expand

Commit Message

Francois Perrad March 13, 2024, 9:13 a.m. UTC
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/grep/grep.mk | 6 ++++++
 1 file changed, 6 insertions(+)
diff mbox series

Patch

diff --git a/package/grep/grep.mk b/package/grep/grep.mk
index 61900bb95..b0602e9e7 100644
--- a/package/grep/grep.mk
+++ b/package/grep/grep.mk
@@ -45,4 +45,10 @@  else
 GREP_CONF_OPTS += --disable-perl-regexp
 endif
 
+define GREP_BUSYBOX_CONFIG_FIXUPS
+	$(call KCONFIG_DISABLE_OPT,CONFIG_GREP)
+	$(call KCONFIG_DISABLE_OPT,CONFIG_EGREP)
+	$(call KCONFIG_DISABLE_OPT,CONFIG_FGREP)
+endef
+
 $(eval $(autotools-package))