diff mbox series

[10/31] package/gzip: disable busybox gunzip & gzip

Message ID 20240313091412.20865-10-francois.perrad@gadz.org
State Rejected
Headers show
Series [01/31] package/busybox: move the hush config in a fragment | expand

Commit Message

Francois Perrad March 13, 2024, 9:13 a.m. UTC
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/gzip/gzip.mk | 5 +++++
 1 file changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/package/gzip/gzip.mk b/package/gzip/gzip.mk
index 330321352..3d16235b0 100644
--- a/package/gzip/gzip.mk
+++ b/package/gzip/gzip.mk
@@ -22,5 +22,10 @@  HOST_GZIP_CONF_ENV += gl_cv_func_fflush_stdin=yes
 #  "using /bin/sh, even though it may have file descriptor bugs"
 GZIP_CONF_ENV += ac_cv_path_shell=/bin/sh
 
+define GZIP_BUSYBOX_CONFIG_FIXUPS
+	$(call KCONFIG_DISABLE_OPT,CONFIG_GUNZIP)
+	$(call KCONFIG_DISABLE_OPT,CONFIG_GZIP)
+endef
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))