diff mbox series

[03/31] package/dcron: disable busybox crond & crontab

Message ID 20240313091412.20865-3-francois.perrad@gadz.org
State Rejected
Headers show
Series [01/31] package/busybox: move the hush config in a fragment | expand

Commit Message

Francois Perrad March 13, 2024, 9:13 a.m. UTC
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/dcron/dcron.mk | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Baruch Siach March 13, 2024, 9:37 a.m. UTC | #1
Hi Francois,

On Wed, Mar 13 2024, Francois Perrad wrote:
> Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
> ---
>  package/dcron/dcron.mk | 5 +++++
>  1 file changed, 5 insertions(+)
>
> diff --git a/package/dcron/dcron.mk b/package/dcron/dcron.mk
> index f0c3efbf8..d4dd48e77 100644
> --- a/package/dcron/dcron.mk
> +++ b/package/dcron/dcron.mk
> @@ -33,4 +33,9 @@ define DCRON_INSTALL_INIT_SYSTEMD
>  		$(TARGET_DIR)/usr/lib/systemd/system/dcron.service
>  endef
>  
> +define DCRON_BUSYBOX_CONFIG_FIXUPS
> +	$(call KCONFIG_DISABLE_OPT,CONFIG_CROND)
> +	$(call KCONFIG_DISABLE_OPT,CONFIG_CRONTAB)
> +endef

Do we still need dcron in BUSYBOX_DEPENDENCIES then?

Same question for other patches in this series.

baruch

> +
>  $(eval $(generic-package))
Francois Perrad March 13, 2024, 6:06 p.m. UTC | #2
Le mer. 13 mars 2024 à 10:48, Baruch Siach via buildroot <
buildroot@buildroot.org> a écrit :

> Hi Francois,
>
> On Wed, Mar 13 2024, Francois Perrad wrote:
> > Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
> > ---
> >  package/dcron/dcron.mk | 5 +++++
> >  1 file changed, 5 insertions(+)
> >
> > diff --git a/package/dcron/dcron.mk b/package/dcron/dcron.mk
> > index f0c3efbf8..d4dd48e77 100644
> > --- a/package/dcron/dcron.mk
> > +++ b/package/dcron/dcron.mk
> > @@ -33,4 +33,9 @@ define DCRON_INSTALL_INIT_SYSTEMD
> >               $(TARGET_DIR)/usr/lib/systemd/system/dcron.service
> >  endef
> >
> > +define DCRON_BUSYBOX_CONFIG_FIXUPS
> > +     $(call KCONFIG_DISABLE_OPT,CONFIG_CROND)
> > +     $(call KCONFIG_DISABLE_OPT,CONFIG_CRONTAB)
> > +endef
>
> Do we still need dcron in BUSYBOX_DEPENDENCIES then?
>
> Same question for other patches in this series.
>
> baruch
>
>
Hi Baruch,

you are right, these kind of dependencies in busybox.mk become useless (the
conflict between the Busybox applet and the full application is gone).

So, I'll remove them in v2.

François



> > +
> >  $(eval $(generic-package))
>
>
> --
>                                                      ~. .~   Tk Open
> Systems
> =}------------------------------------------------ooO--U--Ooo------------{=
>    - baruch@tkos.co.il - tel: +972.52.368.4656, http://www.tkos.co.il -
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
>
diff mbox series

Patch

diff --git a/package/dcron/dcron.mk b/package/dcron/dcron.mk
index f0c3efbf8..d4dd48e77 100644
--- a/package/dcron/dcron.mk
+++ b/package/dcron/dcron.mk
@@ -33,4 +33,9 @@  define DCRON_INSTALL_INIT_SYSTEMD
 		$(TARGET_DIR)/usr/lib/systemd/system/dcron.service
 endef
 
+define DCRON_BUSYBOX_CONFIG_FIXUPS
+	$(call KCONFIG_DISABLE_OPT,CONFIG_CROND)
+	$(call KCONFIG_DISABLE_OPT,CONFIG_CRONTAB)
+endef
+
 $(eval $(generic-package))