diff mbox series

[16/29] package/glib-networking: drop dangling GLIB_NETWORKING_INSTALL_TARGET_OPTS

Message ID 20230101233653.487175-17-ricardo.martincoski@gmail.com
State Accepted
Headers show
Series check-package: warn about symbols not recognized by a package infra | expand

Commit Message

Ricardo Martincoski Jan. 1, 2023, 11:36 p.m. UTC
In 2015, commit "3fe434bf35 glib-networking: specify GIO_MODULE_DIR for
target" correctly used <pkg>_INSTALL_TARGET_OPTS with an autotools
package.

But later on, in 2018, commit "928a72c49f package/glib-networking: bump
version to 2.56.1" changed the package to use the meson infra, that does
not support <pkg>_INSTALL_TARGET_OPTS.

So this symbol is bogus since 2018. Drop it now.

Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
---
Before this patch, 'GIO_MODULE_DIR' cannot be seen in the output of:
make V=1 glib-networking-install-target
---
 package/glib-networking/glib-networking.mk | 2 --
 1 file changed, 2 deletions(-)

Comments

Peter Korsgaard Jan. 4, 2023, 9:55 p.m. UTC | #1
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > In 2015, commit "3fe434bf35 glib-networking: specify GIO_MODULE_DIR for
 > target" correctly used <pkg>_INSTALL_TARGET_OPTS with an autotools
 > package.

 > But later on, in 2018, commit "928a72c49f package/glib-networking: bump
 > version to 2.56.1" changed the package to use the meson infra, that does
 > not support <pkg>_INSTALL_TARGET_OPTS.

 > So this symbol is bogus since 2018. Drop it now.

 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
 > ---
 > Before this patch, 'GIO_MODULE_DIR' cannot be seen in the output of:
 > make V=1 glib-networking-install-target

Committed, thanks.
Peter Korsgaard Jan. 11, 2023, 9:18 a.m. UTC | #2
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > In 2015, commit "3fe434bf35 glib-networking: specify GIO_MODULE_DIR for
 > target" correctly used <pkg>_INSTALL_TARGET_OPTS with an autotools
 > package.

 > But later on, in 2018, commit "928a72c49f package/glib-networking: bump
 > version to 2.56.1" changed the package to use the meson infra, that does
 > not support <pkg>_INSTALL_TARGET_OPTS.

 > So this symbol is bogus since 2018. Drop it now.

 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>

Committed to 2022.11.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/glib-networking/glib-networking.mk b/package/glib-networking/glib-networking.mk
index e8905dfff4..4adc13d39f 100644
--- a/package/glib-networking/glib-networking.mk
+++ b/package/glib-networking/glib-networking.mk
@@ -21,8 +21,6 @@  GLIB_NETWORKING_CONF_OPTS = \
 GLIB_NETWORKING_LICENSE = LGPL-2.0+
 GLIB_NETWORKING_LICENSE_FILES = COPYING
 GLIB_NETWORKING_CPE_ID_VENDOR = gnome
-GLIB_NETWORKING_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) \
-	GIO_MODULE_DIR=/usr/lib/gio/modules install
 
 ifeq ($(BR2_PACKAGE_GNUTLS),y)
 GLIB_NETWORKING_DEPENDENCIES += gnutls