diff mbox series

[13/29] package/checkpolicy: drop bogus CHECKPOLICY_STAGING_CMDS

Message ID 20230101233653.487175-14-ricardo.martincoski@gmail.com
State Accepted
Headers show
Series check-package: warn about symbols not recognized by a package infra | expand

Commit Message

Ricardo Martincoski Jan. 1, 2023, 11:36 p.m. UTC
Commit "b06110621d checkpolicy: allow compiling for target" contains a
typo that prevents installing to staging. It also forgot to enable
CHECKPOLICY_INSTALL_STAGING.

But the package does not install headers or libraries, only ELF and
manual files.
So instead of fixing the install to staging, drop the bogus
CHECKPOLICY_STAGING_CMDS.

Cc: Clayton Shotwell <clayton.shotwell@collins.com>
Cc: Matt Weber <matthew.weber@collins.com>
Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
---
My first try was to fix the install do staging:
+CHECKPOLICY_INSTALL_STAGING = YES
-define CHECKPOLICY_STAGING_CMDS
+define CHECKPOLICY_INSTALL_STAGING_CMDS

But then I notice that the package does not install headers or
libraries, looking at output/build/packages-file-list-staging:
+checkpolicy,./usr/bin/checkmodule
+checkpolicy,./usr/bin/checkpolicy
+checkpolicy,./usr/share/man/man8/checkmodule.8
+checkpolicy,./usr/share/man/man8/checkpolicy.8
+checkpolicy,./usr/share/man/ru/man8/checkmodule.8
+checkpolicy,./usr/share/man/ru/man8/checkpolicy.8
---
 package/checkpolicy/checkpolicy.mk | 5 -----
 1 file changed, 5 deletions(-)

Comments

Peter Korsgaard Jan. 5, 2023, 8:31 a.m. UTC | #1
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > Commit "b06110621d checkpolicy: allow compiling for target" contains a
 > typo that prevents installing to staging. It also forgot to enable
 > CHECKPOLICY_INSTALL_STAGING.

 > But the package does not install headers or libraries, only ELF and
 > manual files.
 > So instead of fixing the install to staging, drop the bogus
 > CHECKPOLICY_STAGING_CMDS.

 > Cc: Clayton Shotwell <clayton.shotwell@collins.com>
 > Cc: Matt Weber <matthew.weber@collins.com>
 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>

Committed, thanks.
Peter Korsgaard Jan. 11, 2023, 9:31 a.m. UTC | #2
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > Commit "b06110621d checkpolicy: allow compiling for target" contains a
 > typo that prevents installing to staging. It also forgot to enable
 > CHECKPOLICY_INSTALL_STAGING.

 > But the package does not install headers or libraries, only ELF and
 > manual files.
 > So instead of fixing the install to staging, drop the bogus
 > CHECKPOLICY_STAGING_CMDS.

 > Cc: Clayton Shotwell <clayton.shotwell@collins.com>
 > Cc: Matt Weber <matthew.weber@collins.com>
 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>

Committed to 2022.11.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/checkpolicy/checkpolicy.mk b/package/checkpolicy/checkpolicy.mk
index af9a58cee8..baf16fb802 100644
--- a/package/checkpolicy/checkpolicy.mk
+++ b/package/checkpolicy/checkpolicy.mk
@@ -20,11 +20,6 @@  define CHECKPOLICY_BUILD_CMDS
 	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(CHECKPOLICY_MAKE_OPTS) DESTDIR=$(STAGING_DIR)
 endef
 
-define CHECKPOLICY_STAGING_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(CHECKPOLICY_MAKE_OPTS) DESTDIR=$(STAGING_DIR) install
-
-endef
-
 define CHECKPOLICY_INSTALL_TARGET_CMDS
 	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(CHECKPOLICY_MAKE_OPTS) DESTDIR=$(TARGET_DIR) install
 endef