diff mbox series

[v8,04/26] package/python-setuptools: revert to last version with functional --build-option

Message ID 20240213211512.3918044-4-james.hilliard1@gmail.com
State Superseded, archived
Headers show
Series [v8,01/26] package/python-poetry-core: new host package | expand

Commit Message

James Hilliard Feb. 13, 2024, 9:14 p.m. UTC
A recent change in setuptools accidentially broke the ability to
pass build_ext args via the --build-option config setting.

Lets downgrade to the last working version for now.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/python-setuptools/python-setuptools.hash | 4 ++--
 package/python-setuptools/python-setuptools.mk   | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

Comments

Marcus Hoffmann Feb. 13, 2024, 11:13 p.m. UTC | #1
Hi James,

On 13.02.24 22:14, James Hilliard wrote:
> A recent change in setuptools accidentially broke the ability to
> pass build_ext args via the --build-option config setting.
> 
> Lets downgrade to the last working version for now.

Do you have a link to a issue here? Is thing acknowledged by upstream, 
is this planned to be fixed?

> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> ---
>   package/python-setuptools/python-setuptools.hash | 4 ++--
>   package/python-setuptools/python-setuptools.mk   | 4 ++--
>   2 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/package/python-setuptools/python-setuptools.hash b/package/python-setuptools/python-setuptools.hash
> index 7f13ac3896..9c971eec11 100644
> --- a/package/python-setuptools/python-setuptools.hash
> +++ b/package/python-setuptools/python-setuptools.hash
> @@ -1,5 +1,5 @@
>   # md5, sha256 from https://pypi.org/pypi/setuptools/json
> -md5  b82de45aaa6b9bb911226660212ebb83  setuptools-69.0.3.tar.gz
> -sha256  be1af57fc409f93647f2e8e4573a142ed38724b8cdd389706a867bb4efcf1e78  setuptools-69.0.3.tar.gz
> +md5  d967ca2ba7f46db887daee2d5c9bd6a2  setuptools-68.2.2.tar.gz
> +sha256  4ac1475276d2f1c48684874089fefcd83bd7162ddaafb81fac866ba0db282a87  setuptools-68.2.2.tar.gz
>   # Locally computed sha256 checksums
>   sha256  86da0f01aeae46348a3c3d465195dc1ceccde79f79e87769a64b8da04b2a4741  LICENSE
> diff --git a/package/python-setuptools/python-setuptools.mk b/package/python-setuptools/python-setuptools.mk
> index 0aea3c6cfa..f26f427ccc 100644
> --- a/package/python-setuptools/python-setuptools.mk
> +++ b/package/python-setuptools/python-setuptools.mk
> @@ -4,9 +4,9 @@
>   #
>   ################################################################################
>   
> -PYTHON_SETUPTOOLS_VERSION = 69.0.3
> +PYTHON_SETUPTOOLS_VERSION = 68.2.2
>   PYTHON_SETUPTOOLS_SOURCE = setuptools-$(PYTHON_SETUPTOOLS_VERSION).tar.gz
> -PYTHON_SETUPTOOLS_SITE = https://files.pythonhosted.org/packages/fc/c9/b146ca195403e0182a374e0ea4dbc69136bad3cd55bc293df496d625d0f7
> +PYTHON_SETUPTOOLS_SITE = https://files.pythonhosted.org/packages/ef/cc/93f7213b2ab5ed383f98ce8020e632ef256b406b8569606c3f160ed8e1c9
>   PYTHON_SETUPTOOLS_LICENSE = MIT
>   PYTHON_SETUPTOOLS_LICENSE_FILES = LICENSE
>   PYTHON_SETUPTOOLS_CPE_ID_VENDOR = python
James Hilliard Feb. 13, 2024, 11:43 p.m. UTC | #2
On Tue, Feb 13, 2024 at 4:14 PM Marcus Hoffmann <buildroot@bubu1.eu> wrote:
>
> Hi James,
>
> On 13.02.24 22:14, James Hilliard wrote:
> > A recent change in setuptools accidentially broke the ability to
> > pass build_ext args via the --build-option config setting.
> >
> > Lets downgrade to the last working version for now.
>
> Do you have a link to a issue here? Is thing acknowledged by upstream,
> is this planned to be fixed?

Yeah, I have a pull request reverting the change that caused this to break:
https://github.com/pypa/setuptools/pull/4218

There's some links/threads there with more info.

>
> >
> > Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> > ---
> >   package/python-setuptools/python-setuptools.hash | 4 ++--
> >   package/python-setuptools/python-setuptools.mk   | 4 ++--
> >   2 files changed, 4 insertions(+), 4 deletions(-)
> >
> > diff --git a/package/python-setuptools/python-setuptools.hash b/package/python-setuptools/python-setuptools.hash
> > index 7f13ac3896..9c971eec11 100644
> > --- a/package/python-setuptools/python-setuptools.hash
> > +++ b/package/python-setuptools/python-setuptools.hash
> > @@ -1,5 +1,5 @@
> >   # md5, sha256 from https://pypi.org/pypi/setuptools/json
> > -md5  b82de45aaa6b9bb911226660212ebb83  setuptools-69.0.3.tar.gz
> > -sha256  be1af57fc409f93647f2e8e4573a142ed38724b8cdd389706a867bb4efcf1e78  setuptools-69.0.3.tar.gz
> > +md5  d967ca2ba7f46db887daee2d5c9bd6a2  setuptools-68.2.2.tar.gz
> > +sha256  4ac1475276d2f1c48684874089fefcd83bd7162ddaafb81fac866ba0db282a87  setuptools-68.2.2.tar.gz
> >   # Locally computed sha256 checksums
> >   sha256  86da0f01aeae46348a3c3d465195dc1ceccde79f79e87769a64b8da04b2a4741  LICENSE
> > diff --git a/package/python-setuptools/python-setuptools.mk b/package/python-setuptools/python-setuptools.mk
> > index 0aea3c6cfa..f26f427ccc 100644
> > --- a/package/python-setuptools/python-setuptools.mk
> > +++ b/package/python-setuptools/python-setuptools.mk
> > @@ -4,9 +4,9 @@
> >   #
> >   ################################################################################
> >
> > -PYTHON_SETUPTOOLS_VERSION = 69.0.3
> > +PYTHON_SETUPTOOLS_VERSION = 68.2.2
> >   PYTHON_SETUPTOOLS_SOURCE = setuptools-$(PYTHON_SETUPTOOLS_VERSION).tar.gz
> > -PYTHON_SETUPTOOLS_SITE = https://files.pythonhosted.org/packages/fc/c9/b146ca195403e0182a374e0ea4dbc69136bad3cd55bc293df496d625d0f7
> > +PYTHON_SETUPTOOLS_SITE = https://files.pythonhosted.org/packages/ef/cc/93f7213b2ab5ed383f98ce8020e632ef256b406b8569606c3f160ed8e1c9
> >   PYTHON_SETUPTOOLS_LICENSE = MIT
> >   PYTHON_SETUPTOOLS_LICENSE_FILES = LICENSE
> >   PYTHON_SETUPTOOLS_CPE_ID_VENDOR = python
Arnout Vandecappelle March 27, 2024, 9:51 p.m. UTC | #3
On 14/02/2024 00:43, James Hilliard wrote:
> On Tue, Feb 13, 2024 at 4:14 PM Marcus Hoffmann <buildroot@bubu1.eu> wrote:
>>
>> Hi James,
>>
>> On 13.02.24 22:14, James Hilliard wrote:
>>> A recent change in setuptools accidentially broke the ability to
>>> pass build_ext args via the --build-option config setting.
>>>
>>> Lets downgrade to the last working version for now.
>>
>> Do you have a link to a issue here? Is thing acknowledged by upstream,
>> is this planned to be fixed?
> 
> Yeah, I have a pull request reverting the change that caused this to break:
> https://github.com/pypa/setuptools/pull/4218
> 
> There's some links/threads there with more info.

  IIUC the situation evolved and we should apply 
https://github.com/pypa/setuptools/pull/4217 instead of doing this revert?

  Regards,
  Arnout

> 
>>
>>>
>>> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
>>> ---
>>>    package/python-setuptools/python-setuptools.hash | 4 ++--
>>>    package/python-setuptools/python-setuptools.mk   | 4 ++--
>>>    2 files changed, 4 insertions(+), 4 deletions(-)
>>>
>>> diff --git a/package/python-setuptools/python-setuptools.hash b/package/python-setuptools/python-setuptools.hash
>>> index 7f13ac3896..9c971eec11 100644
>>> --- a/package/python-setuptools/python-setuptools.hash
>>> +++ b/package/python-setuptools/python-setuptools.hash
>>> @@ -1,5 +1,5 @@
>>>    # md5, sha256 from https://pypi.org/pypi/setuptools/json
>>> -md5  b82de45aaa6b9bb911226660212ebb83  setuptools-69.0.3.tar.gz
>>> -sha256  be1af57fc409f93647f2e8e4573a142ed38724b8cdd389706a867bb4efcf1e78  setuptools-69.0.3.tar.gz
>>> +md5  d967ca2ba7f46db887daee2d5c9bd6a2  setuptools-68.2.2.tar.gz
>>> +sha256  4ac1475276d2f1c48684874089fefcd83bd7162ddaafb81fac866ba0db282a87  setuptools-68.2.2.tar.gz
>>>    # Locally computed sha256 checksums
>>>    sha256  86da0f01aeae46348a3c3d465195dc1ceccde79f79e87769a64b8da04b2a4741  LICENSE
>>> diff --git a/package/python-setuptools/python-setuptools.mk b/package/python-setuptools/python-setuptools.mk
>>> index 0aea3c6cfa..f26f427ccc 100644
>>> --- a/package/python-setuptools/python-setuptools.mk
>>> +++ b/package/python-setuptools/python-setuptools.mk
>>> @@ -4,9 +4,9 @@
>>>    #
>>>    ################################################################################
>>>
>>> -PYTHON_SETUPTOOLS_VERSION = 69.0.3
>>> +PYTHON_SETUPTOOLS_VERSION = 68.2.2
>>>    PYTHON_SETUPTOOLS_SOURCE = setuptools-$(PYTHON_SETUPTOOLS_VERSION).tar.gz
>>> -PYTHON_SETUPTOOLS_SITE = https://files.pythonhosted.org/packages/fc/c9/b146ca195403e0182a374e0ea4dbc69136bad3cd55bc293df496d625d0f7
>>> +PYTHON_SETUPTOOLS_SITE = https://files.pythonhosted.org/packages/ef/cc/93f7213b2ab5ed383f98ce8020e632ef256b406b8569606c3f160ed8e1c9
>>>    PYTHON_SETUPTOOLS_LICENSE = MIT
>>>    PYTHON_SETUPTOOLS_LICENSE_FILES = LICENSE
>>>    PYTHON_SETUPTOOLS_CPE_ID_VENDOR = python
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
James Hilliard March 31, 2024, 12:48 a.m. UTC | #4
On Wed, Mar 27, 2024 at 3:51 PM Arnout Vandecappelle <arnout@mind.be> wrote:
>
>
>
> On 14/02/2024 00:43, James Hilliard wrote:
> > On Tue, Feb 13, 2024 at 4:14 PM Marcus Hoffmann <buildroot@bubu1.eu> wrote:
> >>
> >> Hi James,
> >>
> >> On 13.02.24 22:14, James Hilliard wrote:
> >>> A recent change in setuptools accidentially broke the ability to
> >>> pass build_ext args via the --build-option config setting.
> >>>
> >>> Lets downgrade to the last working version for now.
> >>
> >> Do you have a link to a issue here? Is thing acknowledged by upstream,
> >> is this planned to be fixed?
> >
> > Yeah, I have a pull request reverting the change that caused this to break:
> > https://github.com/pypa/setuptools/pull/4218
> >
> > There's some links/threads there with more info.
>
>   IIUC the situation evolved and we should apply
> https://github.com/pypa/setuptools/pull/4217 instead of doing this revert?

Yeah, I've updated setuptools in my v9, although I did have to tweak how
python-psycopg2 gets passed the pg_config path due to -C--build-option=
now only passing config variables to the bdist_wheel build stage which
appears to be sufficient for all other packages but not python-psycopg2.

https://patchwork.ozlabs.org/project/buildroot/patch/20240331004133.636618-18-james.hilliard1@gmail.com/

>
>
>   Regards,
>   Arnout
>
> >
> >>
> >>>
> >>> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> >>> ---
> >>>    package/python-setuptools/python-setuptools.hash | 4 ++--
> >>>    package/python-setuptools/python-setuptools.mk   | 4 ++--
> >>>    2 files changed, 4 insertions(+), 4 deletions(-)
> >>>
> >>> diff --git a/package/python-setuptools/python-setuptools.hash b/package/python-setuptools/python-setuptools.hash
> >>> index 7f13ac3896..9c971eec11 100644
> >>> --- a/package/python-setuptools/python-setuptools.hash
> >>> +++ b/package/python-setuptools/python-setuptools.hash
> >>> @@ -1,5 +1,5 @@
> >>>    # md5, sha256 from https://pypi.org/pypi/setuptools/json
> >>> -md5  b82de45aaa6b9bb911226660212ebb83  setuptools-69.0.3.tar.gz
> >>> -sha256  be1af57fc409f93647f2e8e4573a142ed38724b8cdd389706a867bb4efcf1e78  setuptools-69.0.3.tar.gz
> >>> +md5  d967ca2ba7f46db887daee2d5c9bd6a2  setuptools-68.2.2.tar.gz
> >>> +sha256  4ac1475276d2f1c48684874089fefcd83bd7162ddaafb81fac866ba0db282a87  setuptools-68.2.2.tar.gz
> >>>    # Locally computed sha256 checksums
> >>>    sha256  86da0f01aeae46348a3c3d465195dc1ceccde79f79e87769a64b8da04b2a4741  LICENSE
> >>> diff --git a/package/python-setuptools/python-setuptools.mk b/package/python-setuptools/python-setuptools.mk
> >>> index 0aea3c6cfa..f26f427ccc 100644
> >>> --- a/package/python-setuptools/python-setuptools.mk
> >>> +++ b/package/python-setuptools/python-setuptools.mk
> >>> @@ -4,9 +4,9 @@
> >>>    #
> >>>    ################################################################################
> >>>
> >>> -PYTHON_SETUPTOOLS_VERSION = 69.0.3
> >>> +PYTHON_SETUPTOOLS_VERSION = 68.2.2
> >>>    PYTHON_SETUPTOOLS_SOURCE = setuptools-$(PYTHON_SETUPTOOLS_VERSION).tar.gz
> >>> -PYTHON_SETUPTOOLS_SITE = https://files.pythonhosted.org/packages/fc/c9/b146ca195403e0182a374e0ea4dbc69136bad3cd55bc293df496d625d0f7
> >>> +PYTHON_SETUPTOOLS_SITE = https://files.pythonhosted.org/packages/ef/cc/93f7213b2ab5ed383f98ce8020e632ef256b406b8569606c3f160ed8e1c9
> >>>    PYTHON_SETUPTOOLS_LICENSE = MIT
> >>>    PYTHON_SETUPTOOLS_LICENSE_FILES = LICENSE
> >>>    PYTHON_SETUPTOOLS_CPE_ID_VENDOR = python
> > _______________________________________________
> > buildroot mailing list
> > buildroot@buildroot.org
> > https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/python-setuptools/python-setuptools.hash b/package/python-setuptools/python-setuptools.hash
index 7f13ac3896..9c971eec11 100644
--- a/package/python-setuptools/python-setuptools.hash
+++ b/package/python-setuptools/python-setuptools.hash
@@ -1,5 +1,5 @@ 
 # md5, sha256 from https://pypi.org/pypi/setuptools/json
-md5  b82de45aaa6b9bb911226660212ebb83  setuptools-69.0.3.tar.gz
-sha256  be1af57fc409f93647f2e8e4573a142ed38724b8cdd389706a867bb4efcf1e78  setuptools-69.0.3.tar.gz
+md5  d967ca2ba7f46db887daee2d5c9bd6a2  setuptools-68.2.2.tar.gz
+sha256  4ac1475276d2f1c48684874089fefcd83bd7162ddaafb81fac866ba0db282a87  setuptools-68.2.2.tar.gz
 # Locally computed sha256 checksums
 sha256  86da0f01aeae46348a3c3d465195dc1ceccde79f79e87769a64b8da04b2a4741  LICENSE
diff --git a/package/python-setuptools/python-setuptools.mk b/package/python-setuptools/python-setuptools.mk
index 0aea3c6cfa..f26f427ccc 100644
--- a/package/python-setuptools/python-setuptools.mk
+++ b/package/python-setuptools/python-setuptools.mk
@@ -4,9 +4,9 @@ 
 #
 ################################################################################
 
-PYTHON_SETUPTOOLS_VERSION = 69.0.3
+PYTHON_SETUPTOOLS_VERSION = 68.2.2
 PYTHON_SETUPTOOLS_SOURCE = setuptools-$(PYTHON_SETUPTOOLS_VERSION).tar.gz
-PYTHON_SETUPTOOLS_SITE = https://files.pythonhosted.org/packages/fc/c9/b146ca195403e0182a374e0ea4dbc69136bad3cd55bc293df496d625d0f7
+PYTHON_SETUPTOOLS_SITE = https://files.pythonhosted.org/packages/ef/cc/93f7213b2ab5ed383f98ce8020e632ef256b406b8569606c3f160ed8e1c9
 PYTHON_SETUPTOOLS_LICENSE = MIT
 PYTHON_SETUPTOOLS_LICENSE_FILES = LICENSE
 PYTHON_SETUPTOOLS_CPE_ID_VENDOR = python