diff mbox series

[v8,19/26] package/python-pylibftdi: migrate to poetry core pep517 build backend

Message ID 20240213211512.3918044-19-james.hilliard1@gmail.com
State Superseded, archived
Headers show
Series [v8,01/26] package/python-poetry-core: new host package | expand

Commit Message

James Hilliard Feb. 13, 2024, 9:15 p.m. UTC
We need to migrate python-pylibftdi to the pep517 poetry-core
backend as setuptools is not supported when building with a pep517
frontend.

This package currently builds using setuptools as we do not yet
use setuptools with a pep517 build frontend. The package contains
a setuptools fallback which only can be used when using setuptools
without a pep517 frontend as the pep517 frontend will only use the
build backend specified in the package pyproject.toml which is
poetry-core and not setuptools.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/python-pylibftdi/python-pylibftdi.mk | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/package/python-pylibftdi/python-pylibftdi.mk b/package/python-pylibftdi/python-pylibftdi.mk
index 7dca37e416..7607c90d4a 100644
--- a/package/python-pylibftdi/python-pylibftdi.mk
+++ b/package/python-pylibftdi/python-pylibftdi.mk
@@ -9,7 +9,9 @@  PYTHON_PYLIBFTDI_SOURCE = pylibftdi-$(PYTHON_PYLIBFTDI_VERSION).tar.gz
 PYTHON_PYLIBFTDI_SITE = https://files.pythonhosted.org/packages/d2/ce/ff3e83f3a14eb5b7950ff3657f07cdc3033dd0ded5c8ed093db515e1de33
 PYTHON_PYLIBFTDI_LICENSE = MIT
 PYTHON_PYLIBFTDI_LICENSE_FILES = LICENSE.txt
-PYTHON_PYLIBFTDI_DEPENDENCIES = libftdi
-PYTHON_PYLIBFTDI_SETUP_TYPE = setuptools
+PYTHON_PYLIBFTDI_SETUP_TYPE = pep517
+PYTHON_PYLIBFTDI_DEPENDENCIES = \
+	host-python-poetry-core \
+	libftdi
 
 $(eval $(python-package))