diff mbox series

[v8,21/26] package/python-rsa: migrate to poetry core pep517 build backend

Message ID 20240213211512.3918044-21-james.hilliard1@gmail.com
State Superseded, archived
Headers show
Series [v8,01/26] package/python-poetry-core: new host package | expand

Commit Message

James Hilliard Feb. 13, 2024, 9:15 p.m. UTC
We need to migrate python-rsa to the pep517 poetry-core
backend as setuptools is not supported when building with a pep517
frontend.

This package currently builds using setuptools as we do not yet
use setuptools with a pep517 build frontend. The package contains
a setuptools fallback which only can be used when using setuptools
without a pep517 frontend as the pep517 frontend will only use the
build backend specified in the package pyproject.toml which is
poetry-core and not setuptools.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/python-rsa/python-rsa.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Raphaël Mélotte Feb. 14, 2024, 3:47 p.m. UTC | #1
Hi James, all

On 2/13/24 22:15, James Hilliard wrote:
> We need to migrate python-rsa to the pep517 poetry-core
> backend as setuptools is not supported when building with a pep517
> frontend.
> 
> This package currently builds using setuptools as we do not yet
> use setuptools with a pep517 build frontend. The package contains
> a setuptools fallback which only can be used when using setuptools
> without a pep517 frontend as the pep517 frontend will only use the
> build backend specified in the package pyproject.toml which is
> poetry-core and not setuptools.
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>

I ran the associated run-tests test on my side (only for python-rsa so far), it looks good to me.

Tested-by: Raphaël Mélotte <raphael.melotte@mind.be>

> ---
>   package/python-rsa/python-rsa.mk | 3 ++-
>   1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/python-rsa/python-rsa.mk b/package/python-rsa/python-rsa.mk
> index d84ba8b431..69a6309b19 100644
> --- a/package/python-rsa/python-rsa.mk
> +++ b/package/python-rsa/python-rsa.mk
> @@ -7,9 +7,10 @@
>   PYTHON_RSA_VERSION = 4.9
>   PYTHON_RSA_SOURCE = rsa-$(PYTHON_RSA_VERSION).tar.gz
>   PYTHON_RSA_SITE = https://files.pythonhosted.org/packages/aa/65/7d973b89c4d2351d7fb232c2e452547ddfa243e93131e7cfa766da627b52
> -PYTHON_RSA_SETUP_TYPE = setuptools
> +PYTHON_RSA_SETUP_TYPE = pep517
>   PYTHON_RSA_LICENSE = Apache-2.0
>   PYTHON_RSA_LICENSE_FILES = LICENSE
>   PYTHON_RSA_CPE_ID_VALID = YES
> +PYTHON_RSA_DEPENDENCIES = host-python-poetry-core
>   
>   $(eval $(python-package))
diff mbox series

Patch

diff --git a/package/python-rsa/python-rsa.mk b/package/python-rsa/python-rsa.mk
index d84ba8b431..69a6309b19 100644
--- a/package/python-rsa/python-rsa.mk
+++ b/package/python-rsa/python-rsa.mk
@@ -7,9 +7,10 @@ 
 PYTHON_RSA_VERSION = 4.9
 PYTHON_RSA_SOURCE = rsa-$(PYTHON_RSA_VERSION).tar.gz
 PYTHON_RSA_SITE = https://files.pythonhosted.org/packages/aa/65/7d973b89c4d2351d7fb232c2e452547ddfa243e93131e7cfa766da627b52
-PYTHON_RSA_SETUP_TYPE = setuptools
+PYTHON_RSA_SETUP_TYPE = pep517
 PYTHON_RSA_LICENSE = Apache-2.0
 PYTHON_RSA_LICENSE_FILES = LICENSE
 PYTHON_RSA_CPE_ID_VALID = YES
+PYTHON_RSA_DEPENDENCIES = host-python-poetry-core
 
 $(eval $(python-package))