diff mbox series

[v8,20/26] package/python-sip: add missing setuptools dependency

Message ID 20240213211512.3918044-20-james.hilliard1@gmail.com
State Superseded, archived
Headers show
Series [v8,01/26] package/python-poetry-core: new host package | expand

Commit Message

James Hilliard Feb. 13, 2024, 9:15 p.m. UTC
The python-sip package requires distutils which is no longer included
with python but is now part of setuptools.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/python-sip/python-sip.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/package/python-sip/python-sip.mk b/package/python-sip/python-sip.mk
index 3e015fa16c..392928f01e 100644
--- a/package/python-sip/python-sip.mk
+++ b/package/python-sip/python-sip.mk
@@ -9,8 +9,8 @@  PYTHON_SIP_SOURCE = sip-$(PYTHON_SIP_VERSION).tar.gz
 PYTHON_SIP_SITE = https://www.riverbankcomputing.com/static/Downloads/sip/$(PYTHON_SIP_VERSION)
 PYTHON_SIP_LICENSE = SIP license or GPL-2.0 or GPL-3.0
 PYTHON_SIP_LICENSE_FILES = LICENSE LICENSE-GPL2 LICENSE-GPL3
-PYTHON_SIP_DEPENDENCIES = python3 qt5base
-HOST_PYTHON_SIP_DEPENDENCIES = host-python3
+PYTHON_SIP_DEPENDENCIES = host-python-setuptools python3 qt5base
+HOST_PYTHON_SIP_DEPENDENCIES = host-python3 host-python-setuptools
 
 define HOST_PYTHON_SIP_CONFIGURE_CMDS
 	(cd $(@D); \