diff mbox series

[01/20] ppp: make copy of compiler_types.h unconditional

Message ID af5c57f86477d2e2af9dbf86dd2eac5db3d8e823.1700010289.git.ehem+openwrt@m5p.com
State Not Applicable
Delegated to: Petr Štetiar
Headers show
Series Kernel build fixups, split object directory off (partial WIP) | expand

Commit Message

Elliott Mitchell Nov. 12, 2023, 6:22 p.m. UTC
04cb1e0fd2 was implemented to avoid failures with kernels before
4.14.9.  At this point OpenWRT no longer supports earlier kernels,
so make the copy fail if compiler_types.h doesn't exist.

Updates: 04cb1e0fd2 ("ppp: fix build with kernel 4.14.9+")
Signed-off-by: Elliott Mitchell <ehem+openwrt@m5p.com>
---
 package/network/services/ppp/Makefile | 6 +-----
 1 file changed, 1 insertion(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/package/network/services/ppp/Makefile b/package/network/services/ppp/Makefile
index 40ec5c5cf1..5f4b8ac02f 100644
--- a/package/network/services/ppp/Makefile
+++ b/package/network/services/ppp/Makefile
@@ -184,13 +184,9 @@  $(call Build/Configure/Default,, \
 	mkdir -p $(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux
 	$(CP) \
 		$(LINUX_DIR)/include/linux/compiler.h \
+		$(LINUX_DIR)/include/linux/compiler_types.h \
 		$(LINUX_DIR)/include/$(LINUX_UAPI_DIR)linux/atm*.h \
 		$(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
-
-	# Kernel 4.14.9+ only, ignore the exit status of cp in case the file
-	# doesn't exits
-	-$(CP) $(LINUX_DIR)/include/linux/compiler_types.h \
-		$(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
 endef
 
 MAKE_FLAGS += COPTS="$(TARGET_CFLAGS)" \