diff mbox series

[05/20] build: merge Kernel/Prepare steps together

Message ID 708427ecc8fbba15cae98fb58a19985ed397e604.1700010290.git.ehem+openwrt@m5p.com
State Not Applicable
Delegated to: Petr Štetiar
Headers show
Series Kernel build fixups, split object directory off (partial WIP) | expand

Commit Message

Elliott Mitchell Nov. 15, 2023, 1:04 a.m. UTC
Date: Mon, 30 Oct 2023 14:46:24 -0700

The two Kernel/Prepare/Default implementations had become identical.
As such merge the identical sections together, and only have the
extra piece be conditional.

Signed-off-by: Elliott Mitchell <ehem+openwrt@m5p.com>
---
 include/kernel-defaults.mk | 12 ++++--------
 1 file changed, 4 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index d9842fd82a..05ec9afe09 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -21,17 +21,13 @@  else
 endif
 
 ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
-  ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
-    define Kernel/Prepare/Default
+  define Kernel/Prepare/Default
 	$(LINUX_CAT) $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
+    ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
 	$(Kernel/Patch)
 	$(if $(QUILT),touch $(LINUX_DIR)/.quilt_used)
-    endef
-  else
-    define Kernel/Prepare/Default
-	$(LINUX_CAT) $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
-    endef
-  endif
+    endif
+  endef
 else
   define Kernel/Prepare/Default
 	mkdir -p $(KERNEL_BUILD_DIR)