diff mbox series

[v4,07/29] package/qt6/qt6base: add support for dbus module

Message ID 20220826135503.20612-8-jesseevg@gmail.com
State Accepted
Headers show
Series Extend Qt6 configuration | expand

Commit Message

Jesse Van Gavere Aug. 26, 2022, 1:54 p.m. UTC
Signed-off-by: Jesse Van Gavere <jesseevg@gmail.com>
---
 package/qt6/qt6base/Config.in  |  8 ++++++++
 package/qt6/qt6base/qt6base.mk | 11 +++++++++++
 2 files changed, 19 insertions(+)

Comments

Thomas Petazzoni Aug. 29, 2022, 8:07 p.m. UTC | #1
On Fri, 26 Aug 2022 15:54:41 +0200
Jesse Van Gavere <jesseevg@gmail.com> wrote:

> Signed-off-by: Jesse Van Gavere <jesseevg@gmail.com>
> ---
>  package/qt6/qt6base/Config.in  |  8 ++++++++
>  package/qt6/qt6base/qt6base.mk | 11 +++++++++++
>  2 files changed, 19 insertions(+)
> 
> diff --git a/package/qt6/qt6base/Config.in b/package/qt6/qt6base/Config.in
> index 354e02280a..2d4a4df223 100644
> --- a/package/qt6/qt6base/Config.in
> +++ b/package/qt6/qt6base/Config.in
> @@ -22,6 +22,14 @@ config BR2_PACKAGE_QT6BASE_CONCURRENT
>  	help
>  	  This options enables the Qt6Concurrent library.
>  
> +config BR2_PACKAGE_QT6BASE_DBUS
> +	bool "DBus module"
> +	depends on BR2_TOOLCHAIN_HAS_THREADS
> +	depends on BR2_USE_MMU
> +	select BR2_PACKAGE_DBUS
> +	help
> +	  This option enables the D-Bus module.
> +
>  config BR2_PACKAGE_QT6BASE_NETWORK
>  	bool "network module"
>  	help
> diff --git a/package/qt6/qt6base/qt6base.mk b/package/qt6/qt6base/qt6base.mk
> index fd1e0a2847..fdb3377eb4 100644
> --- a/package/qt6/qt6base/qt6base.mk
> +++ b/package/qt6/qt6base/qt6base.mk
> @@ -77,6 +77,17 @@ define HOST_QT6BASE_INSTALL_CMDS
>  	$(HOST_MAKE_ENV) $(BR2_CMAKE) --install $(HOST_QT6BASE_BUILDDIR)
>  endef
>  
> +ifeq ($(BR2_PACKAGE_QT6BASE_DBUS),y)
> +QT6BASE_CONF_OPTS += -DFEATURE_dbus=ON
> +QT6BASE_CONF_OPTS += -DINPUT_dbus=linked
> +QT6BASE_DEPENDENCIES += dbus
> +HOST_QT6BASE_CONF_OPTS += -DFEATURE_dbus=ON
> +HOST_QT6BASE_DEPENDENCIES += host-dbus

I've added a comment to explain why this is necessary, and I've applied
to next.

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/qt6/qt6base/Config.in b/package/qt6/qt6base/Config.in
index 354e02280a..2d4a4df223 100644
--- a/package/qt6/qt6base/Config.in
+++ b/package/qt6/qt6base/Config.in
@@ -22,6 +22,14 @@  config BR2_PACKAGE_QT6BASE_CONCURRENT
 	help
 	  This options enables the Qt6Concurrent library.
 
+config BR2_PACKAGE_QT6BASE_DBUS
+	bool "DBus module"
+	depends on BR2_TOOLCHAIN_HAS_THREADS
+	depends on BR2_USE_MMU
+	select BR2_PACKAGE_DBUS
+	help
+	  This option enables the D-Bus module.
+
 config BR2_PACKAGE_QT6BASE_NETWORK
 	bool "network module"
 	help
diff --git a/package/qt6/qt6base/qt6base.mk b/package/qt6/qt6base/qt6base.mk
index fd1e0a2847..fdb3377eb4 100644
--- a/package/qt6/qt6base/qt6base.mk
+++ b/package/qt6/qt6base/qt6base.mk
@@ -77,6 +77,17 @@  define HOST_QT6BASE_INSTALL_CMDS
 	$(HOST_MAKE_ENV) $(BR2_CMAKE) --install $(HOST_QT6BASE_BUILDDIR)
 endef
 
+ifeq ($(BR2_PACKAGE_QT6BASE_DBUS),y)
+QT6BASE_CONF_OPTS += -DFEATURE_dbus=ON
+QT6BASE_CONF_OPTS += -DINPUT_dbus=linked
+QT6BASE_DEPENDENCIES += dbus
+HOST_QT6BASE_CONF_OPTS += -DFEATURE_dbus=ON
+HOST_QT6BASE_DEPENDENCIES += host-dbus
+else
+QT6BASE_CONF_OPTS += -DFEATURE_dbus=OFF
+HOST_QT6BASE_CONF_OPTS += -DFEATURE_dbus=OFF
+endif
+
 ifeq ($(BR2_PACKAGE_QT6BASE_NETWORK),y)
 QT6BASE_CONF_OPTS += -DFEATURE_network=ON
 else