diff mbox series

[v4,12/29] package/qt6/qt6base: add linking to libatomic

Message ID 20220826135503.20612-13-jesseevg@gmail.com
State Rejected
Headers show
Series Extend Qt6 configuration | expand

Commit Message

Jesse Van Gavere Aug. 26, 2022, 1:54 p.m. UTC
This patch might not be necessary for qt6 but I can't find anything
indicating so, Yann E. made the original commit for this on qt5 so
he might be aware of current necessity

Signed-off-by: Jesse Van Gavere <jesseevg@gmail.com>
---
 package/qt6/qt6base/qt6base.mk | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Thomas Petazzoni Sept. 18, 2022, 10:03 a.m. UTC | #1
On Fri, 26 Aug 2022 15:54:46 +0200
Jesse Van Gavere <jesseevg@gmail.com> wrote:

> This patch might not be necessary for qt6 but I can't find anything
> indicating so, Yann E. made the original commit for this on qt5 so
> he might be aware of current necessity

I also imagine that linking with libatomic will be necessary, but
before applying a patch that does this, I would like to have some
actual evidence. There are currently only two build failures for
qt6base in the autobuilders, and they are not related to libatomic
issues.

So for now, I'll mark this patch as Rejected, but we can obviously
revisit if we get a confirmation that it is indeed needed.

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/qt6/qt6base/qt6base.mk b/package/qt6/qt6base/qt6base.mk
index 8bca29900e..c04564d132 100644
--- a/package/qt6/qt6base/qt6base.mk
+++ b/package/qt6/qt6base/qt6base.mk
@@ -151,5 +151,10 @@  else
 QT6BASE_CONF_OPTS += -DFEATURE_syslog=OFF
 endif
 
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+# Qt needs atomics, which on various architectures are in -latomic
+QT6BASE_CONF_OPTS += -DCMAKE_SHARED_LINKER_FLAGS="-latomic"
+endif
+
 $(eval $(cmake-package))
 $(eval $(host-cmake-package))