diff mbox series

[v4,19/29] package/qt6/qt6base: add support for sql module w/ postgresql

Message ID 20220826135503.20612-20-jesseevg@gmail.com
State Accepted
Headers show
Series Extend Qt6 configuration | expand

Commit Message

Jesse Van Gavere Aug. 26, 2022, 1:54 p.m. UTC
Signed-off-by: Jesse Van Gavere <jesseevg@gmail.com>
---
 package/qt6/qt6base/Config.in  | 14 ++++++++++++++
 package/qt6/qt6base/qt6base.mk |  7 +++++++
 2 files changed, 21 insertions(+)

Comments

Thomas Petazzoni Sept. 20, 2022, 6:38 a.m. UTC | #1
On Fri, 26 Aug 2022 15:54:53 +0200
Jesse Van Gavere <jesseevg@gmail.com> wrote:

> Signed-off-by: Jesse Van Gavere <jesseevg@gmail.com>
> ---
>  package/qt6/qt6base/Config.in  | 14 ++++++++++++++
>  package/qt6/qt6base/qt6base.mk |  7 +++++++
>  2 files changed, 21 insertions(+)
> 
> diff --git a/package/qt6/qt6base/Config.in b/package/qt6/qt6base/Config.in
> index 9509fa5be9..79b6d675c5 100644
> --- a/package/qt6/qt6base/Config.in
> +++ b/package/qt6/qt6base/Config.in
> @@ -76,6 +76,20 @@ config BR2_PACKAGE_QT6BASE_MYSQL
>  	  Build MySQL plugin
>  	  If unsure, say n.
>  
> +config BR2_PACKAGE_QT6BASE_PSQL
> +	bool "PostgreSQL Plugin"
> +	depends on BR2_USE_MMU # postgresql
> +	depends on !BR2_STATIC_LIBS
> +	depends on BR2_USE_WCHAR # postgresql

Some dependencies of postgresql were missing, so I updated that.

> +	select BR2_PACKAGE_POSTGRESQL
> +	help
> +	  Build PostgreSQL plugin
> +	  If unsure, say n.

Dropped this line.

> +
> +comment "PostgreSQL plugin needs a toolchain w/ wchar, dynamic library"
> +	depends on BR2_USE_MMU
> +	depends on BR2_STATIC_LIBS || !BR2_USE_WCHAR

Adjusted the comments here to take into account other postgresql
dependencies.

And applied!

Thanks a lot!

Thomas
diff mbox series

Patch

diff --git a/package/qt6/qt6base/Config.in b/package/qt6/qt6base/Config.in
index 9509fa5be9..79b6d675c5 100644
--- a/package/qt6/qt6base/Config.in
+++ b/package/qt6/qt6base/Config.in
@@ -76,6 +76,20 @@  config BR2_PACKAGE_QT6BASE_MYSQL
 	  Build MySQL plugin
 	  If unsure, say n.
 
+config BR2_PACKAGE_QT6BASE_PSQL
+	bool "PostgreSQL Plugin"
+	depends on BR2_USE_MMU # postgresql
+	depends on !BR2_STATIC_LIBS
+	depends on BR2_USE_WCHAR # postgresql
+	select BR2_PACKAGE_POSTGRESQL
+	help
+	  Build PostgreSQL plugin
+	  If unsure, say n.
+
+comment "PostgreSQL plugin needs a toolchain w/ wchar, dynamic library"
+	depends on BR2_USE_MMU
+	depends on BR2_STATIC_LIBS || !BR2_USE_WCHAR
+
 endif
 
 config BR2_PACKAGE_QT6BASE_SYSLOG
diff --git a/package/qt6/qt6base/qt6base.mk b/package/qt6/qt6base/qt6base.mk
index 0061a69c63..3925dee83b 100644
--- a/package/qt6/qt6base/qt6base.mk
+++ b/package/qt6/qt6base/qt6base.mk
@@ -115,6 +115,13 @@  else
 QT6BASE_CONF_OPTS += -DFEATURE_sql_mysql=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_QT6BASE_PSQL),y)
+QT6BASE_CONF_OPTS += -DFEATURE_sql_psql=ON
+QT6BASE_DEPENDENCIES += postgresql
+else
+QT6BASE_CONF_OPTS += -DFEATURE_sql_psql=OFF
+endif
+
 else
 QT6BASE_CONF_OPTS += -DFEATURE_sql=OFF
 endif