diff mbox

[1/1] package/git: fix pcre support

Message ID 20170312121203.8626-1-bernd.kuhls@t-online.de
State Accepted
Headers show

Commit Message

Bernd Kuhls March 12, 2017, 12:12 p.m. UTC
The current code contains some obvious typos.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/git/git.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni March 12, 2017, 1:14 p.m. UTC | #1
Hello,

On Sun, 12 Mar 2017 13:12:03 +0100, Bernd Kuhls wrote:
> The current code contains some obvious typos.
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
>  package/git/git.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Applied to master, thanks. Peter: this is really a bug fix, maybe we
want it for the LTS version?

Thomas
Peter Korsgaard March 13, 2017, 11:26 p.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 > Hello,
 > On Sun, 12 Mar 2017 13:12:03 +0100, Bernd Kuhls wrote:
 >> The current code contains some obvious typos.
 >> 
 >> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
 >> ---
 >> package/git/git.mk | 4 ++--
 >> 1 file changed, 2 insertions(+), 2 deletions(-)

 > Applied to master, thanks. Peter: this is really a bug fix, maybe we
 > want it for the LTS version?

Yes, I agree. Committed to 2017.02.x, thanks.
diff mbox

Patch

diff --git a/package/git/git.mk b/package/git/git.mk
index 1d70924ae..ec606a415 100644
--- a/package/git/git.mk
+++ b/package/git/git.mk
@@ -19,8 +19,8 @@  else
 GIT_CONF_OPTS += --without-openssl
 endif
 
-ifeq ($(BR2_PACKAGE_PERL),y)
-GIT_DEPENDENCIES += perl
+ifeq ($(BR2_PACKAGE_PCRE),y)
+GIT_DEPENDENCIES += pcre
 GIT_CONF_OPTS += --with-libpcre
 else
 GIT_CONF_OPTS += --without-libpcre