diff mbox

[v5,5/8] package/kodi: add support for libudev

Message ID 1468260542-7194-5-git-send-email-bernd.kuhls@t-online.de
State Accepted
Headers show

Commit Message

Bernd Kuhls July 11, 2016, 6:08 p.m. UTC
Most of the times this is not needed because libdrm & mesa3d already
pull in the dependency to udev. Let's add it anyway to make sure that
udev is really used and to document that Kodi makes use of udev.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
v5: initial version in this patch series, fixed typo (Thomas)

 package/kodi/kodi.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Thomas Petazzoni July 17, 2016, 12:48 p.m. UTC | #1
Hello,

On Mon, 11 Jul 2016 20:08:59 +0200, Bernd Kuhls wrote:
> Most of the times this is not needed because libdrm & mesa3d already
> pull in the dependency to udev. Let's add it anyway to make sure that
> udev is really used and to document that Kodi makes use of udev.
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
> v5: initial version in this patch series, fixed typo (Thomas)

Applied to master, thanks.

Thomas
diff mbox

Patch

diff --git a/package/kodi/kodi.mk b/package/kodi/kodi.mk
index da5d1fa..e291947 100644
--- a/package/kodi/kodi.mk
+++ b/package/kodi/kodi.mk
@@ -102,6 +102,13 @@  KODI_CONF_ENV += INCLUDES="-I$(STAGING_DIR)/usr/include/interface/vcos/pthreads
 	LIBS="-lvcos -lvchostif"
 endif
 
+ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
+KODI_DEPENDENCIES += udev
+KODI_CONF_OPTS += --enable-udev
+else
+KODI_CONF_OPTS += --disable-udev
+endif
+
 ifeq ($(BR2_PACKAGE_IMX_VPUWRAP),y)
 KODI_DEPENDENCIES += imx-vpuwrap
 KODI_CONF_OPTS += --enable-codec=imxvpu