diff mbox

[v5,4/8] package/kodi: Add suboption to control unrar support

Message ID 1468260542-7194-4-git-send-email-bernd.kuhls@t-online.de
State Accepted
Headers show

Commit Message

Bernd Kuhls July 11, 2016, 6:08 p.m. UTC
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
v5: no changes
v4: no changes
v3: rebased series, no changes to this patch
v2: rebased series, no changes to this patch

 package/kodi/Config.in | 6 ++++++
 package/kodi/kodi.mk   | 8 ++++++++
 2 files changed, 14 insertions(+)

Comments

Thomas Petazzoni July 17, 2016, 12:36 p.m. UTC | #1
Hello,

On Mon, 11 Jul 2016 20:08:58 +0200, Bernd Kuhls wrote:

> +config BR2_PACKAGE_KODI_NONFREE
> +	bool "nonfree"

Changed to:

	bool "non-free components"

because "nonfree" doesn't mean much.

> +	help
> +	  Enable components with non-compliant licenses.

"non-compliant" doesn't mean anything. non-compliant with what? So I've
changed this to "non-free licenses".

Applied with these changes. Thanks!

Thomas
Bernd Kuhls July 17, 2016, 12:48 p.m. UTC | #2
Hi Thomas,

Am Sun, 17 Jul 2016 14:36:28 +0200 schrieb Thomas Petazzoni:

>> +	help
>> +	  Enable components with non-compliant licenses.

the help text was copied from
https://github.com/xbmc/xbmc/blob/Jarvis/configure.ac#L419

;)

> "non-compliant" doesn't mean anything. non-compliant with what?

I guess they mean non-compliance with GPLv2 under which Kodi is licensed.

Thanks for committing the series!

Regards, Bernd
diff mbox

Patch

diff --git a/package/kodi/Config.in b/package/kodi/Config.in
index a000e79..5e7aa67 100644
--- a/package/kodi/Config.in
+++ b/package/kodi/Config.in
@@ -174,6 +174,12 @@  config BR2_PACKAGE_KODI_LIBNFS
 comment "nfs support needs a toolchain w/ threads support"
 	depends on !(BR2_TOOLCHAIN_HAS_THREADS || BR2_TOOLCHAIN_HAS_NATIVE_RPC)
 
+config BR2_PACKAGE_KODI_NONFREE
+	bool "nonfree"
+	help
+	  Enable components with non-compliant licenses.
+	  This option currently only controls support for RAR archives.
+
 config BR2_PACKAGE_KODI_RTMPDUMP
 	bool "rtmp"
 	select BR2_PACKAGE_RTMPDUMP
diff --git a/package/kodi/kodi.mk b/package/kodi/kodi.mk
index 52593aa..da5d1fa 100644
--- a/package/kodi/kodi.mk
+++ b/package/kodi/kodi.mk
@@ -86,6 +86,14 @@  else
 KODI_CONF_OPTS += --disable-mysql
 endif
 
+ifeq ($(BR2_PACKAGE_KODI_NONFREE),y)
+KODI_CONF_OPTS += --enable-non-free
+KODI_LICENSE := $(KODI_LICENSE), unrar
+KODI_LICENSE_FILES += lib/UnrarXLib/license.txt
+else
+KODI_CONF_OPTS += --disable-non-free
+endif
+
 ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
 KODI_DEPENDENCIES += rpi-userland
 KODI_CONF_OPTS += --with-platform=raspberry-pi --enable-player=omxplayer