diff mbox

[02/47] package/libplatform: new package

Message ID 1437597069-6448-3-git-send-email-bernd.kuhls@t-online.de
State Accepted
Headers show

Commit Message

Bernd Kuhls July 22, 2015, 8:30 p.m. UTC
Needed by libcec 3.x

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/Config.in                  |    1 +
 package/libplatform/Config.in      |    6 ++++++
 package/libplatform/libplatform.mk |   16 ++++++++++++++++
 3 files changed, 23 insertions(+)
 create mode 100644 package/libplatform/Config.in
 create mode 100644 package/libplatform/libplatform.mk

Comments

Yann E. MORIN July 25, 2015, 4:55 p.m. UTC | #1
Bernd, All,

On 2015-07-22 22:30 +0200, Bernd Kuhls spake thusly:
> Needed by libcec 3.x
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[--SNIP--]
> diff --git a/package/libplatform/libplatform.mk b/package/libplatform/libplatform.mk
> new file mode 100644
> index 0000000..77fbcec
> --- /dev/null
> +++ b/package/libplatform/libplatform.mk
> @@ -0,0 +1,16 @@
> +################################################################################
> +#
> +# libplatform
> +#
> +################################################################################
> +
> +LIBPLATFORM_VERSION = 1.0.10
> +LIBPLATFORM_SITE = $(call github,Pulse-Eight,platform,$(LIBPLATFORM_VERSION))
> +LIBPLATFORM_LICENSE = GPLv3+

I could only see references to GPLv2+, not v+

Also, a file is under the PHP-3.0.1 licences: src/util/fstrcmp.c

> +LIBPLATFORM_LICENSE_FILES = COPYING

There's no COPYING file. There's in fact no file with the licensing
information.

> +LIBPLATFORM_INSTALL_STAGING = YES
> +
> +LIBPLATFORM_CONF_OPTS += \
> +	-DCMAKE_MODULE_PATH=$(STAGING_DIR)/usr/lib/kodi

Why do you hard-code the path to the kodi directory? Can't libplatform
be used for anything else?

Regards,
Yann E. MORIN.

> +$(eval $(cmake-package))
> -- 
> 1.7.10.4
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni July 30, 2015, 1:26 p.m. UTC | #2
Dear Bernd Kuhls,

On Wed, 22 Jul 2015 22:30:24 +0200, Bernd Kuhls wrote:
> Needed by libcec 3.x
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
>  package/Config.in                  |    1 +
>  package/libplatform/Config.in      |    6 ++++++
>  package/libplatform/libplatform.mk |   16 ++++++++++++++++
>  3 files changed, 23 insertions(+)
>  create mode 100644 package/libplatform/Config.in
>  create mode 100644 package/libplatform/libplatform.mk

Applied with some changes:

    [Thomas:
      - adjust licensing information: license is not GPLv3+, but GPLv2+
        plus one source file in PHP license v3.01.
      - add proper license files.
      - remove the -DCMAKE_MODULE_PATH=$(STAGING_DIR)/usr/lib/kodi since
        it doesn't seem to be necessary
      - add patch to fix invalid header and library paths in
        platform-config.cmake.]

Thomas
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index f4213b1..16915c0 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1064,6 +1064,7 @@  menu "Other"
 	source "package/liblinear/Config.in"
 	source "package/libnspr/Config.in"
 	source "package/libpfm4/Config.in"
+	source "package/libplatform/Config.in"
 	source "package/libplist/Config.in"
 	source "package/libpthread-stubs/Config.in"
 	source "package/libpthsem/Config.in"
diff --git a/package/libplatform/Config.in b/package/libplatform/Config.in
new file mode 100644
index 0000000..7d275b1
--- /dev/null
+++ b/package/libplatform/Config.in
@@ -0,0 +1,6 @@ 
+config BR2_PACKAGE_LIBPLATFORM
+	bool
+	help
+	  Platform support library used by libCEC and binary add-ons for Kodi
+
+	  https://github.com/Pulse-Eight/platform
diff --git a/package/libplatform/libplatform.mk b/package/libplatform/libplatform.mk
new file mode 100644
index 0000000..77fbcec
--- /dev/null
+++ b/package/libplatform/libplatform.mk
@@ -0,0 +1,16 @@ 
+################################################################################
+#
+# libplatform
+#
+################################################################################
+
+LIBPLATFORM_VERSION = 1.0.10
+LIBPLATFORM_SITE = $(call github,Pulse-Eight,platform,$(LIBPLATFORM_VERSION))
+LIBPLATFORM_LICENSE = GPLv3+
+LIBPLATFORM_LICENSE_FILES = COPYING
+LIBPLATFORM_INSTALL_STAGING = YES
+
+LIBPLATFORM_CONF_OPTS += \
+	-DCMAKE_MODULE_PATH=$(STAGING_DIR)/usr/lib/kodi
+
+$(eval $(cmake-package))