@@ -19,7 +19,7 @@ PKG_FLAGS:=nonshared
# Perf's makefile and headers are not relocatable and must be built from the
# Linux sources directory
-PKG_BUILD_DIR:=$(LINUX_DIR)/tools/perf-$(TARGET_DIR_NAME)
+PKG_BUILD_DIR:=$(LINUX_OBJ_DIR)/tools/perf-$(TARGET_DIR_NAME)
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
@@ -70,7 +70,7 @@ MAKE_FLAGS = \
define Build/Compile
+$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \
--no-print-directory \
- -C $(LINUX_DIR)/tools/perf
+ -C $(LINUX_SRC_DIR)/tools/perf
endef
define Package/perf/install
@@ -274,9 +274,9 @@ ifeq ($(BUILD_VARIANT),smallbuffers)
endif
MAKE_OPTS:= \
- $(subst -C $(LINUX_DIR),-C "$(PKG_BUILD_DIR)",$(KERNEL_MAKEOPTS)) \
+ $(subst -C $(LINUX_SRC_DIR),-C "$(PKG_BUILD_DIR)",$(KERNEL_MAKEOPTS)) \
EXTRA_CFLAGS="-I$(PKG_BUILD_DIR)/include $(IREMAP_CFLAGS) $(C_DEFINES)" \
- KLIB_BUILD="$(LINUX_DIR)" \
+ KLIB_BUILD="$(LINUX_OBJ_DIR)" \
MODPROBE=true \
KLIB=$(TARGET_MODULES_DIR) \
KERNEL_SUBLEVEL=$(lastword $(subst ., ,$(KERNEL_PATCHVER))) \
Identifying which variable to substitute in appropriate places is a bit interesting here. Since these set their own make flags, they need to reference both. Signed-off-by: Elliott Mitchell <ehem+openwrt@m5p.com> --- I'm less than certain about perf. I *hope* this matches the requirements, but I'm worried about the comment. --- package/devel/perf/Makefile | 4 ++-- package/kernel/mac80211/Makefile | 4 ++-- 2 files changed, 4 insertions(+), 4 deletions(-)