diff mbox series

[20/20,TEST] TESTING: try separating build from sources

Message ID 3c39ec02c837eacd2f5fcda0c14e8a39c7e0a1ab.1700010295.git.ehem+openwrt@m5p.com
State Not Applicable
Delegated to: Petr Štetiar
Headers show
Series Kernel build fixups, split object directory off (partial WIP) | expand

Commit Message

Elliott Mitchell Nov. 12, 2023, 9:28 p.m. UTC
Check whether all the spots have been handled.  This hasn't been tried
in a long while, I doubt I've got everything right.

Signed-off-by: Elliott Mitchell <ehem+openwrt@m5p.com>
---
 include/kernel.mk | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

Comments

Elliott Mitchell Nov. 17, 2023, 12:34 a.m. UTC | #1
In case anyone was wondering, the later patches are marked "WIP" since
they hadn't been sufficiently tested.

I had run into this a bit ago, but hadn't tracked down the issue.  Now
that I have, another patch is attached to this message.  This is an
outright bug in the patch and should be fixed.
diff mbox series

Patch

diff --git a/include/kernel.mk b/include/kernel.mk
index 7f236ece45..4afc9eaf4e 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -44,11 +44,10 @@  else
     FILES_DIR ?= $(foreach dir,$(wildcard $(CURDIR)/files $(CURDIR)/files-$(KERNEL_PATCHVER)),"$(dir)")
   endif
   KERNEL_BUILD_DIR ?= $(BUILD_DIR)/linux-$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET))
-  LINUX_DIR ?= $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
   # Location of kernel source files
-  LINUX_SRC_DIR ?= $(LINUX_DIR)
+  LINUX_SRC_DIR ?= $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
   # Location of kernel object files
-  LINUX_OBJ_DIR ?= $(LINUX_DIR)
+  LINUX_OBJ_DIR ?= $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)-$(PROFILE)
   LINUX_UAPI_DIR=uapi/
   LINUX_VERMAGIC:=$(strip $(shell cat $(LINUX_OBJ_DIR)/.vermagic 2>/dev/null))
   LINUX_VERMAGIC:=$(if $(LINUX_VERMAGIC),$(LINUX_VERMAGIC),unknown)