diff mbox series

[18/20,WIP] build: point remaining obvious cases at $(LINUX_SRC_DIR)

Message ID ced6e694a8259d64d6ca9ed3263448808f1990cc.1700010294.git.ehem+openwrt@m5p.com
State Not Applicable
Delegated to: Petr Štetiar
Headers show
Series Kernel build fixups, split object directory off (partial WIP) | expand

Commit Message

Elliott Mitchell Nov. 12, 2023, 6:51 a.m. UTC
make -C is most often needs the kernel source.  The copyright files
come from the kernel source.

Signed-off-by: Elliott Mitchell <ehem+openwrt@m5p.com>
---
I'm running out of steam on this.  These seem fairly clear, but I'm
less than 100% certain.
---
 package/devel/kselftests-bpf/Makefile       | 2 +-
 package/kernel/broadcom-wl/Makefile         | 2 +-
 package/kernel/lantiq/ltq-adsl-mei/Makefile | 2 +-
 package/kernel/lantiq/ltq-atm/Makefile      | 2 +-
 package/kernel/lantiq/ltq-deu/Makefile      | 2 +-
 package/kernel/lantiq/ltq-ptm/Makefile      | 2 +-
 package/kernel/qca-nss-dp/Makefile          | 2 +-
 target/linux/bcm27xx/image/Makefile         | 2 +-
 target/linux/rockchip/image/Makefile        | 2 +-
 9 files changed, 9 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/package/devel/kselftests-bpf/Makefile b/package/devel/kselftests-bpf/Makefile
index bb34f0ff5f..ccb5aee465 100644
--- a/package/devel/kselftests-bpf/Makefile
+++ b/package/devel/kselftests-bpf/Makefile
@@ -51,7 +51,7 @@  MAKE_FLAGS = \
 
 define Build/Compile
 	+$(MAKE_VARS) \
-	$(MAKE) $(PKG_JOBS) -C $(LINUX_DIR)/$(MAKE_PATH) \
+	$(MAKE) $(PKG_JOBS) -C $(LINUX_SRC_DIR)/$(MAKE_PATH) \
 		$(MAKE_FLAGS) $(TEST_TARGET) ;
 endef
 
diff --git a/package/kernel/broadcom-wl/Makefile b/package/kernel/broadcom-wl/Makefile
index a1feacbe29..51aa5496ec 100644
--- a/package/kernel/broadcom-wl/Makefile
+++ b/package/kernel/broadcom-wl/Makefile
@@ -120,7 +120,7 @@  endef
 
 define Build/Compile
 	# Compile glue driver
-	$(MAKE_KMOD) -C "$(LINUX_DIR)" \
+	$(MAKE_KMOD) -C "$(LINUX_SRC_DIR)" \
 		M="$(PKG_BUILD_DIR)/glue" \
 		modules
 
diff --git a/package/kernel/lantiq/ltq-adsl-mei/Makefile b/package/kernel/lantiq/ltq-adsl-mei/Makefile
index e9db785960..647e449e11 100644
--- a/package/kernel/lantiq/ltq-adsl-mei/Makefile
+++ b/package/kernel/lantiq/ltq-adsl-mei/Makefile
@@ -35,7 +35,7 @@  endef
 
 define Build/Compile
 	ARCH=mips CROSS_COMPILE="$(KERNEL_CROSS)" \
-	$(MAKE) -C $(LINUX_DIR) BUILD_VARIANT=$(BUILD_VARIANT) M=$(PKG_BUILD_DIR)/ V=1 modules
+	$(MAKE) -C $(LINUX_SRC_DIR) BUILD_VARIANT=$(BUILD_VARIANT) M=$(PKG_BUILD_DIR)/ V=1 modules
 endef
 
 $(eval $(call KernelPackage,ltq-adsl-danube-mei))
diff --git a/package/kernel/lantiq/ltq-atm/Makefile b/package/kernel/lantiq/ltq-atm/Makefile
index af852e9a01..d3a34493d0 100644
--- a/package/kernel/lantiq/ltq-atm/Makefile
+++ b/package/kernel/lantiq/ltq-atm/Makefile
@@ -40,7 +40,7 @@  endef
 
 define Build/Compile
 	ARCH=mips CROSS_COMPILE="$(KERNEL_CROSS)" \
-	$(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKE_FLAGS) BUILD_VARIANT=$(BUILD_VARIANT) M=$(PKG_BUILD_DIR) V=1 modules
+	$(MAKE) -C $(LINUX_SRC_DIR) $(KERNEL_MAKE_FLAGS) BUILD_VARIANT=$(BUILD_VARIANT) M=$(PKG_BUILD_DIR) V=1 modules
 endef
 
 $(eval $(call KernelPackage,ltq-atm-danube))
diff --git a/package/kernel/lantiq/ltq-deu/Makefile b/package/kernel/lantiq/ltq-deu/Makefile
index 4b8fae2766..5c151245bd 100644
--- a/package/kernel/lantiq/ltq-deu/Makefile
+++ b/package/kernel/lantiq/ltq-deu/Makefile
@@ -35,7 +35,7 @@  endef
 
 define Build/Compile
 	ARCH=mips CROSS_COMPILE="$(KERNEL_CROSS)" \
-	$(MAKE) -C $(LINUX_DIR) BUILD_VARIANT=$(BUILD_VARIANT) M=$(PKG_BUILD_DIR) V=1 modules
+	$(MAKE) -C $(LINUX_SRC_DIR) BUILD_VARIANT=$(BUILD_VARIANT) M=$(PKG_BUILD_DIR) V=1 modules
 endef
 
 $(eval $(call KernelPackage,ltq-deu-danube))
diff --git a/package/kernel/lantiq/ltq-ptm/Makefile b/package/kernel/lantiq/ltq-ptm/Makefile
index a1fb2250d2..6d7ba98086 100644
--- a/package/kernel/lantiq/ltq-ptm/Makefile
+++ b/package/kernel/lantiq/ltq-ptm/Makefile
@@ -44,7 +44,7 @@  endef
 
 define Build/Compile
 	ARCH=mips CROSS_COMPILE="$(KERNEL_CROSS)" \
-	$(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKE_FLAGS) BUILD_VARIANT=$(BUILD_VARIANT) M=$(PKG_BUILD_DIR) V=1 modules
+	$(MAKE) -C $(LINUX_SRC_DIR) $(KERNEL_MAKE_FLAGS) BUILD_VARIANT=$(BUILD_VARIANT) M=$(PKG_BUILD_DIR) V=1 modules
 endef
 
 $(eval $(call KernelPackage,ltq-ptm-danube))
diff --git a/package/kernel/qca-nss-dp/Makefile b/package/kernel/qca-nss-dp/Makefile
index f9e992f246..e55cdc61e8 100644
--- a/package/kernel/qca-nss-dp/Makefile
+++ b/package/kernel/qca-nss-dp/Makefile
@@ -45,7 +45,7 @@  endef
 
 define Build/Compile
 	+$(KERNEL_MAKE) $(PKG_JOBS) \
-		-C "$(LINUX_DIR)" \
+		-C "$(LINUX_SRC_DIR)" \
 		M="$(PKG_BUILD_DIR)" \
 		EXTRA_CFLAGS="$(EXTRA_CFLAGS)" SoC="$(CONFIG_TARGET_SUBTARGET)" \
 		modules
diff --git a/target/linux/bcm27xx/image/Makefile b/target/linux/bcm27xx/image/Makefile
index 7fcb78c8f7..fa0633095b 100644
--- a/target/linux/bcm27xx/image/Makefile
+++ b/target/linux/bcm27xx/image/Makefile
@@ -10,7 +10,7 @@  FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_TARGET_KERNEL_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
 define Build/Compile
-	$(CP) $(LINUX_DIR)/COPYING $(KDIR)/COPYING.linux
+	$(CP) $(LINUX_SRC_DIR)/COPYING $(KDIR)/COPYING.linux
 endef
 
 ### Image scripts ###
diff --git a/target/linux/rockchip/image/Makefile b/target/linux/rockchip/image/Makefile
index e7fe7178a6..0fedee33a4 100644
--- a/target/linux/rockchip/image/Makefile
+++ b/target/linux/rockchip/image/Makefile
@@ -6,7 +6,7 @@  include $(INCLUDE_DIR)/image.mk
 DEVICE_VARS += UBOOT_DEVICE_NAME
 
 define Build/Compile
-	$(CP) $(LINUX_DIR)/COPYING $(KDIR)/COPYING.linux
+	$(CP) $(LINUX_SRC_DIR)/COPYING $(KDIR)/COPYING.linux
 endef
 
 ### Image scripts ###