diff mbox series

[4/4] boot/opensbi: update condition for custom tarball management

Message ID 20220623140028.1315712-4-kory.maincent@bootlin.com
State Accepted
Headers show
Series [1/4] boot/arm-trusted-firmware: update condition for custom tarball management | expand

Commit Message

Kory Maincent June 23, 2022, 2 p.m. UTC
From: Kory Maincent <kory.maincent@bootlin.com>

This patch updates the condition to handle custom tarballs as specified by
the configuration. This change is made to have cleaner condition and for
consistency.

Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>
---
 boot/opensbi/opensbi.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/boot/opensbi/opensbi.mk b/boot/opensbi/opensbi.mk
index 8e055633a8..01f0c3ad40 100644
--- a/boot/opensbi/opensbi.mk
+++ b/boot/opensbi/opensbi.mk
@@ -6,7 +6,7 @@ 
 
 OPENSBI_VERSION = $(call qstrip,$(BR2_TARGET_OPENSBI_VERSION))
 
-ifeq ($(OPENSBI_VERSION),custom)
+ifeq ($(BR2_TARGET_OPENSBI_CUSTOM_TARBALL),y)
 # Handle custom OpenSBI tarballs as specified by the configuration
 OPENSBI_TARBALL = $(call qstrip,$(BR2_TARGET_OPENSBI_CUSTOM_TARBALL_LOCATION))
 OPENSBI_SITE = $(patsubst %/,%,$(dir $(OPENSBI_TARBALL)))