diff mbox series

[3/4] boot/barebox: update condition for custom tarball management

Message ID 20220623140028.1315712-3-kory.maincent@bootlin.com
State Accepted
Headers show
Series [1/4] boot/arm-trusted-firmware: update condition for custom tarball management | expand

Commit Message

Köry Maincent June 23, 2022, 2 p.m. UTC
From: Kory Maincent <kory.maincent@bootlin.com>

This patch updates the condition to handle custom tarballs as specified by
the configuration. This change is made to have cleaner condition and for
consistency.

Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>
---
 boot/barebox/barebox.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index 6506294d6d..da151d3c25 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -17,7 +17,7 @@  define inner-barebox-package
 
 $(1)_VERSION = $$(call qstrip,$$(BR2_TARGET_BAREBOX_VERSION))
 
-ifeq ($$($(1)_VERSION),custom)
+ifeq ($$(BR2_TARGET_BAREBOX_CUSTOM_TARBALL),y)
 # Handle custom Barebox tarballs as specified by the configuration
 $(1)_TARBALL = $$(call qstrip,$$(BR2_TARGET_BAREBOX_CUSTOM_TARBALL_LOCATION))
 $(1)_SITE = $$(patsubst %/,%,$$(dir $$($(1)_TARBALL)))