diff mbox series

[1/4] boot/arm-trusted-firmware: update condition for custom tarball management

Message ID 20220623140028.1315712-1-kory.maincent@bootlin.com
State Accepted
Headers show
Series [1/4] boot/arm-trusted-firmware: update condition for custom tarball management | expand

Commit Message

Kory Maincent June 23, 2022, 2 p.m. UTC
From: Kory Maincent <kory.maincent@bootlin.com>

This patch updates the condition to handle custom tarballs as specified by
the configuration. This change is made to have cleaner condition and for
consistency.

Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>
---

Notes:
    This patch is based on this other one:
    https://lists.buildroot.org/pipermail/buildroot/2022-June/645216.html

 boot/arm-trusted-firmware/arm-trusted-firmware.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN July 23, 2022, 8:12 p.m. UTC | #1
Köry, All,

On 2022-06-23 16:00 +0200, Kory Maincent via buildroot spake thusly:
> From: Kory Maincent <kory.maincent@bootlin.com>
> 
> This patch updates the condition to handle custom tarballs as specified by
> the configuration. This change is made to have cleaner condition and for
> consistency.
> 
> Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>

Series of 4 patches applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
> 
> Notes:
>     This patch is based on this other one:
>     https://lists.buildroot.org/pipermail/buildroot/2022-June/645216.html
> 
>  boot/arm-trusted-firmware/arm-trusted-firmware.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/boot/arm-trusted-firmware/arm-trusted-firmware.mk b/boot/arm-trusted-firmware/arm-trusted-firmware.mk
> index 965b1a2eb5..421d8c770d 100644
> --- a/boot/arm-trusted-firmware/arm-trusted-firmware.mk
> +++ b/boot/arm-trusted-firmware/arm-trusted-firmware.mk
> @@ -6,7 +6,7 @@
>  
>  ARM_TRUSTED_FIRMWARE_VERSION = $(call qstrip,$(BR2_TARGET_ARM_TRUSTED_FIRMWARE_VERSION))
>  
> -ifeq ($(ARM_TRUSTED_FIRMWARE_VERSION),custom)
> +ifeq ($(BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_TARBALL),y)
>  # Handle custom ATF tarballs as specified by the configuration
>  ARM_TRUSTED_FIRMWARE_TARBALL = $(call qstrip,$(BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_TARBALL_LOCATION))
>  ARM_TRUSTED_FIRMWARE_SITE = $(patsubst %/,%,$(dir $(ARM_TRUSTED_FIRMWARE_TARBALL)))
> @@ -190,7 +190,7 @@ endef
>  # Configuration check
>  ifeq ($(BR2_TARGET_ARM_TRUSTED_FIRMWARE)$(BR_BUILDING),yy)
>  
> -ifeq ($(ARM_TRUSTED_FIRMWARE_VERSION),custom)
> +ifeq ($(BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_TARBALL),y)
>  ifeq ($(call qstrip,$(BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_TARBALL_LOCATION)),)
>  $(error No tarball location specified. Please check BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_TARBALL_LOCATION)
>  endif
> -- 
> 2.25.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/boot/arm-trusted-firmware/arm-trusted-firmware.mk b/boot/arm-trusted-firmware/arm-trusted-firmware.mk
index 965b1a2eb5..421d8c770d 100644
--- a/boot/arm-trusted-firmware/arm-trusted-firmware.mk
+++ b/boot/arm-trusted-firmware/arm-trusted-firmware.mk
@@ -6,7 +6,7 @@ 
 
 ARM_TRUSTED_FIRMWARE_VERSION = $(call qstrip,$(BR2_TARGET_ARM_TRUSTED_FIRMWARE_VERSION))
 
-ifeq ($(ARM_TRUSTED_FIRMWARE_VERSION),custom)
+ifeq ($(BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_TARBALL),y)
 # Handle custom ATF tarballs as specified by the configuration
 ARM_TRUSTED_FIRMWARE_TARBALL = $(call qstrip,$(BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_TARBALL_LOCATION))
 ARM_TRUSTED_FIRMWARE_SITE = $(patsubst %/,%,$(dir $(ARM_TRUSTED_FIRMWARE_TARBALL)))
@@ -190,7 +190,7 @@  endef
 # Configuration check
 ifeq ($(BR2_TARGET_ARM_TRUSTED_FIRMWARE)$(BR_BUILDING),yy)
 
-ifeq ($(ARM_TRUSTED_FIRMWARE_VERSION),custom)
+ifeq ($(BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_TARBALL),y)
 ifeq ($(call qstrip,$(BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_TARBALL_LOCATION)),)
 $(error No tarball location specified. Please check BR2_TARGET_ARM_TRUSTED_FIRMWARE_CUSTOM_TARBALL_LOCATION)
 endif