diff mbox series

[2/2,v2] package/asterisk: bump to 20.6.0

Message ID Zb0RQA8kV+RXOd0h@waldemar-brodkorb.de
State New
Headers show
Series [1/2,v2] package/libjwt: new package | expand

Commit Message

Waldemar Brodkorb Feb. 2, 2024, 3:58 p.m. UTC
See here for changes:
https://downloads.asterisk.org/pub/telephony/asterisk/ChangeLog-20-current.md

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
---
v1->v2:
 - use separate libjwt package instead of bundled one, suggested by
   Peter Korsgaard
---
 package/asterisk/Config.in     | 1 +
 package/asterisk/asterisk.hash | 2 +-
 package/asterisk/asterisk.mk   | 6 ++++--
 3 files changed, 6 insertions(+), 3 deletions(-)

Comments

Peter Korsgaard Feb. 3, 2024, 10:31 a.m. UTC | #1
>>>>> "Waldemar" == Waldemar Brodkorb <wbx@openadk.org> writes:

 > See here for changes:
 > https://downloads.asterisk.org/pub/telephony/asterisk/ChangeLog-20-current.md

 > Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
 > ---
 v1-> v2:
 >  - use separate libjwt package instead of bundled one, suggested by
 >    Peter Korsgaard
 > ---
 >  package/asterisk/Config.in     | 1 +
 >  package/asterisk/asterisk.hash | 2 +-
 >  package/asterisk/asterisk.mk   | 6 ++++--
 >  3 files changed, 6 insertions(+), 3 deletions(-)

 > diff --git a/package/asterisk/Config.in b/package/asterisk/Config.in
 > index c52456f8fc..662f070dac 100644
 > --- a/package/asterisk/Config.in
 > +++ b/package/asterisk/Config.in
 > @@ -10,6 +10,7 @@ config BR2_PACKAGE_ASTERISK
 >  	select BR2_PACKAGE_LIBCURL
 >  	select BR2_PACKAGE_LIBEDIT
 >  	select BR2_PACKAGE_LIBILBC
 > +	select BR2_PACKAGE_LIBJWT
 >  	select BR2_PACKAGE_LIBXML2
 >  	select BR2_PACKAGE_SQLITE
 >  	select BR2_PACKAGE_UTIL_LINUX
 > diff --git a/package/asterisk/asterisk.hash b/package/asterisk/asterisk.hash
 > index 246f4219aa..d50955dd2b 100644
 > --- a/package/asterisk/asterisk.hash
 > +++ b/package/asterisk/asterisk.hash
 > @@ -1,5 +1,5 @@
 >  # Locally computed
 > -sha256  9def260ac8745a5eac7aceabe1c22f84a283b7812f0eccd760f87ce9eb991d22  asterisk-20.5.2.tar.gz
 > +sha256  088dbc08916e21528dba364f5452b2090b066dbba4548b32ec10af138d4b442f  asterisk-20.6.0.tar.gz
 
 >  # sha1 from: http://downloads.asterisk.org/pub/telephony/sounds/releases
 >  # sha256 locally computed
 > diff --git a/package/asterisk/asterisk.mk b/package/asterisk/asterisk.mk
 > index d1f3ea82d3..869e4128ff 100644
 > --- a/package/asterisk/asterisk.mk
 > +++ b/package/asterisk/asterisk.mk
 > @@ -4,7 +4,7 @@
 >  #
 >  ################################################################################
 
 > -ASTERISK_VERSION = 20.5.2
 > +ASTERISK_VERSION = 20.6.0
 >  # Use the github mirror: it's an official mirror maintained by Digium, and
 >  # provides tarballs, which the main Asterisk git tree (behind Gerrit) does not.
 >  ASTERISK_SITE = $(call github,asterisk,asterisk,$(ASTERISK_VERSION))
 > @@ -27,7 +27,7 @@ ASTERISK_SELINUX_MODULES = asterisk
 
 >  # For patches 0002 and 0003
 >  ASTERISK_AUTORECONF = YES
 > -ASTERISK_AUTORECONF_OPTS = -Iautoconf -Ithird-party -Ithird-party/pjproject -Ithird-party/jansson
 > +ASTERISK_AUTORECONF_OPTS = -Iautoconf -Ithird-party -Ithird-party/pjproject -Ithird-party/jansson -Ithird-party/libjwt

Why do we still need to point autoreconf to the bundle libjwt?

Even worse, I see the following during the configure step:

checking for embedded pjproject (may have to download)... configuring
[pjproject]  Downloading https://raw.githubusercontent.com/asterisk/third-party/master/pjproject/2.13.1/pjproject-2.13.1.tar.bz2 to /tmp/pjproject-2.13.1.tar.bz2
[pjproject]  Verifying /tmp/pjproject-2.13.1.tar.bz2
[pjproject]  Verify successful
[pjproject]  Verifying /tmp/pjproject-2.13.1.tar.bz2
[pjproject]  Verify successful
[pjproject]  Unpacking /tmp/pjproject-2.13.1.tar.bz2

We don't want packages to download stuff behind our back. Can we use an
external pjproject?
Waldemar Brodkorb Feb. 4, 2024, 7:40 a.m. UTC | #2
Hi Peter,
Peter Korsgaard wrote,

> >>>>> "Waldemar" == Waldemar Brodkorb <wbx@openadk.org> writes:
> 
>  > See here for changes:
>  > https://downloads.asterisk.org/pub/telephony/asterisk/ChangeLog-20-current.md
> 
>  > Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
>  > ---
>  v1-> v2:
>  >  - use separate libjwt package instead of bundled one, suggested by
>  >    Peter Korsgaard
>  > ---
>  >  package/asterisk/Config.in     | 1 +
>  >  package/asterisk/asterisk.hash | 2 +-
>  >  package/asterisk/asterisk.mk   | 6 ++++--
>  >  3 files changed, 6 insertions(+), 3 deletions(-)
> 
>  > diff --git a/package/asterisk/Config.in b/package/asterisk/Config.in
>  > index c52456f8fc..662f070dac 100644
>  > --- a/package/asterisk/Config.in
>  > +++ b/package/asterisk/Config.in
>  > @@ -10,6 +10,7 @@ config BR2_PACKAGE_ASTERISK
>  >  	select BR2_PACKAGE_LIBCURL
>  >  	select BR2_PACKAGE_LIBEDIT
>  >  	select BR2_PACKAGE_LIBILBC
>  > +	select BR2_PACKAGE_LIBJWT
>  >  	select BR2_PACKAGE_LIBXML2
>  >  	select BR2_PACKAGE_SQLITE
>  >  	select BR2_PACKAGE_UTIL_LINUX
>  > diff --git a/package/asterisk/asterisk.hash b/package/asterisk/asterisk.hash
>  > index 246f4219aa..d50955dd2b 100644
>  > --- a/package/asterisk/asterisk.hash
>  > +++ b/package/asterisk/asterisk.hash
>  > @@ -1,5 +1,5 @@
>  >  # Locally computed
>  > -sha256  9def260ac8745a5eac7aceabe1c22f84a283b7812f0eccd760f87ce9eb991d22  asterisk-20.5.2.tar.gz
>  > +sha256  088dbc08916e21528dba364f5452b2090b066dbba4548b32ec10af138d4b442f  asterisk-20.6.0.tar.gz
>  
>  >  # sha1 from: http://downloads.asterisk.org/pub/telephony/sounds/releases
>  >  # sha256 locally computed
>  > diff --git a/package/asterisk/asterisk.mk b/package/asterisk/asterisk.mk
>  > index d1f3ea82d3..869e4128ff 100644
>  > --- a/package/asterisk/asterisk.mk
>  > +++ b/package/asterisk/asterisk.mk
>  > @@ -4,7 +4,7 @@
>  >  #
>  >  ################################################################################
>  
>  > -ASTERISK_VERSION = 20.5.2
>  > +ASTERISK_VERSION = 20.6.0
>  >  # Use the github mirror: it's an official mirror maintained by Digium, and
>  >  # provides tarballs, which the main Asterisk git tree (behind Gerrit) does not.
>  >  ASTERISK_SITE = $(call github,asterisk,asterisk,$(ASTERISK_VERSION))
>  > @@ -27,7 +27,7 @@ ASTERISK_SELINUX_MODULES = asterisk
>  
>  >  # For patches 0002 and 0003
>  >  ASTERISK_AUTORECONF = YES
>  > -ASTERISK_AUTORECONF_OPTS = -Iautoconf -Ithird-party -Ithird-party/pjproject -Ithird-party/jansson
>  > +ASTERISK_AUTORECONF_OPTS = -Iautoconf -Ithird-party -Ithird-party/pjproject -Ithird-party/jansson -Ithird-party/libjwt
> 
> Why do we still need to point autoreconf to the bundle libjwt?

Otherwise the generated configure does not work.
 
> Even worse, I see the following during the configure step:
> 
> checking for embedded pjproject (may have to download)... configuring
> [pjproject]  Downloading https://raw.githubusercontent.com/asterisk/third-party/master/pjproject/2.13.1/pjproject-2.13.1.tar.bz2 to /tmp/pjproject-2.13.1.tar.bz2
> [pjproject]  Verifying /tmp/pjproject-2.13.1.tar.bz2
> [pjproject]  Verify successful
> [pjproject]  Verifying /tmp/pjproject-2.13.1.tar.bz2
> [pjproject]  Verify successful
> [pjproject]  Unpacking /tmp/pjproject-2.13.1.tar.bz2
> 
> We don't want packages to download stuff behind our back. Can we use an
> external pjproject?

I tried with the existing libpjsip in the tree, but asterisk is
segfauting with my config:
Asterisk Ready.
asterisk: ../src/pjsip/sip_transport.c:296: get_tpname: Assertion
`!"Invalid transport type!"' failed.

Thread 28 "asterisk" received signal SIGABRT, Aborted.

Unfortunately the external libpjsip 2.14 does not work well with
Asterisk.

What can we do about it?

best regards
 Waldemar
diff mbox series

Patch

diff --git a/package/asterisk/Config.in b/package/asterisk/Config.in
index c52456f8fc..662f070dac 100644
--- a/package/asterisk/Config.in
+++ b/package/asterisk/Config.in
@@ -10,6 +10,7 @@  config BR2_PACKAGE_ASTERISK
 	select BR2_PACKAGE_LIBCURL
 	select BR2_PACKAGE_LIBEDIT
 	select BR2_PACKAGE_LIBILBC
+	select BR2_PACKAGE_LIBJWT
 	select BR2_PACKAGE_LIBXML2
 	select BR2_PACKAGE_SQLITE
 	select BR2_PACKAGE_UTIL_LINUX
diff --git a/package/asterisk/asterisk.hash b/package/asterisk/asterisk.hash
index 246f4219aa..d50955dd2b 100644
--- a/package/asterisk/asterisk.hash
+++ b/package/asterisk/asterisk.hash
@@ -1,5 +1,5 @@ 
 # Locally computed
-sha256  9def260ac8745a5eac7aceabe1c22f84a283b7812f0eccd760f87ce9eb991d22  asterisk-20.5.2.tar.gz
+sha256  088dbc08916e21528dba364f5452b2090b066dbba4548b32ec10af138d4b442f  asterisk-20.6.0.tar.gz
 
 # sha1 from: http://downloads.asterisk.org/pub/telephony/sounds/releases
 # sha256 locally computed
diff --git a/package/asterisk/asterisk.mk b/package/asterisk/asterisk.mk
index d1f3ea82d3..869e4128ff 100644
--- a/package/asterisk/asterisk.mk
+++ b/package/asterisk/asterisk.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-ASTERISK_VERSION = 20.5.2
+ASTERISK_VERSION = 20.6.0
 # Use the github mirror: it's an official mirror maintained by Digium, and
 # provides tarballs, which the main Asterisk git tree (behind Gerrit) does not.
 ASTERISK_SITE = $(call github,asterisk,asterisk,$(ASTERISK_VERSION))
@@ -27,7 +27,7 @@  ASTERISK_SELINUX_MODULES = asterisk
 
 # For patches 0002 and 0003
 ASTERISK_AUTORECONF = YES
-ASTERISK_AUTORECONF_OPTS = -Iautoconf -Ithird-party -Ithird-party/pjproject -Ithird-party/jansson
+ASTERISK_AUTORECONF_OPTS = -Iautoconf -Ithird-party -Ithird-party/pjproject -Ithird-party/jansson -Ithird-party/libjwt
 
 ASTERISK_DEPENDENCIES = \
 	host-asterisk \
@@ -35,6 +35,7 @@  ASTERISK_DEPENDENCIES = \
 	jansson \
 	libcurl \
 	libedit \
+	libjwt \
 	libxml2 \
 	sqlite \
 	util-linux
@@ -89,6 +90,7 @@  ASTERISK_CONF_OPTS = \
 	--with-jansson \
 	--with-libcurl \
 	--with-ilbc \
+	--with-libjwt="$(STAGING_DIR)/usr" \
 	--with-libxml2 \
 	--with-libedit="$(STAGING_DIR)/usr" \
 	--with-pjproject \