diff mbox series

[1/2,v2] package/libjwt: new package

Message ID Zb0Qnnauhkwtp8Q0@waldemar-brodkorb.de
State Accepted
Headers show
Series [1/2,v2] package/libjwt: new package | expand

Commit Message

Waldemar Brodkorb Feb. 2, 2024, 3:56 p.m. UTC
JSON Web Tokens are an open, industry standard RFC 7519
method for representing claims securely between two parties.

This Library is used by Asterisk 20.6.0 and newer.
We need to use autotools to install pkgconfig file.

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
---
 package/Config.in          |  1 +
 package/libjwt/Config.in   |  9 +++++++++
 package/libjwt/libjwt.hash |  3 +++
 package/libjwt/libjwt.mk   | 16 ++++++++++++++++
 4 files changed, 29 insertions(+)
 create mode 100644 package/libjwt/Config.in
 create mode 100644 package/libjwt/libjwt.hash
 create mode 100644 package/libjwt/libjwt.mk

Comments

Peter Korsgaard Feb. 3, 2024, 10:02 a.m. UTC | #1
>>>>> "Waldemar" == Waldemar Brodkorb <wbx@openadk.org> writes:

 > JSON Web Tokens are an open, industry standard RFC 7519
 > method for representing claims securely between two parties.

 > This Library is used by Asterisk 20.6.0 and newer.
 > We need to use autotools to install pkgconfig file.

 > Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
 > ---
 >  package/Config.in          |  1 +
 >  package/libjwt/Config.in   |  9 +++++++++
 >  package/libjwt/libjwt.hash |  3 +++
 >  package/libjwt/libjwt.mk   | 16 ++++++++++++++++
 >  4 files changed, 29 insertions(+)
 >  create mode 100644 package/libjwt/Config.in
 >  create mode 100644 package/libjwt/libjwt.hash
 >  create mode 100644 package/libjwt/libjwt.mk

 > diff --git a/package/Config.in b/package/Config.in
 > index 426bd7d090..75a94177eb 100644
 > --- a/package/Config.in
 > +++ b/package/Config.in
 > @@ -1846,6 +1846,7 @@ menu "JSON/XML"
 >  	source "package/libbson/Config.in"
 >  	source "package/libfastjson/Config.in"
 >  	source "package/libjson/Config.in"
 > +	source "package/libjwt/Config.in"
 >  	source "package/libroxml/Config.in"
 >  	source "package/libucl/Config.in"
 >  	source "package/libxml2/Config.in"
 > diff --git a/package/libjwt/Config.in b/package/libjwt/Config.in
 > new file mode 100644
 > index 0000000000..d6bca54adc
 > --- /dev/null
 > +++ b/package/libjwt/Config.in
 > @@ -0,0 +1,9 @@
 > +config BR2_PACKAGE_LIBJWT
 > +	bool "libjwt"
 > +	select BR2_PACKAGE_OPENSSL
 > +	select BR2_PACKAGE_JANSSON
 > +	help
 > +	  JSON Web Tokens are an open, industry standard RFC 7519 

I've dropped the trailing spaces here.

> diff --git a/package/libjwt/libjwt.mk b/package/libjwt/libjwt.mk
 > new file mode 100644
 > index 0000000000..f7be28d206
 > --- /dev/null
 > +++ b/package/libjwt/libjwt.mk
 > @@ -0,0 +1,16 @@
 > +################################################################################
 > +#
 > +# libjwt
 > +#
 > +################################################################################
 > +
 > +LIBJWT_VERSION = 1.15.3
 > +LIBJWT_SITE = $(call github,benmcollins,libjwt,v$(LIBJWT_VERSION))
 > +LIBJWT_SOURCE = libjwt-$(LIBJWT_VERSION).tar.gz

THis is the default value for _SOURCE as pointed out by
./utils/check-package, so I've dropped that.

> +LIBJWT_DEPENDENCIES = jansson openssl

The configure script uses pkg-config, so I've added host-pkgconf here.

You also forgot to add an entry to DEVELOPERS, so I've added that.

Committed with those fixes, thanks.
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index 426bd7d090..75a94177eb 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1846,6 +1846,7 @@  menu "JSON/XML"
 	source "package/libbson/Config.in"
 	source "package/libfastjson/Config.in"
 	source "package/libjson/Config.in"
+	source "package/libjwt/Config.in"
 	source "package/libroxml/Config.in"
 	source "package/libucl/Config.in"
 	source "package/libxml2/Config.in"
diff --git a/package/libjwt/Config.in b/package/libjwt/Config.in
new file mode 100644
index 0000000000..d6bca54adc
--- /dev/null
+++ b/package/libjwt/Config.in
@@ -0,0 +1,9 @@ 
+config BR2_PACKAGE_LIBJWT
+	bool "libjwt"
+	select BR2_PACKAGE_OPENSSL
+	select BR2_PACKAGE_JANSSON
+	help
+	  JSON Web Tokens are an open, industry standard RFC 7519 
+	  method for representing claims securely between two parties.
+
+	  https://github.com/benmcollins/libjwt
diff --git a/package/libjwt/libjwt.hash b/package/libjwt/libjwt.hash
new file mode 100644
index 0000000000..2235fa3f99
--- /dev/null
+++ b/package/libjwt/libjwt.hash
@@ -0,0 +1,3 @@ 
+# Locally computed:
+sha256  cb2fd95123689e7d209a3a8c060e02f68341c9a5ded524c0cd881a8cd20d711f  libjwt-1.15.3.tar.gz
+sha256  fab3dd6bdab226f1c08630b1dd917e11fcb4ec5e1e020e2c16f83a0a13863e85  LICENSE
diff --git a/package/libjwt/libjwt.mk b/package/libjwt/libjwt.mk
new file mode 100644
index 0000000000..f7be28d206
--- /dev/null
+++ b/package/libjwt/libjwt.mk
@@ -0,0 +1,16 @@ 
+################################################################################
+#
+# libjwt
+#
+################################################################################
+
+LIBJWT_VERSION = 1.15.3
+LIBJWT_SITE = $(call github,benmcollins,libjwt,v$(LIBJWT_VERSION))
+LIBJWT_SOURCE = libjwt-$(LIBJWT_VERSION).tar.gz
+LIBJWT_DEPENDENCIES = jansson openssl
+LIBJWT_AUTORECONF = YES
+LIBJWT_INSTALL_STAGING = YES
+LIBJWT_LICENSE = MPL-2.0
+LIBJWT_LICENSE_FILES = LICENSE
+
+$(eval $(autotools-package))