diff mbox

Can we update NodeJS package to 0.12.*

Message ID B9FA34E87D998B44A9DFD1535DEAC39C4870891C@BBYEXM01.pmc-sierra.internal
State Not Applicable
Headers show

Commit Message

George Chen April 13, 2015, 4:05 p.m. UTC
Current 2015.03 buildroot contains NodeJS 0.10.36

Is there a way to customly configure the package to 0.11.* or 0.12.*?

The reason for the newer NodeJS version is that IPv6 is not fully supported in 0.10.*



I tried to change Config.mk

- NODEJS_VERSION = 0.10.36 
+ NODEJS_VERSION = 0.12.0


And then I changed nodejs-remove-python-bz2-dependency.patch



However, I am getting the make error:

../deps/v8/src/base/atomicops_internals_arm_gcc.h:258:4: error: #error "Your CPU's ARM architecture is not supported yet"


Is there an easy way to update the NodeJS package?
Is my only option to add NodeJS 0.12.0 as a custom package?

Thanks!

Comments

Thomas Petazzoni April 13, 2015, 7:19 p.m. UTC | #1
Dear George Chen,

On Mon, 13 Apr 2015 16:05:59 +0000, George Chen wrote:
> Current 2015.03 buildroot contains NodeJS 0.10.36
> 
> Is there a way to customly configure the package to 0.11.* or 0.12.*?

Well, just adjust nodejs.mk. And then, send a patch to the Buildroot
mailing list, so that we can integrate this update in the official
Buildroot.

> The reason for the newer NodeJS version is that IPv6 is not fully supported in 0.10.*
> 
> I tried to change Config.mk

I guess you meant nodejs.mk here.

> 
> - NODEJS_VERSION = 0.10.36 
> + NODEJS_VERSION = 0.12.0
> 
> However, I am getting the make error:
> 
> ../deps/v8/src/base/atomicops_internals_arm_gcc.h:258:4: error: #error "Your CPU's ARM architecture is not supported yet"

For which ARM target are you trying to build?

> Is my only option to add NodeJS 0.12.0 as a custom package?

Why would you want to add another package? Just improve the existing
nodejs package.

Best regards,

Thomas Petazzoni
Jörg Krause April 15, 2015, 8:02 a.m. UTC | #2
Hello George, Thomas,

On Mo, 2015-04-13 at 21:19 +0200, Thomas Petazzoni wrote:
> Dear George Chen,
> 
> On Mon, 13 Apr 2015 16:05:59 +0000, George Chen wrote:
> > Current 2015.03 buildroot contains NodeJS 0.10.36
> > 
> > Is there a way to customly configure the package to 0.11.* or 
> > 0.12.*?
> 
> Well, just adjust nodejs.mk. And then, send a patch to the Buildroot
> mailing list, so that we can integrate this update in the official
> Buildroot.
> 
> > The reason for the newer NodeJS version is that IPv6 is not fully 
> > supported in 0.10.*
> > 
> > I tried to change Config.mk
> 
> I guess you meant nodejs.mk here.
> 
> > 
> > - NODEJS_VERSION = 0.10.36 
> > + NODEJS_VERSION = 0.12.0
> > 
> > However, I am getting the make error:
> > 
> > ../deps/v8/src/base/atomicops_internals_arm_gcc.h:258:4: error: 
> > #error "Your CPU's ARM architecture is not supported yet"
> 
> For which ARM target are you trying to build?

The V8 version used in Node.js dropped support for ARMv5. That's why I
stick to Node.js 0.10.

> > Is my only option to add NodeJS 0.12.0 as a custom package?
> 
> Why would you want to add another package? Just improve the existing
> nodejs package.

Maybe we can support v0.10 (Maintance) and v0.12 (Stable) in Buildroot?

Best regards
Jörg Krause
diff mbox

Patch

Index: b/deps/v8/tools/js2c.py
===================================================================
--- a/deps/v8/tools/js2c.py
+++ b/deps/v8/tools/js2c.py
@@ -34,7 +34,6 @@ 
 import os, re, sys, string
 import optparse
 import jsmin
-import bz2
 import textwrap
 
 
@@ -492,6 +491,7 @@ 
   if compression_type == "off":
     return sources_bytes
   elif compression_type == "bz2":
+    import bz2
     return bz2.compress(sources_bytes)
   else:
     raise Error("Unknown compression type %s." % compression_type)