diff mbox

[1/2] package/eigen: install .pc file

Message ID 6208cd9e3ec1e0da22459393104981ab0e43d69b.1451329553.git.yann.morin.1998@free.fr
State Accepted
Headers show

Commit Message

Yann E. MORIN Dec. 28, 2015, 7:08 p.m. UTC
Other packages will look for eigen3.pc to detect the presence of eigen3.

eigen3.pc is usually installed by eigen's cmake buildsystem, but we do a
manual install to not depend on host-cmake just to install header files.
But in doing so, we forgot to install the .pc file.

Manually sed the source .pc.in to generate the final .pc file.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
---
 package/eigen/eigen.mk | 9 +++++++++
 1 file changed, 9 insertions(+)

Comments

Thomas Petazzoni Dec. 28, 2015, 9:05 p.m. UTC | #1
Dear Yann E. MORIN,

On Mon, 28 Dec 2015 20:08:54 +0100, Yann E. MORIN wrote:
> Other packages will look for eigen3.pc to detect the presence of eigen3.
> 
> eigen3.pc is usually installed by eigen's cmake buildsystem, but we do a
> manual install to not depend on host-cmake just to install header files.
> But in doing so, we forgot to install the .pc file.
> 
> Manually sed the source .pc.in to generate the final .pc file.
> 
> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> ---
>  package/eigen/eigen.mk | 9 +++++++++
>  1 file changed, 9 insertions(+)

Applied, thanks. Since I forgot to fix it in the commit, I did a
follow-up commit to fix the indentation. You used a mix of tabs and
spaces in a not very consistent way.

Best regards,

Thomas
Yann E. MORIN Dec. 28, 2015, 9:13 p.m. UTC | #2
Thomas, All,

On 2015-12-28 22:05 +0100, Thomas Petazzoni spake thusly:
> Dear Yann E. MORIN,
> 
> On Mon, 28 Dec 2015 20:08:54 +0100, Yann E. MORIN wrote:
> > Other packages will look for eigen3.pc to detect the presence of eigen3.
> > 
> > eigen3.pc is usually installed by eigen's cmake buildsystem, but we do a
> > manual install to not depend on host-cmake just to install header files.
> > But in doing so, we forgot to install the .pc file.
> > 
> > Manually sed the source .pc.in to generate the final .pc file.
> > 
> > Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> > ---
> >  package/eigen/eigen.mk | 9 +++++++++
> >  1 file changed, 9 insertions(+)
> 
> Applied, thanks.

:-)

> Since I forgot to fix it in the commit, I did a
> follow-up commit to fix the indentation. You used a mix of tabs and
> spaces in a not very consistent way.

Well, it was not really 'inconsistent' since I did it on purpose:
  - the sed's -e expression were all aligned (with tabstop=8)
  - the install's source and destination were aligned (with tabstop=8)

But OK, your fix provides another kind of 'consistency' ;-)

Thanks! :-)

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/package/eigen/eigen.mk b/package/eigen/eigen.mk
index dd88fde..3eb858a 100644
--- a/package/eigen/eigen.mk
+++ b/package/eigen/eigen.mk
@@ -20,6 +20,13 @@  define EIGEN_INSTALL_UNSUPPORTED_MODULES_CMDS
 endef
 endif
 
+# Generate the .pc file at build time
+define EIGEN_BUILD_CMDS
+	sed -r -e 's,^Version: .*,Version: $(EIGEN_VERSION),' \
+	       -e 's,^Cflags: .*,Cflags: -I$(EIGEN_DEST_DIR),' \
+	       $(@D)/eigen3.pc.in >$(@D)/eigen3.pc
+endef
+
 # This package only consists of headers that need to be
 # copied over to the sysroot for compile time use
 define EIGEN_INSTALL_STAGING_CMDS
@@ -27,6 +34,8 @@  define EIGEN_INSTALL_STAGING_CMDS
 	mkdir -p $(EIGEN_DEST_DIR)
 	cp -a $(@D)/Eigen $(EIGEN_DEST_DIR)
 	$(EIGEN_INSTALL_UNSUPPORTED_MODULES_CMDS)
+	$(INSTALL) -D -m 0644 $(@D)/eigen3.pc \
+			      $(STAGING_DIR)/usr/lib/pkgconfig/eigen3.pc
 endef
 
 $(eval $(generic-package))