diff mbox

[4,of,7,v3] toolchain/toolchain-buildroot: migrate to virtual package infrastructure

Message ID 58ea2200cf19b356f9d9.1402085580@localhost
State Superseded
Headers show

Commit Message

Thomas De Schampheleire June 6, 2014, 8:13 p.m. UTC
This patch migrates the toolchain and toolchain-buildroot packages to the
virtual package infrastructure, causing the log messages to change from:

>>> toolchain undefined Downloading
>>> toolchain undefined Extracting
...

to

>>> toolchain virtual Downloading
>>> toolchain virtual Extracting
...

and similar for 'toolchain-buildroot', simply because it looks nicer.

At the same time, the directory names also become toolchain-virtual,
toolchain-buildroot-virtual instead of the corresponding 'undefined'
variants.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

---
v3: no changes
v2: no changes

Note: this patch should only be applied when the first patch in this series
is.

 toolchain/toolchain-buildroot/toolchain-buildroot.mk |  4 +---
 toolchain/toolchain/toolchain.mk                     |  4 +---
 2 files changed, 2 insertions(+), 6 deletions(-)

Comments

Thomas Petazzoni June 7, 2014, 8:56 a.m. UTC | #1
Dear Thomas De Schampheleire,

On Fri, 06 Jun 2014 22:13:00 +0200, Thomas De Schampheleire wrote:
> This patch migrates the toolchain and toolchain-buildroot packages to the
> virtual package infrastructure, causing the log messages to change from:
> 
> >>> toolchain undefined Downloading
> >>> toolchain undefined Extracting
> ...
> 
> to
> 
> >>> toolchain virtual Downloading
> >>> toolchain virtual Extracting
> ...
> 
> and similar for 'toolchain-buildroot', simply because it looks nicer.

While 'toolchain' is really a virtual package, 'toolchain-buildroot' is
a bit weird because it always pulls the same dependency
(host-gcc-final). But oh, well, I guess we can consider it as being a
virtual package that has only one provider.

So:

Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
diff mbox

Patch

diff -r b3ada349b3a1 -r 58ea2200cf19 toolchain/toolchain-buildroot/toolchain-buildroot.mk
--- a/toolchain/toolchain-buildroot/toolchain-buildroot.mk	Sun May 11 10:32:44 2014 +0200
+++ b/toolchain/toolchain-buildroot/toolchain-buildroot.mk	Tue May 06 09:36:14 2014 +0200
@@ -4,8 +4,6 @@ 
 #
 ################################################################################
 
-TOOLCHAIN_BUILDROOT_SOURCE =
-
 BR_LIBC = $(call qstrip,$(BR2_TOOLCHAIN_BUILDROOT_LIBC))
 
 # Triggering the build of the host-gcc-final will automatically do the
@@ -16,4 +14,4 @@ 
 
 TOOLCHAIN_BUILDROOT_ADD_TOOLCHAIN_DEPENDENCY = NO
 
-$(eval $(generic-package))
+$(eval $(virtual-package))
diff -r b3ada349b3a1 -r 58ea2200cf19 toolchain/toolchain/toolchain.mk
--- a/toolchain/toolchain/toolchain.mk	Sun May 11 10:32:44 2014 +0200
+++ b/toolchain/toolchain/toolchain.mk	Tue May 06 09:36:14 2014 +0200
@@ -4,8 +4,6 @@ 
 #
 ################################################################################
 
-TOOLCHAIN_SOURCE =
-
 ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
 TOOLCHAIN_DEPENDENCIES += toolchain-buildroot
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL),y)
@@ -14,6 +12,6 @@ 
 
 TOOLCHAIN_ADD_TOOLCHAIN_DEPENDENCY = NO
 
-$(eval $(generic-package))
+$(eval $(virtual-package))
 
 toolchain: $(HOST_DIR)/usr/share/buildroot/toolchainfile.cmake