diff mbox

[06/21,v2] docs/manual: do not override BR2_EXTERNAL

Message ID 4ffb76bcc38fd984ddd6b91f6a0228456b418f1d.1445545973.git.yann.morin.1998@free.fr
State Accepted
Headers show

Commit Message

Yann E. MORIN Oct. 22, 2015, 8:34 p.m. UTC
Currently, we forcibly override BR2_EXTERNAL when building the manual,
so as to avoid referring to packages therein from the manual.

However, when generating the lists of packages, we limit ourselves to
scanning for packages in (Buildroot's) TOPDIR and never search in
BR2_EXTERNAL. So, we do not really need to override BR2_EXTERNAL when
generating the manual to achieve the same result.

Furthermore, we're only looking for packages that are defined in the
sub-menu "Target packages", and never anywhere else, and especially not
in the sub-menu "User-provided options".

Finally, we're soon to completely eliminate use of BR2_EXTERNAL in
Kconfig altogether, so that would no longer have any impact anyway.

So, just leave BR2_EXTERNAL alone when generating the manual.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Peter Korsgaard <jacmet@uclibc.org>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Samuel Martin <s.martin49@gmail.com>
---
 docs/manual/manual.mk | 3 ---
 1 file changed, 3 deletions(-)

Comments

Arnout Vandecappelle Oct. 26, 2015, 9:12 p.m. UTC | #1
On 22-10-15 22:34, Yann E. MORIN wrote:
> Currently, we forcibly override BR2_EXTERNAL when building the manual,
> so as to avoid referring to packages therein from the manual.
> 
> However, when generating the lists of packages, we limit ourselves to
> scanning for packages in (Buildroot's) TOPDIR and never search in
> BR2_EXTERNAL. So, we do not really need to override BR2_EXTERNAL when
> generating the manual to achieve the same result.
> 
> Furthermore, we're only looking for packages that are defined in the
> sub-menu "Target packages", and never anywhere else, and especially not
> in the sub-menu "User-provided options".
> 
> Finally, we're soon to completely eliminate use of BR2_EXTERNAL in
> Kconfig altogether, so that would no longer have any impact anyway.
> 
> So, just leave BR2_EXTERNAL alone when generating the manual.
> 
> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>


 Again, can be applied independently of the rest of the series.

 Regards,
 Arnout

> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
> Cc: Peter Korsgaard <jacmet@uclibc.org>
> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
> Cc: Arnout Vandecappelle <arnout@mind.be>
> Cc: Samuel Martin <s.martin49@gmail.com>
> ---
>  docs/manual/manual.mk | 3 ---
>  1 file changed, 3 deletions(-)
> 
> diff --git a/docs/manual/manual.mk b/docs/manual/manual.mk
> index ad9bd90..caf080a 100644
> --- a/docs/manual/manual.mk
> +++ b/docs/manual/manual.mk
> @@ -8,13 +8,10 @@ MANUAL_SOURCES = $(sort $(wildcard docs/manual/*.txt) $(wildcard docs/images/*))
>  MANUAL_RESOURCES = $(TOPDIR)/docs/images
>  
>  # Our manual needs to generate lists
> -# Packages included in BR2_EXTERNAL are not part of buildroot, so they
> -# should not be included in the manual.
>  define MANUAL_GEN_LISTS
>  	$(Q)$(call MESSAGE,"Updating the manual lists...")
>  	$(Q)$(COMMON_CONFIG_ENV) \
>  		BR2_DEFCONFIG="" \
> -		BR2_EXTERNAL=$(TOPDIR)/support/dummy-external \
>  		TOPDIR=$(TOPDIR) \
>  		O=$(@D) \
>  		python -B $(TOPDIR)/support/scripts/gen-manual-lists.py
>
Thomas Petazzoni Nov. 3, 2015, 10:42 p.m. UTC | #2
Dear Yann E. MORIN,

On Thu, 22 Oct 2015 22:34:01 +0200, Yann E. MORIN wrote:
> Currently, we forcibly override BR2_EXTERNAL when building the manual,
> so as to avoid referring to packages therein from the manual.
> 
> However, when generating the lists of packages, we limit ourselves to
> scanning for packages in (Buildroot's) TOPDIR and never search in
> BR2_EXTERNAL. So, we do not really need to override BR2_EXTERNAL when
> generating the manual to achieve the same result.
> 
> Furthermore, we're only looking for packages that are defined in the
> sub-menu "Target packages", and never anywhere else, and especially not
> in the sub-menu "User-provided options".
> 
> Finally, we're soon to completely eliminate use of BR2_EXTERNAL in
> Kconfig altogether, so that would no longer have any impact anyway.
> 
> So, just leave BR2_EXTERNAL alone when generating the manual.
> 
> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
> Cc: Peter Korsgaard <jacmet@uclibc.org>
> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
> Cc: Arnout Vandecappelle <arnout@mind.be>
> Cc: Samuel Martin <s.martin49@gmail.com>
> ---
>  docs/manual/manual.mk | 3 ---
>  1 file changed, 3 deletions(-)

Applied, thanks.

Thomas
diff mbox

Patch

diff --git a/docs/manual/manual.mk b/docs/manual/manual.mk
index ad9bd90..caf080a 100644
--- a/docs/manual/manual.mk
+++ b/docs/manual/manual.mk
@@ -8,13 +8,10 @@  MANUAL_SOURCES = $(sort $(wildcard docs/manual/*.txt) $(wildcard docs/images/*))
 MANUAL_RESOURCES = $(TOPDIR)/docs/images
 
 # Our manual needs to generate lists
-# Packages included in BR2_EXTERNAL are not part of buildroot, so they
-# should not be included in the manual.
 define MANUAL_GEN_LISTS
 	$(Q)$(call MESSAGE,"Updating the manual lists...")
 	$(Q)$(COMMON_CONFIG_ENV) \
 		BR2_DEFCONFIG="" \
-		BR2_EXTERNAL=$(TOPDIR)/support/dummy-external \
 		TOPDIR=$(TOPDIR) \
 		O=$(@D) \
 		python -B $(TOPDIR)/support/scripts/gen-manual-lists.py