diff mbox series

[2/2] package/tiff: explicitly disable jbig support for host and target

Message ID 20240404153438.3337807-2-peter@korsgaard.com
State Accepted
Headers show
Series [1/2] package/tiff: explicitly disable lerc support for host and target | expand

Commit Message

Peter Korsgaard April 4, 2024, 3:34 p.m. UTC
BR2_PACKAGE_TIFF_JBIG did actually not do anything, as no explicit
--enable-jbig was passed to configure and there is no libjbig in Buildroot,
so drop it and instead explicitly disable jbig support.

Also add --disable-jbig for the host build, which was missed when host
support was added in commit 91b16fbbf9db (tiff: add host variant).

As the TIFF_JBIG option was a noop, do not add legacy handling for it.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/tiff/Config.in | 4 ----
 package/tiff/tiff.mk   | 6 ++----
 2 files changed, 2 insertions(+), 8 deletions(-)

Comments

Peter Korsgaard April 6, 2024, 7:43 a.m. UTC | #1
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > BR2_PACKAGE_TIFF_JBIG did actually not do anything, as no explicit
 > --enable-jbig was passed to configure and there is no libjbig in Buildroot,
 > so drop it and instead explicitly disable jbig support.

 > Also add --disable-jbig for the host build, which was missed when host
 > support was added in commit 91b16fbbf9db (tiff: add host variant).

 > As the TIFF_JBIG option was a noop, do not add legacy handling for it.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/tiff/Config.in b/package/tiff/Config.in
index d1004d6668..d357d08406 100644
--- a/package/tiff/Config.in
+++ b/package/tiff/Config.in
@@ -63,10 +63,6 @@  config BR2_PACKAGE_TIFF_OLD_JPEG
 	bool "Old JPEG decompression"
 	default y
 
-config BR2_PACKAGE_TIFF_JBIG
-	bool "JBIG compression"
-	default y
-
 config BR2_PACKAGE_TIFF_UTILITIES
 	bool "tiff utilities"
 	help
diff --git a/package/tiff/tiff.mk b/package/tiff/tiff.mk
index 8ec53d4fe1..0e5e0dd48a 100644
--- a/package/tiff/tiff.mk
+++ b/package/tiff/tiff.mk
@@ -17,6 +17,7 @@  TIFF_INSTALL_STAGING = YES
 TIFF_CONF_OPTS = \
 	--disable-contrib \
 	--disable-lerc \
+	--disable-jbig \
 	--disable-tests \
 	--disable-webp
 
@@ -28,6 +29,7 @@  HOST_TIFF_CONF_OPTS = \
 	--disable-lerc \
 	--disable-libdeflate \
 	--disable-lzma \
+	--disable-jbig \
 	--disable-jpeg \
 	--disable-tests \
 	--disable-webp \
@@ -101,10 +103,6 @@  ifneq ($(BR2_PACKAGE_TIFF_OLD_JPEG),y)
 TIFF_CONF_OPTS += --disable-old-jpeg
 endif
 
-ifneq ($(BR2_PACKAGE_TIFF_JBIG),y)
-TIFF_CONF_OPTS += --disable-jbig
-endif
-
 ifeq ($(BR2_PACKAGE_TIFF_UTILITIES),y)
 TIFF_CONF_OPTS += --enable-tools
 else