diff mbox series

[1/2] package/tiff: explicitly disable lerc support for host and target

Message ID 20240404153438.3337807-1-peter@korsgaard.com
State Accepted
Headers show
Series [1/2] package/tiff: explicitly disable lerc support for host and target | expand

Commit Message

Peter Korsgaard April 4, 2024, 3:34 p.m. UTC
We do not have liblerc in Buildroot and it may cause linking issues for
host-tiff on build hosts with liblerc:

libtool: link: /usr/bin/gcc -O2
-I/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/per-package/host-tiff/host/include
-Wall -W -Wl,-rpath
-Wl,/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/per-package/host-tiff/host/lib
-o tiffcp tiffcp.o
-L/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/per-package/host-tiff/host/lib
../libtiff/.libs/libtiff.so ../port/.libs/libport.a -lLerc -ljbig -lm
-Wl,-rpath
-Wl,/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/build/host-tiff-4.6.0/libtiff/.libs
-Wl,-rpath
-Wl,/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/per-package/host-tiff/host/lib
/usr/bin/ld: ../libtiff/.libs/libtiff.so: undefined reference to
`deflateInit_'
/usr/bin/ld: ../libtiff/.libs/libtiff.so: undefined reference to `deflate'
/usr/bin/ld: ../libtiff/.libs/libtiff.so: undefined reference to
`deflateEnd'
/usr/bin/ld: ../libtiff/.libs/libtiff.so: undefined reference to `inflate'

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/tiff/tiff.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Peter Korsgaard April 6, 2024, 7:43 a.m. UTC | #1
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > We do not have liblerc in Buildroot and it may cause linking issues for
 > host-tiff on build hosts with liblerc:

 > libtool: link: /usr/bin/gcc -O2
 > -I/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/per-package/host-tiff/host/include
 > -Wall -W -Wl,-rpath
 > -Wl,/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/per-package/host-tiff/host/lib
 > -o tiffcp tiffcp.o
 > -L/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/per-package/host-tiff/host/lib
 > ../libtiff/.libs/libtiff.so ../port/.libs/libport.a -lLerc -ljbig -lm
 > -Wl,-rpath
 > -Wl,/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/build/host-tiff-4.6.0/libtiff/.libs
 > -Wl,-rpath
 > -Wl,/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/per-package/host-tiff/host/lib
 > /usr/bin/ld: ../libtiff/.libs/libtiff.so: undefined reference to
 > `deflateInit_'
 > /usr/bin/ld: ../libtiff/.libs/libtiff.so: undefined reference to `deflate'
 > /usr/bin/ld: ../libtiff/.libs/libtiff.so: undefined reference to
 > `deflateEnd'
 > /usr/bin/ld: ../libtiff/.libs/libtiff.so: undefined reference to `inflate'

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/tiff/tiff.mk b/package/tiff/tiff.mk
index e384e8b814..8ec53d4fe1 100644
--- a/package/tiff/tiff.mk
+++ b/package/tiff/tiff.mk
@@ -16,6 +16,7 @@  TIFF_INSTALL_STAGING = YES
 # support in tiff, or that would create a circular dependency.
 TIFF_CONF_OPTS = \
 	--disable-contrib \
+	--disable-lerc \
 	--disable-tests \
 	--disable-webp
 
@@ -24,6 +25,7 @@  TIFF_DEPENDENCIES = host-pkgconf
 HOST_TIFF_CONF_OPTS = \
 	--disable-cxx \
 	--disable-zlib \
+	--disable-lerc \
 	--disable-libdeflate \
 	--disable-lzma \
 	--disable-jpeg \