diff mbox series

[7/9] package/pure-ftpd: add optional dependency to libxcrypt

Message ID 20240403153641.4122789-7-bernd@kuhls.net
State Accepted
Headers show
Series [1/9] package/apg: add optional dependency to libxcrypt | expand

Commit Message

Bernd Kuhls April 3, 2024, 3:36 p.m. UTC
When glibc was bumped to version 2.39 in commit
b5680f53d60acf8ff6010082f873438a39bd5d97 it removed the deprecated
libcrypt support.

As glibc's libcrypt was providing pure-ftpd's libcrypt dependency this
broke the pure-ftpd build using glibc version 2.39.

To fix this select the libxcrypt dependency to pure-ftpd when using a
glibc toolchain and add the dependency if selected.

Fixes:
http://autobuild.buildroot.net/results/2a62f48973b30873f4da842e75176633398bef86/

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
 package/pure-ftpd/Config.in    | 1 +
 package/pure-ftpd/pure-ftpd.mk | 4 ++++
 2 files changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/package/pure-ftpd/Config.in b/package/pure-ftpd/Config.in
index c060102650..edfe0159e3 100644
--- a/package/pure-ftpd/Config.in
+++ b/package/pure-ftpd/Config.in
@@ -2,6 +2,7 @@  config BR2_PACKAGE_PURE_FTPD
 	bool "pure-ftpd"
 	depends on BR2_USE_MMU # fork()
 	select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	help
 	  Pure-FTPd is a free (BSD), secure, production-quality and
 	  standard- conformant FTP server. It doesn't provide useless
diff --git a/package/pure-ftpd/pure-ftpd.mk b/package/pure-ftpd/pure-ftpd.mk
index b918c70930..2c01bc8804 100644
--- a/package/pure-ftpd/pure-ftpd.mk
+++ b/package/pure-ftpd/pure-ftpd.mk
@@ -30,6 +30,10 @@  ifeq ($(BR2_PACKAGE_LIBSODIUM),y)
 PURE_FTPD_DEPENDENCIES += libsodium
 endif
 
+ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
+PURE_FTPD_DEPENDENCIES += libxcrypt
+endif
+
 ifeq ($(BR2_PACKAGE_MARIADB),y)
 PURE_FTPD_CONF_OPTS += --with-mysql=$(STAGING_DIR)/usr
 PURE_FTPD_DEPENDENCIES += mariadb