diff mbox series

[1/9] package/apg: add optional dependency to libxcrypt

Message ID 20240403153641.4122789-1-bernd@kuhls.net
State Accepted
Headers show
Series [1/9] package/apg: add optional dependency to libxcrypt | expand

Commit Message

Bernd Kuhls April 3, 2024, 3:36 p.m. UTC
When glibc was bumped to version 2.39 in commit
b5680f53d60acf8ff6010082f873438a39bd5d97 it removed the deprecated
libcrypt support.

As glibc's libcrypt was providing apg's libcrypt dependency this broke
the apg build using glibc version 2.39.

To fix this select the libxcrypt dependency to apg when using a glibc
toolchain and add the dependency if selected.

Fixes:
http://autobuild.buildroot.net/results/3df84ae300bb648492cffc21e4481fc5abf02aeb/

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
 package/apg/Config.in | 1 +
 package/apg/apg.mk    | 4 ++++
 2 files changed, 5 insertions(+)

Comments

Yann E. MORIN April 3, 2024, 7:56 p.m. UTC | #1
Bernd, All,

On 2024-04-03 17:36 +0200, Bernd Kuhls spake thusly:
> When glibc was bumped to version 2.39 in commit
> b5680f53d60acf8ff6010082f873438a39bd5d97 it removed the deprecated
> libcrypt support.
> 
> As glibc's libcrypt was providing apg's libcrypt dependency this broke
> the apg build using glibc version 2.39.
> 
> To fix this select the libxcrypt dependency to apg when using a glibc
> toolchain and add the dependency if selected.
> 
> Fixes:
> http://autobuild.buildroot.net/results/3df84ae300bb648492cffc21e4481fc5abf02aeb/
> 
> Signed-off-by: Bernd Kuhls <bernd@kuhls.net>

Thanks a lot for those patches! Whole series applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/apg/Config.in | 1 +
>  package/apg/apg.mk    | 4 ++++
>  2 files changed, 5 insertions(+)
> 
> diff --git a/package/apg/Config.in b/package/apg/Config.in
> index 94c286a178..f54ffdba39 100644
> --- a/package/apg/Config.in
> +++ b/package/apg/Config.in
> @@ -1,5 +1,6 @@
>  config BR2_PACKAGE_APG
>  	bool "apg"
> +	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
>  	help
>  	  Automated Password Generator (APG).
>  
> diff --git a/package/apg/apg.mk b/package/apg/apg.mk
> index 16661f4b8d..1929e21f58 100644
> --- a/package/apg/apg.mk
> +++ b/package/apg/apg.mk
> @@ -9,6 +9,10 @@ APG_SITE = $(call github,wilx,apg,v$(APG_VERSION))
>  APG_LICENSE = BSD-3-Clause
>  APG_LICENSE_FILES = COPYING
>  
> +ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
> +APG_DEPENDENCIES += libxcrypt
> +endif
> +
>  define APG_BUILD_CMDS
>  	$(MAKE) $(TARGET_CONFIGURE_OPTS) FLAGS="$(TARGET_CFLAGS)" -C $(@D)
>  endef
> -- 
> 2.39.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/apg/Config.in b/package/apg/Config.in
index 94c286a178..f54ffdba39 100644
--- a/package/apg/Config.in
+++ b/package/apg/Config.in
@@ -1,5 +1,6 @@ 
 config BR2_PACKAGE_APG
 	bool "apg"
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	help
 	  Automated Password Generator (APG).
 
diff --git a/package/apg/apg.mk b/package/apg/apg.mk
index 16661f4b8d..1929e21f58 100644
--- a/package/apg/apg.mk
+++ b/package/apg/apg.mk
@@ -9,6 +9,10 @@  APG_SITE = $(call github,wilx,apg,v$(APG_VERSION))
 APG_LICENSE = BSD-3-Clause
 APG_LICENSE_FILES = COPYING
 
+ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
+APG_DEPENDENCIES += libxcrypt
+endif
+
 define APG_BUILD_CMDS
 	$(MAKE) $(TARGET_CONFIGURE_OPTS) FLAGS="$(TARGET_CFLAGS)" -C $(@D)
 endef