diff mbox series

[2/3] packages/libcamera: Fix libcamera build with rpi pipeline

Message ID 20231227182429.1215185-2-mail@sebastianbauer.info
State Not Applicable
Headers show
Series [1/3] Revert "package/libcamera-apps: bump to version 1.3.0" | expand

Commit Message

Sebastian Bauer Dec. 27, 2023, 6:24 p.m. UTC
The name of the pipeline was renamed from raspberrypi to rpi/vc4 in
version 0.1.0 of libcamera, which is why, without this fix, the build is
broken.

Signed-off-by: Sebastian Bauer <mail@sebastianbauer.info>
---
 package/libcamera/libcamera.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Seiderer Dec. 27, 2023, 9:52 p.m. UTC | #1
Hello Sebastian,

thanks for the patch..., but submitted already a prior (and I think more
complete?) one fixing the same issue, see:

	http://lists.busybox.net/pipermail/buildroot/2023-November/679414.html

Regards,
Peter


On Wed, 27 Dec 2023 19:24:28 +0100, Sebastian Bauer <mail@sebastianbauer.info> wrote:

> The name of the pipeline was renamed from raspberrypi to rpi/vc4 in
> version 0.1.0 of libcamera, which is why, without this fix, the build is
> broken.
>
> Signed-off-by: Sebastian Bauer <mail@sebastianbauer.info>
> ---
>  package/libcamera/libcamera.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/package/libcamera/libcamera.mk b/package/libcamera/libcamera.mk
> index 8dce67f60f..c0c5a02368 100644
> --- a/package/libcamera/libcamera.mk
> +++ b/package/libcamera/libcamera.mk
> @@ -52,7 +52,7 @@ endif
>
>  LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_IPU3) += ipu3
>  ifeq ($(BR2_PACKAGE_LIBCAMERA_PIPELINE_RASPBERRYPI),y)
> -LIBCAMERA_PIPELINES-y += raspberrypi
> +LIBCAMERA_PIPELINES-y += rpi/vc4
>  LIBCAMERA_DEPENDENCIES += boost
>  endif
>  LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_RKISP1) += rkisp1
Yann E. MORIN Dec. 27, 2023, 10:15 p.m. UTC | #2
Sebastien, All,

Thanks for this patch!

On 2023-12-27 19:24 +0100, Sebastian Bauer spake thusly:
> The name of the pipeline was renamed from raspberrypi to rpi/vc4 in
> version 0.1.0 of libcamera, which is why, without this fix, the build is
> broken.

As Peter pointed out, his patch is a bit more complete, so I ended up
applying his patch.

Regards,
Yann E. MORIN.

> Signed-off-by: Sebastian Bauer <mail@sebastianbauer.info>
> ---
>  package/libcamera/libcamera.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/libcamera/libcamera.mk b/package/libcamera/libcamera.mk
> index 8dce67f60f..c0c5a02368 100644
> --- a/package/libcamera/libcamera.mk
> +++ b/package/libcamera/libcamera.mk
> @@ -52,7 +52,7 @@ endif
>  
>  LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_IPU3) += ipu3
>  ifeq ($(BR2_PACKAGE_LIBCAMERA_PIPELINE_RASPBERRYPI),y)
> -LIBCAMERA_PIPELINES-y += raspberrypi
> +LIBCAMERA_PIPELINES-y += rpi/vc4
>  LIBCAMERA_DEPENDENCIES += boost
>  endif
>  LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_RKISP1) += rkisp1
> -- 
> 2.43.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Sebastian Bauer Dec. 28, 2023, 10:46 a.m. UTC | #3
Am 2023-12-27 23:15, schrieb Yann E. MORIN:
> On 2023-12-27 19:24 +0100, Sebastian Bauer spake thusly:
>> The name of the pipeline was renamed from raspberrypi to rpi/vc4 in
>> version 0.1.0 of libcamera, which is why, without this fix, the build 
>> is
>> broken.
> As Peter pointed out, his patch is a bit more complete, so I ended up
> applying his patch.

Yes, I agree. I didn't know that there was another patch pending (I have 
not yet figured out how to search through patches). Thanks for fixing 
the problem!

Bye
Sebastian
diff mbox series

Patch

diff --git a/package/libcamera/libcamera.mk b/package/libcamera/libcamera.mk
index 8dce67f60f..c0c5a02368 100644
--- a/package/libcamera/libcamera.mk
+++ b/package/libcamera/libcamera.mk
@@ -52,7 +52,7 @@  endif
 
 LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_IPU3) += ipu3
 ifeq ($(BR2_PACKAGE_LIBCAMERA_PIPELINE_RASPBERRYPI),y)
-LIBCAMERA_PIPELINES-y += raspberrypi
+LIBCAMERA_PIPELINES-y += rpi/vc4
 LIBCAMERA_DEPENDENCIES += boost
 endif
 LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_RKISP1) += rkisp1