diff mbox series

[v1,1/4] package/libcamera: pipeline option 'raspberrypi' changed to 'rpi/vc4'

Message ID 20231109212901.5596-1-ps.report@gmx.net
State Accepted
Headers show
Series [v1,1/4] package/libcamera: pipeline option 'raspberrypi' changed to 'rpi/vc4' | expand

Commit Message

Peter Seiderer Nov. 9, 2023, 9:28 p.m. UTC
With upstram commit [1] (since version v0.1.0) the pipeline option 'raspberrypi'
was renamed to 'rpi/vc4'.

Change the buildroot option name from BR2_PACKAGE_LIBCAMERA_PIPELINE_RASPBERRYPI
to BR2_PACKAGE_LIBCAMERA_PIPELINE_RPI_VC4 (and add Config.in.legacy entry
accordingly) and move handling in Config.in/libcamer.mk to follow alphabetic
ordering.

Fixes:

  .../build/libcamera-v0.1.0/meson.build:3:0: ERROR: Options "raspberrypi" are not in allowed choices: "all, auto, imx8-isi, ipu3, rkisp1, rpi/vc4, simple, uvcvideo, vimc"

[1] https://git.libcamera.org/libcamera/libcamera.git/commit/?id=726e9274ea95fa46352556d340c5793a8da51fcd

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
 Config.in.legacy               | 10 ++++++++++
 package/libcamera/Config.in    | 16 ++++++++--------
 package/libcamera/libcamera.mk |  6 +++---
 3 files changed, 21 insertions(+), 11 deletions(-)

Comments

Yann E. MORIN Dec. 27, 2023, 10:16 p.m. UTC | #1
Peter, All,

On 2023-11-09 22:28 +0100, Peter Seiderer spake thusly:
> With upstram commit [1] (since version v0.1.0) the pipeline option 'raspberrypi'
> was renamed to 'rpi/vc4'.
> 
> Change the buildroot option name from BR2_PACKAGE_LIBCAMERA_PIPELINE_RASPBERRYPI
> to BR2_PACKAGE_LIBCAMERA_PIPELINE_RPI_VC4 (and add Config.in.legacy entry
> accordingly) and move handling in Config.in/libcamer.mk to follow alphabetic
> ordering.
> 
> Fixes:
> 
>   .../build/libcamera-v0.1.0/meson.build:3:0: ERROR: Options "raspberrypi" are not in allowed choices: "all, auto, imx8-isi, ipu3, rkisp1, rpi/vc4, simple, uvcvideo, vimc"
> 
> [1] https://git.libcamera.org/libcamera/libcamera.git/commit/?id=726e9274ea95fa46352556d340c5793a8da51fcd
> 
> Signed-off-by: Peter Seiderer <ps.report@gmx.net>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  Config.in.legacy               | 10 ++++++++++
>  package/libcamera/Config.in    | 16 ++++++++--------
>  package/libcamera/libcamera.mk |  6 +++---
>  3 files changed, 21 insertions(+), 11 deletions(-)
> 
> diff --git a/Config.in.legacy b/Config.in.legacy
> index 6fef2318b0..06a40f0b38 100644
> --- a/Config.in.legacy
> +++ b/Config.in.legacy
> @@ -146,6 +146,16 @@ endif
>  
>  comment "Legacy options removed in 2023.11"
>  
> +config BR2_PACKAGE_LIBCAMERA_PIPELINE_RASPBERRYPI
> +	bool "libcamera pipeline 'raspberrypi' was renamed to 'rpi/vc4'"
> +	depends on BR2_arm || BR2_aarch64
> +	depends on BR2_USE_WCHAR
> +	select BR2_LEGACY
> +	select BR2_PACKAGE_LIBCAMERA_PIPELINE_RPI_VC4
> +	help
> +	  Since version ... the libcamera pipeline option 'raspberrypi' was
> +	  renamed to 'rpi/vc4'.
> +
>  config BR2_PACKAGE_OPENJDK_VERSION_11
>  	bool "openjdk 11 has been removed"
>  	select BR2_LEGACY
> diff --git a/package/libcamera/Config.in b/package/libcamera/Config.in
> index 63c06173db..65d5fb37f8 100644
> --- a/package/libcamera/Config.in
> +++ b/package/libcamera/Config.in
> @@ -40,21 +40,21 @@ config BR2_PACKAGE_LIBCAMERA_PIPELINE_IPU3
>  	help
>  	  Pipeline for Intel IPU3.
>  
> -config BR2_PACKAGE_LIBCAMERA_PIPELINE_RASPBERRYPI
> -	bool "raspberrypi pipeline"
> +config BR2_PACKAGE_LIBCAMERA_PIPELINE_RKISP1
> +	bool "rkisp1 pipeline"
>  	depends on BR2_arm || BR2_aarch64
> -	depends on BR2_USE_WCHAR # boost (already enforced for gnutls)
> -	select BR2_PACKAGE_BOOST
>  	select BR2_PACKAGE_LIBCAMERA_HAS_PIPELINE
>  	help
> -	  Pipeline for Raspberry Pi devices.
> +	  Pipeline for Rockchip ISP1.
>  
> -config BR2_PACKAGE_LIBCAMERA_PIPELINE_RKISP1
> -	bool "rkisp1 pipeline"
> +config BR2_PACKAGE_LIBCAMERA_PIPELINE_RPI_VC4
> +	bool "rpi/vc4 pipeline"
>  	depends on BR2_arm || BR2_aarch64
> +	depends on BR2_USE_WCHAR # boost (already enforced for gnutls)
> +	select BR2_PACKAGE_BOOST
>  	select BR2_PACKAGE_LIBCAMERA_HAS_PIPELINE
>  	help
> -	  Pipeline for Rockchip ISP1.
> +	  Pipeline for Raspberry Pi devices.
>  
>  config BR2_PACKAGE_LIBCAMERA_PIPELINE_SIMPLE
>  	bool "simple pipeline"
> diff --git a/package/libcamera/libcamera.mk b/package/libcamera/libcamera.mk
> index 8dce67f60f..c1c8bb7b33 100644
> --- a/package/libcamera/libcamera.mk
> +++ b/package/libcamera/libcamera.mk
> @@ -51,11 +51,11 @@ LIBCAMERA_CONF_OPTS += -Dv4l2=false
>  endif
>  
>  LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_IPU3) += ipu3
> -ifeq ($(BR2_PACKAGE_LIBCAMERA_PIPELINE_RASPBERRYPI),y)
> -LIBCAMERA_PIPELINES-y += raspberrypi
> +LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_RKISP1) += rkisp1
> +ifeq ($(BR2_PACKAGE_LIBCAMERA_PIPELINE_RPI_VC4),y)
> +LIBCAMERA_PIPELINES-y += rpi/vc4
>  LIBCAMERA_DEPENDENCIES += boost
>  endif
> -LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_RKISP1) += rkisp1
>  LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_SIMPLE) += simple
>  LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_UVCVIDEO) += uvcvideo
>  LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_VIMC) += vimc
> -- 
> 2.42.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Yann E. MORIN Dec. 27, 2023, 10:20 p.m. UTC | #2
Peter, All,

On 2023-12-27 23:16 +0100, Yann E. MORIN spake thusly:
> On 2023-11-09 22:28 +0100, Peter Seiderer spake thusly:
> > With upstram commit [1] (since version v0.1.0) the pipeline option 'raspberrypi'
> > was renamed to 'rpi/vc4'.
> > 
> > Change the buildroot option name from BR2_PACKAGE_LIBCAMERA_PIPELINE_RASPBERRYPI
> > to BR2_PACKAGE_LIBCAMERA_PIPELINE_RPI_VC4 (and add Config.in.legacy entry
> > accordingly) and move handling in Config.in/libcamer.mk to follow alphabetic
> > ordering.
> > 
> > Fixes:
> > 
> >   .../build/libcamera-v0.1.0/meson.build:3:0: ERROR: Options "raspberrypi" are not in allowed choices: "all, auto, imx8-isi, ipu3, rkisp1, rpi/vc4, simple, uvcvideo, vimc"
> > 
> > [1] https://git.libcamera.org/libcamera/libcamera.git/commit/?id=726e9274ea95fa46352556d340c5793a8da51fcd
> > 
> > Signed-off-by: Peter Seiderer <ps.report@gmx.net>
> Applied to master, thanks.
[--SNIP--]
> > diff --git a/Config.in.legacy b/Config.in.legacy
> > index 6fef2318b0..06a40f0b38 100644
> > --- a/Config.in.legacy
> > +++ b/Config.in.legacy
> > @@ -146,6 +146,16 @@ endif
> >  
> >  comment "Legacy options removed in 2023.11"
> >  
> > +config BR2_PACKAGE_LIBCAMERA_PIPELINE_RASPBERRYPI
> > +	bool "libcamera pipeline 'raspberrypi' was renamed to 'rpi/vc4'"
> > +	depends on BR2_arm || BR2_aarch64
> > +	depends on BR2_USE_WCHAR
> > +	select BR2_LEGACY
> > +	select BR2_PACKAGE_LIBCAMERA_PIPELINE_RPI_VC4
> > +	help
> > +	  Since version ... the libcamera pipeline option 'raspberrypi' was

    $ ./utils/docker-run make check-pacakge
    Config.in.legacy:156: help text: <tab><2 spaces><62 chars> (http://nightly.buildroot.org/#writing-rules-config-in)

I had it fixed locally, but forgot to commit before pushing, so I pushed
a follow-up fix.

I also replaced the '...' with the actual version you talked about ion
the commit log: 0.1.0.

Regards,
Yann E. MORIN.

> > +	  renamed to 'rpi/vc4'.
Peter Korsgaard Jan. 10, 2024, 3:37 p.m. UTC | #3
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 > Peter, All,
 > On 2023-11-09 22:28 +0100, Peter Seiderer spake thusly:
 >> With upstram commit [1] (since version v0.1.0) the pipeline option 'raspberrypi'
 >> was renamed to 'rpi/vc4'.
 >> 
 >> Change the buildroot option name from BR2_PACKAGE_LIBCAMERA_PIPELINE_RASPBERRYPI
 >> to BR2_PACKAGE_LIBCAMERA_PIPELINE_RPI_VC4 (and add Config.in.legacy entry
 >> accordingly) and move handling in Config.in/libcamer.mk to follow alphabetic
 >> ordering.
 >> 
 >> Fixes:
 >> 
 >> .../build/libcamera-v0.1.0/meson.build:3:0: ERROR: Options
 >> "raspberrypi" are not in allowed choices: "all, auto, imx8-isi,
 >> ipu3, rkisp1, rpi/vc4, simple, uvcvideo, vimc"
 >> 
 >> [1] https://git.libcamera.org/libcamera/libcamera.git/commit/?id=726e9274ea95fa46352556d340c5793a8da51fcd
 >> 
 >> Signed-off-by: Peter Seiderer <ps.report@gmx.net>

 > Applied to master, thanks.

 > Regards,
 > Yann E. MORIN.

 >> ---
 >> Config.in.legacy               | 10 ++++++++++
 >> package/libcamera/Config.in    | 16 ++++++++--------
 >> package/libcamera/libcamera.mk |  6 +++---
 >> 3 files changed, 21 insertions(+), 11 deletions(-)
 >> 
 >> diff --git a/Config.in.legacy b/Config.in.legacy
 >> index 6fef2318b0..06a40f0b38 100644
 >> --- a/Config.in.legacy
 >> +++ b/Config.in.legacy
 >> @@ -146,6 +146,16 @@ endif
 >> 
 >> comment "Legacy options removed in 2023.11"
 >> 
 >> +config BR2_PACKAGE_LIBCAMERA_PIPELINE_RASPBERRYPI
 >> +	bool "libcamera pipeline 'raspberrypi' was renamed to 'rpi/vc4'"
 >> +	depends on BR2_arm || BR2_aarch64
 >> +	depends on BR2_USE_WCHAR
 >> +	select BR2_LEGACY
 >> +	select BR2_PACKAGE_LIBCAMERA_PIPELINE_RPI_VC4
 >> +	help
 >> +	  Since version ... the libcamera pipeline option 'raspberrypi' was

I guess ... should have been 0.1.0:

git describe --contains 726e9274e
v0.1.0~78

check-package also complains about too long help line:

Config.in.legacy:156: help text: <tab><2 spaces><62 chars> (http://nightly.buildroot.org/#writing-rules-config-in)

Committed to 2023.11.x after fixing those issues, thanks.
Peter Korsgaard Jan. 10, 2024, 3:37 p.m. UTC | #4
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

Hi,

 >> > +	  Since version ... the libcamera pipeline option 'raspberrypi' was

 >     $ ./utils/docker-run make check-pacakge
 >     Config.in.legacy:156: help text: <tab><2 spaces><62 chars> (http://nightly.buildroot.org/#writing-rules-config-in)

 > I had it fixed locally, but forgot to commit before pushing, so I pushed
 > a follow-up fix.

 > I also replaced the '...' with the actual version you talked about ion
 > the commit log: 0.1.0.

Ahh ;)
diff mbox series

Patch

diff --git a/Config.in.legacy b/Config.in.legacy
index 6fef2318b0..06a40f0b38 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -146,6 +146,16 @@  endif
 
 comment "Legacy options removed in 2023.11"
 
+config BR2_PACKAGE_LIBCAMERA_PIPELINE_RASPBERRYPI
+	bool "libcamera pipeline 'raspberrypi' was renamed to 'rpi/vc4'"
+	depends on BR2_arm || BR2_aarch64
+	depends on BR2_USE_WCHAR
+	select BR2_LEGACY
+	select BR2_PACKAGE_LIBCAMERA_PIPELINE_RPI_VC4
+	help
+	  Since version ... the libcamera pipeline option 'raspberrypi' was
+	  renamed to 'rpi/vc4'.
+
 config BR2_PACKAGE_OPENJDK_VERSION_11
 	bool "openjdk 11 has been removed"
 	select BR2_LEGACY
diff --git a/package/libcamera/Config.in b/package/libcamera/Config.in
index 63c06173db..65d5fb37f8 100644
--- a/package/libcamera/Config.in
+++ b/package/libcamera/Config.in
@@ -40,21 +40,21 @@  config BR2_PACKAGE_LIBCAMERA_PIPELINE_IPU3
 	help
 	  Pipeline for Intel IPU3.
 
-config BR2_PACKAGE_LIBCAMERA_PIPELINE_RASPBERRYPI
-	bool "raspberrypi pipeline"
+config BR2_PACKAGE_LIBCAMERA_PIPELINE_RKISP1
+	bool "rkisp1 pipeline"
 	depends on BR2_arm || BR2_aarch64
-	depends on BR2_USE_WCHAR # boost (already enforced for gnutls)
-	select BR2_PACKAGE_BOOST
 	select BR2_PACKAGE_LIBCAMERA_HAS_PIPELINE
 	help
-	  Pipeline for Raspberry Pi devices.
+	  Pipeline for Rockchip ISP1.
 
-config BR2_PACKAGE_LIBCAMERA_PIPELINE_RKISP1
-	bool "rkisp1 pipeline"
+config BR2_PACKAGE_LIBCAMERA_PIPELINE_RPI_VC4
+	bool "rpi/vc4 pipeline"
 	depends on BR2_arm || BR2_aarch64
+	depends on BR2_USE_WCHAR # boost (already enforced for gnutls)
+	select BR2_PACKAGE_BOOST
 	select BR2_PACKAGE_LIBCAMERA_HAS_PIPELINE
 	help
-	  Pipeline for Rockchip ISP1.
+	  Pipeline for Raspberry Pi devices.
 
 config BR2_PACKAGE_LIBCAMERA_PIPELINE_SIMPLE
 	bool "simple pipeline"
diff --git a/package/libcamera/libcamera.mk b/package/libcamera/libcamera.mk
index 8dce67f60f..c1c8bb7b33 100644
--- a/package/libcamera/libcamera.mk
+++ b/package/libcamera/libcamera.mk
@@ -51,11 +51,11 @@  LIBCAMERA_CONF_OPTS += -Dv4l2=false
 endif
 
 LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_IPU3) += ipu3
-ifeq ($(BR2_PACKAGE_LIBCAMERA_PIPELINE_RASPBERRYPI),y)
-LIBCAMERA_PIPELINES-y += raspberrypi
+LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_RKISP1) += rkisp1
+ifeq ($(BR2_PACKAGE_LIBCAMERA_PIPELINE_RPI_VC4),y)
+LIBCAMERA_PIPELINES-y += rpi/vc4
 LIBCAMERA_DEPENDENCIES += boost
 endif
-LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_RKISP1) += rkisp1
 LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_SIMPLE) += simple
 LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_UVCVIDEO) += uvcvideo
 LIBCAMERA_PIPELINES-$(BR2_PACKAGE_LIBCAMERA_PIPELINE_VIMC) += vimc