diff mbox series

[3/3] package/earlyoom: unhardcode package version in CFLAGS

Message ID 20230529134320.1961326-3-SIBobrenok@sberdevices.ru
State Accepted
Headers show
Series [1/3] package/earlyoom: fix daemon executable path in the init script | expand

Commit Message

Sergey Bobrenok May 29, 2023, 1:44 p.m. UTC
'earlyoom --help' still says 'earlyoom 1.6' though it's already
version 1.7. '-DVERSION' flag value should be either unhardcoded,
either updated with each package version bump.

Signed-off-by: Sergey Bobrenok <SIBobrenok@sberdevices.ru>
---
 package/earlyoom/earlyoom.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard June 2, 2023, 7:25 p.m. UTC | #1
>>>>> "Sergey" == Sergey Bobrenok via buildroot <buildroot@buildroot.org> writes:

 > 'earlyoom --help' still says 'earlyoom 1.6' though it's already
 > version 1.7. '-DVERSION' flag value should be either unhardcoded,
 > either updated with each package version bump.

 > Signed-off-by: Sergey Bobrenok <SIBobrenok@sberdevices.ru>

Committed, thanks.
Peter Korsgaard June 14, 2023, 9:23 a.m. UTC | #2
>>>>> "Sergey" == Sergey Bobrenok via buildroot <buildroot@buildroot.org> writes:

 > 'earlyoom --help' still says 'earlyoom 1.6' though it's already
 > version 1.7. '-DVERSION' flag value should be either unhardcoded,
 > either updated with each package version bump.

 > Signed-off-by: Sergey Bobrenok <SIBobrenok@sberdevices.ru>

Committed to 2023.02.x, thanks.
diff mbox series

Patch

diff --git a/package/earlyoom/earlyoom.mk b/package/earlyoom/earlyoom.mk
index c7042a054e..808b9c49fa 100644
--- a/package/earlyoom/earlyoom.mk
+++ b/package/earlyoom/earlyoom.mk
@@ -11,7 +11,7 @@  EARLYOOM_LICENSE_FILES = LICENSE
 
 EARLYOOM_BUILD_TARGETS = earlyoom.service earlyoom
 EARLYOOM_INSTALL_TARGETS = install-default install-bin
-EARLYOOM_CFLAGS = '$(TARGET_CFLAGS) -std=gnu99 -DVERSION=\"1.6\"'
+EARLYOOM_CFLAGS = '$(TARGET_CFLAGS) -std=gnu99 -DVERSION=\"$(EARLYOOM_VERSION)\"'
 
 EARLYOOM_MAKE_OPTS = \
 	$(TARGET_CONFIGURE_OPTS) \