diff mbox series

[1/3] package/earlyoom: fix daemon executable path in the init script

Message ID 20230529134320.1961326-1-SIBobrenok@sberdevices.ru
State Accepted
Headers show
Series [1/3] package/earlyoom: fix daemon executable path in the init script | expand

Commit Message

Sergey Bobrenok May 29, 2023, 1:43 p.m. UTC
earlyoom.mk file explicitly sets 'PREFIX=/usr', and the init script
fails to start earlyoom because of a nonexistent executable path:

  # /etc/init.d/S02earlyoom start
  start-stop-daemon: unable to stat /bin/earlyoom (No such file or directory)
  FAIL

Signed-off-by: Sergey Bobrenok <SIBobrenok@sberdevices.ru>
---
 package/earlyoom/S02earlyoom | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: c765ac9c02dbddd53cf6813cf59c8f265b043caf

Comments

Peter Korsgaard June 2, 2023, 7:25 p.m. UTC | #1
>>>>> "Sergey" == Sergey Bobrenok via buildroot <buildroot@buildroot.org> writes:

 > earlyoom.mk file explicitly sets 'PREFIX=/usr', and the init script
 > fails to start earlyoom because of a nonexistent executable path:

 >   # /etc/init.d/S02earlyoom start
 >   start-stop-daemon: unable to stat /bin/earlyoom (No such file or directory)
 >   FAIL

 > Signed-off-by: Sergey Bobrenok <SIBobrenok@sberdevices.ru>

Committed, thanks.
Peter Korsgaard June 14, 2023, 9:23 a.m. UTC | #2
>>>>> "Sergey" == Sergey Bobrenok via buildroot <buildroot@buildroot.org> writes:

 > earlyoom.mk file explicitly sets 'PREFIX=/usr', and the init script
 > fails to start earlyoom because of a nonexistent executable path:

 >   # /etc/init.d/S02earlyoom start
 >   start-stop-daemon: unable to stat /bin/earlyoom (No such file or directory)
 >   FAIL

 > Signed-off-by: Sergey Bobrenok <SIBobrenok@sberdevices.ru>

Committed to 2023.02.x, thanks.
diff mbox series

Patch

diff --git a/package/earlyoom/S02earlyoom b/package/earlyoom/S02earlyoom
index c02495af90..35624f3c72 100644
--- a/package/earlyoom/S02earlyoom
+++ b/package/earlyoom/S02earlyoom
@@ -9,7 +9,7 @@  EARLYOOM_ARGS=""
 
 start() {
 	printf() 'Starting %s: ' "$DAEMON"
-	start-stop-daemon -b -m -S -q -p "$PIDFILE" -x "/bin/$DAEMON" \
+	start-stop-daemon -b -m -S -q -p "$PIDFILE" -x "/usr/bin/$DAEMON" \
 	       -- $EARLYOOM_ARGS
 	status=$?
 	if [ "$status" -eq 0 ]; then