diff mbox series

[1/1] package/php: link with -latomic if needed

Message ID 20230310170611.425280-1-bernd.kuhls@t-online.de
State Accepted
Headers show
Series [1/1] package/php: link with -latomic if needed | expand

Commit Message

Bernd Kuhls March 10, 2023, 5:06 p.m. UTC
Fixes:
http://autobuild.buildroot.net/results/112/112ec5cb0de6f55a29caf7ec563367afd28eb8a0/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/php/php.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Arnout Vandecappelle March 10, 2023, 7:53 p.m. UTC | #1
On 10/03/2023 18:06, Bernd Kuhls wrote:
> Fixes:
> http://autobuild.buildroot.net/results/112/112ec5cb0de6f55a29caf7ec563367afd28eb8a0/
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/php/php.mk | 4 ++++
>   1 file changed, 4 insertions(+)
> 
> diff --git a/package/php/php.mk b/package/php/php.mk
> index bd7d5a8c3c..49f02d7f20 100644
> --- a/package/php/php.mk
> +++ b/package/php/php.mk
> @@ -35,6 +35,10 @@ ifeq ($(BR2_STATIC_LIBS)$(BR2_TOOLCHAIN_HAS_THREADS),yy)
>   PHP_STATIC_LIBS += -lpthread
>   endif
>   
> +ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
> +PHP_EXTRA_LIBS += -latomic
> +endif
> +
>   ifeq ($(call qstrip,$(BR2_TARGET_LOCALTIME)),)
>   PHP_LOCALTIME = UTC
>   else
diff mbox series

Patch

diff --git a/package/php/php.mk b/package/php/php.mk
index bd7d5a8c3c..49f02d7f20 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -35,6 +35,10 @@  ifeq ($(BR2_STATIC_LIBS)$(BR2_TOOLCHAIN_HAS_THREADS),yy)
 PHP_STATIC_LIBS += -lpthread
 endif
 
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+PHP_EXTRA_LIBS += -latomic
+endif
+
 ifeq ($(call qstrip,$(BR2_TARGET_LOCALTIME)),)
 PHP_LOCALTIME = UTC
 else