diff mbox series

[v1,2/2] package/speechd: add default configure options

Message ID 20230227214220.12101-2-ps.report@gmx.net
State Accepted
Headers show
Series [v1,1/2] package/speechd: fix libltdl enable/disable configure option | expand

Commit Message

Peter Seiderer Feb. 27, 2023, 9:42 p.m. UTC
- add default configure options for all optional speechd features/
  output modules (disable all with additional library dependencies, enable
  oss)

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
 package/speechd/speechd.mk | 17 ++++++++++++++++-
 1 file changed, 16 insertions(+), 1 deletion(-)

Comments

Arnout Vandecappelle March 9, 2023, 8:28 p.m. UTC | #1
On 27/02/2023 22:42, Peter Seiderer wrote:
> - add default configure options for all optional speechd features/
>    output modules (disable all with additional library dependencies, enable
>    oss)
> 
> Signed-off-by: Peter Seiderer <ps.report@gmx.net>

  Applied to master, thanks.

  Why not next, you will ask? Well, this is in fact a fix; otherwise, what gets 
built will depend on the build order (if alsa or pulse or ... is built as well).

> ---
>   package/speechd/speechd.mk | 17 ++++++++++++++++-
>   1 file changed, 16 insertions(+), 1 deletion(-)
> 
> diff --git a/package/speechd/speechd.mk b/package/speechd/speechd.mk
> index b545863035..5944ea3a28 100644
> --- a/package/speechd/speechd.mk
> +++ b/package/speechd/speechd.mk
> @@ -14,7 +14,22 @@ SPEECHD_AUTORECONF = YES
>   SPEECHD_GETTEXTIZE = YES
>   SPEECHD_DEPENDENCIES = host-pkgconf dotconf libglib2 libsndfile
>   SPEECHD_CONF_ENV = ac_cv_prog_HELP2MAN=""
> -SPEECHD_CONF_OPTS = --without-kali
> +SPEECHD_CONF_OPTS = \
> +	--disable-python \
> +	--without-espeak \
> +	--without-espeak-ng \
> +	--without-flite \
> +	--without-ibmtts \
> +	--without-voxin \
> +	--without-ivona \
> +	--without-pico \
> +	--without-baratinoo \
> +	--without-kali \
> +	--without-pulse \
> +	--without-libao \
> +	--without-alsa \
> +	--with-oss \
> +	--without-nas

  Since OSS is pretty solidly deprecated, this essentially makes the package 
useless for producing actual audio output... How is it supposed to be used then? 
Peter, you introduced it, I assume you use it for something? Or was it just for 
qt5speech and you don't actually use it?

  It would obviously be best to add either automatic or user-selectable 
dependencies for at least pulse and alsa. And obviously, we have flite and 
espeak packages so those are relevant as well. Not to mention python.

  Regards,
  Arnout

>   
>   # fix missing config.rpath (needed for autoreconf) in the codebase
>   define SPEECHD_TOUCH_CONFIG_RPATH
diff mbox series

Patch

diff --git a/package/speechd/speechd.mk b/package/speechd/speechd.mk
index b545863035..5944ea3a28 100644
--- a/package/speechd/speechd.mk
+++ b/package/speechd/speechd.mk
@@ -14,7 +14,22 @@  SPEECHD_AUTORECONF = YES
 SPEECHD_GETTEXTIZE = YES
 SPEECHD_DEPENDENCIES = host-pkgconf dotconf libglib2 libsndfile
 SPEECHD_CONF_ENV = ac_cv_prog_HELP2MAN=""
-SPEECHD_CONF_OPTS = --without-kali
+SPEECHD_CONF_OPTS = \
+	--disable-python \
+	--without-espeak \
+	--without-espeak-ng \
+	--without-flite \
+	--without-ibmtts \
+	--without-voxin \
+	--without-ivona \
+	--without-pico \
+	--without-baratinoo \
+	--without-kali \
+	--without-pulse \
+	--without-libao \
+	--without-alsa \
+	--with-oss \
+	--without-nas
 
 # fix missing config.rpath (needed for autoreconf) in the codebase
 define SPEECHD_TOUCH_CONFIG_RPATH