diff mbox series

[v1,1/2] package/speechd: fix libltdl enable/disable configure option

Message ID 20230227214220.12101-1-ps.report@gmx.net
State Accepted
Headers show
Series [v1,1/2] package/speechd: fix libltdl enable/disable configure option | expand

Commit Message

Peter Seiderer Feb. 27, 2023, 9:42 p.m. UTC
- libltdl usage is configured by --disable/enable-ltdl (see configure.ac
  'AC_ARG_ENABLE([ltdl], [...])')

Fixes:

  configure: WARNING: unrecognized options: [...] --with-libltdl

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
 package/speechd/speechd.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Arnout Vandecappelle March 9, 2023, 8:24 p.m. UTC | #1
On 27/02/2023 22:42, Peter Seiderer wrote:
> - libltdl usage is configured by --disable/enable-ltdl (see configure.ac
>    'AC_ARG_ENABLE([ltdl], [...])')
> 
> Fixes:
> 
>    configure: WARNING: unrecognized options: [...] --with-libltdl
> 
> Signed-off-by: Peter Seiderer <ps.report@gmx.net>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/speechd/speechd.mk | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/package/speechd/speechd.mk b/package/speechd/speechd.mk
> index ec62980986..b545863035 100644
> --- a/package/speechd/speechd.mk
> +++ b/package/speechd/speechd.mk
> @@ -24,9 +24,9 @@ SPEECHD_PRE_CONFIGURE_HOOKS += SPEECHD_TOUCH_CONFIG_RPATH
>   
>   ifeq ($(BR2_PACKAGE_LIBTOOL),y)
>   SPEECHD_DEPENDENCIES += libtool
> -SPEECHD_CONF_OPTS += --with-libltdl
> +SPEECHD_CONF_OPTS += --enable-ltdl
>   else
> -SPEECHD_CONF_OPTS += --without-libltdl
> +SPEECHD_CONF_OPTS += --disable-ltdl
>   endif
>   
>   define SPEECHD_INSTALL_INIT_SYSTEMD
diff mbox series

Patch

diff --git a/package/speechd/speechd.mk b/package/speechd/speechd.mk
index ec62980986..b545863035 100644
--- a/package/speechd/speechd.mk
+++ b/package/speechd/speechd.mk
@@ -24,9 +24,9 @@  SPEECHD_PRE_CONFIGURE_HOOKS += SPEECHD_TOUCH_CONFIG_RPATH
 
 ifeq ($(BR2_PACKAGE_LIBTOOL),y)
 SPEECHD_DEPENDENCIES += libtool
-SPEECHD_CONF_OPTS += --with-libltdl
+SPEECHD_CONF_OPTS += --enable-ltdl
 else
-SPEECHD_CONF_OPTS += --without-libltdl
+SPEECHD_CONF_OPTS += --disable-ltdl
 endif
 
 define SPEECHD_INSTALL_INIT_SYSTEMD