diff mbox series

[v2,1/1] package/libarchive: Only add "iconv" to the .pc file if needed

Message ID 20230201181005.731564-1-bernd.kuhls@t-online.de
State Accepted
Headers show
Series [v2,1/1] package/libarchive: Only add "iconv" to the .pc file if needed | expand

Commit Message

Bernd Kuhls Feb. 1, 2023, 6:10 p.m. UTC
Fix the following build failure with fwup raised since bump to version
3.6.2 in commit 380341b249175382691f268de4b41d3843ff0acc and
https://github.com/libarchive/libarchive/commit/a83f3d327aefe8d628230f326621b014d82f55b4

checking for pkg-config... /tmp/instance-19/output-1/host/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for ARCHIVE... no
configure: error: Requires libarchive. Libarchive must be built with zlib support.

Fixes:
http://autobuild.buildroot.net/results/f5d/f5d549fb4f08156ba5952ce75926f7fd2242bfdf/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
v2: added dependency to host-pkgconf to fix autoconf error

 ...y-add-iconv-to-the-pc-file-if-needed.patch | 44 +++++++++++++++++++
 package/libarchive/libarchive.mk              |  4 ++
 2 files changed, 48 insertions(+)
 create mode 100644 package/libarchive/0001-Only-add-iconv-to-the-pc-file-if-needed.patch

Comments

Peter Seiderer Feb. 2, 2023, 8:46 p.m. UTC | #1
On Wed,  1 Feb 2023 19:10:05 +0100, Bernd Kuhls <bernd.kuhls@t-online.de> wrote:

> Fix the following build failure with fwup raised since bump to version
> 3.6.2 in commit 380341b249175382691f268de4b41d3843ff0acc and
> https://github.com/libarchive/libarchive/commit/a83f3d327aefe8d628230f326621b014d82f55b4
>
> checking for pkg-config... /tmp/instance-19/output-1/host/bin/pkg-config
> checking pkg-config is at least version 0.9.0... yes
> checking for ARCHIVE... no
> configure: error: Requires libarchive. Libarchive must be built with zlib support.
>
> Fixes:
> http://autobuild.buildroot.net/results/f5d/f5d549fb4f08156ba5952ce75926f7fd2242bfdf/

And some opkg autobuild failures:

http://autobuild.buildroot.net/results/3c0cb8ff764fb97c9d0498a4d58857351b659676/
http://autobuild.buildroot.net/results/87d5ebbe2db2358da05751c087e31b8528d8b0e7/
http://autobuild.buildroot.net/results/f604b2e3cdc0b8d8fcdfc847a3b2c8904fff649c/
http://autobuild.buildroot.net/results/9a54d6267fb69657bf994f77a1193c37dff01066/
http://autobuild.buildroot.net/results/5dc839d26b34824f78311c5e745d51209f7a1987/
http://autobuild.buildroot.net/results/7cc3bceddd4ba016164d31d2718138c43cb8b976/
http://autobuild.buildroot.net/results/b844d753f5d1969e941e2a865c7ff760fde37d9c/
http://autobuild.buildroot.net/results/29d5d20660318620befb78af3be06896d4a70e99/

Regards,
Peter


>
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
> v2: added dependency to host-pkgconf to fix autoconf error
>
>  ...y-add-iconv-to-the-pc-file-if-needed.patch | 44 +++++++++++++++++++
>  package/libarchive/libarchive.mk              |  4 ++
>  2 files changed, 48 insertions(+)
>  create mode 100644 package/libarchive/0001-Only-add-iconv-to-the-pc-file-if-needed.patch
>
> diff --git a/package/libarchive/0001-Only-add-iconv-to-the-pc-file-if-needed.patch b/package/libarchive/0001-Only-add-iconv-to-the-pc-file-if-needed.patch
> new file mode 100644
> index 0000000000..c93944f789
> --- /dev/null
> +++ b/package/libarchive/0001-Only-add-iconv-to-the-pc-file-if-needed.patch
> @@ -0,0 +1,44 @@
> +From 1f35c466aaa9444335a1b854b0b7223b0d2346c2 Mon Sep 17 00:00:00 2001
> +From: Peter Pentchev <roam@ringlet.net>
> +Date: Thu, 29 Dec 2022 00:04:40 +0200
> +Subject: [PATCH] Only add "iconv" to the .pc file if needed (#1825)
> +
> +Hi,
> +
> +Thanks for writing and maintaining libarchive!
> +
> +What do you think about this trivial change that does not add "iconv" to
> +the pkg-config file's list of required packages unless it is actually
> +needed? On at least Debian GNU/Linux systems, the iconv(3) function is
> +part of the system C library and there is no Debian package that
> +installs an iconv.pc file, so I had to make this change to the Debian
> +package of libarchive.
> +
> +Thanks again, and keep up the great work!
> +
> +G'luck,
> +Peter
> +
> +Downloaded from upstream commit:
> +https://github.com/libarchive/libarchive/commit/1f35c466aaa9444335a1b854b0b7223b0d2346c2
> +
> +Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> +---
> + configure.ac | 4 +++-
> + 1 file changed, 3 insertions(+), 1 deletion(-)
> +
> +diff --git a/configure.ac b/configure.ac
> +index 99bff20d1..e2715cfde 100644
> +--- a/configure.ac
> ++++ b/configure.ac
> +@@ -378,7 +378,9 @@ if test "x$with_iconv" != "xno"; then
> +     AC_CHECK_HEADERS([localcharset.h])
> +     am_save_LIBS="$LIBS"
> +     LIBS="${LIBS} ${LIBICONV}"
> +-    LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }iconv"
> ++    if test -n "$LIBICONV"; then
> ++      LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }iconv"
> ++    fi
> +     AC_CHECK_FUNCS([locale_charset])
> +     LIBS="${am_save_LIBS}"
> +     if test "x$ac_cv_func_locale_charset" != "xyes"; then
> diff --git a/package/libarchive/libarchive.mk b/package/libarchive/libarchive.mk
> index cfc148d01d..cd7c13fbed 100644
> --- a/package/libarchive/libarchive.mk
> +++ b/package/libarchive/libarchive.mk
> @@ -11,6 +11,10 @@ LIBARCHIVE_INSTALL_STAGING = YES
>  LIBARCHIVE_LICENSE = BSD-2-Clause, BSD-3-Clause, CC0-1.0, OpenSSL, Apache-2.0
>  LIBARCHIVE_LICENSE_FILES = COPYING
>  LIBARCHIVE_CPE_ID_VENDOR = libarchive
> +# We're patching configure.ac
> +LIBARCHIVE_AUTORECONF = YES
> +# needed for autoreconf
> +LIBARCHIVE_DEPENDENCIES += host-pkgconf
>
>  ifeq ($(BR2_PACKAGE_LIBARCHIVE_BSDTAR),y)
>  ifeq ($(BR2_STATIC_LIBS),y)
Yann E. MORIN Feb. 4, 2023, 2:55 p.m. UTC | #2
Bernd, All,

On 2023-02-01 19:10 +0100, Bernd Kuhls spake thusly:
> Fix the following build failure with fwup raised since bump to version
> 3.6.2 in commit 380341b249175382691f268de4b41d3843ff0acc and
> https://github.com/libarchive/libarchive/commit/a83f3d327aefe8d628230f326621b014d82f55b4
> 
> checking for pkg-config... /tmp/instance-19/output-1/host/bin/pkg-config
> checking pkg-config is at least version 0.9.0... yes
> checking for ARCHIVE... no
> configure: error: Requires libarchive. Libarchive must be built with zlib support.
> 
> Fixes:
> http://autobuild.buildroot.net/results/f5d/f5d549fb4f08156ba5952ce75926f7fd2242bfdf/
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
> v2: added dependency to host-pkgconf to fix autoconf error
> 
>  ...y-add-iconv-to-the-pc-file-if-needed.patch | 44 +++++++++++++++++++
>  package/libarchive/libarchive.mk              |  4 ++
>  2 files changed, 48 insertions(+)
>  create mode 100644 package/libarchive/0001-Only-add-iconv-to-the-pc-file-if-needed.patch
> 
> diff --git a/package/libarchive/0001-Only-add-iconv-to-the-pc-file-if-needed.patch b/package/libarchive/0001-Only-add-iconv-to-the-pc-file-if-needed.patch
> new file mode 100644
> index 0000000000..c93944f789
> --- /dev/null
> +++ b/package/libarchive/0001-Only-add-iconv-to-the-pc-file-if-needed.patch
> @@ -0,0 +1,44 @@
> +From 1f35c466aaa9444335a1b854b0b7223b0d2346c2 Mon Sep 17 00:00:00 2001
> +From: Peter Pentchev <roam@ringlet.net>
> +Date: Thu, 29 Dec 2022 00:04:40 +0200
> +Subject: [PATCH] Only add "iconv" to the .pc file if needed (#1825)
> +
> +Hi,
> +
> +Thanks for writing and maintaining libarchive!
> +
> +What do you think about this trivial change that does not add "iconv" to
> +the pkg-config file's list of required packages unless it is actually
> +needed? On at least Debian GNU/Linux systems, the iconv(3) function is
> +part of the system C library and there is no Debian package that
> +installs an iconv.pc file, so I had to make this change to the Debian
> +package of libarchive.
> +
> +Thanks again, and keep up the great work!
> +
> +G'luck,
> +Peter
> +
> +Downloaded from upstream commit:
> +https://github.com/libarchive/libarchive/commit/1f35c466aaa9444335a1b854b0b7223b0d2346c2
> +
> +Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> +---
> + configure.ac | 4 +++-
> + 1 file changed, 3 insertions(+), 1 deletion(-)
> +
> +diff --git a/configure.ac b/configure.ac
> +index 99bff20d1..e2715cfde 100644
> +--- a/configure.ac
> ++++ b/configure.ac
> +@@ -378,7 +378,9 @@ if test "x$with_iconv" != "xno"; then
> +     AC_CHECK_HEADERS([localcharset.h])
> +     am_save_LIBS="$LIBS"
> +     LIBS="${LIBS} ${LIBICONV}"
> +-    LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }iconv"
> ++    if test -n "$LIBICONV"; then
> ++      LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }iconv"
> ++    fi
> +     AC_CHECK_FUNCS([locale_charset])
> +     LIBS="${am_save_LIBS}"
> +     if test "x$ac_cv_func_locale_charset" != "xyes"; then
> diff --git a/package/libarchive/libarchive.mk b/package/libarchive/libarchive.mk
> index cfc148d01d..cd7c13fbed 100644
> --- a/package/libarchive/libarchive.mk
> +++ b/package/libarchive/libarchive.mk
> @@ -11,6 +11,10 @@ LIBARCHIVE_INSTALL_STAGING = YES
>  LIBARCHIVE_LICENSE = BSD-2-Clause, BSD-3-Clause, CC0-1.0, OpenSSL, Apache-2.0
>  LIBARCHIVE_LICENSE_FILES = COPYING
>  LIBARCHIVE_CPE_ID_VENDOR = libarchive
> +# We're patching configure.ac
> +LIBARCHIVE_AUTORECONF = YES
> +# needed for autoreconf
> +LIBARCHIVE_DEPENDENCIES += host-pkgconf
>  
>  ifeq ($(BR2_PACKAGE_LIBARCHIVE_BSDTAR),y)
>  ifeq ($(BR2_STATIC_LIBS),y)
> -- 
> 2.39.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/libarchive/0001-Only-add-iconv-to-the-pc-file-if-needed.patch b/package/libarchive/0001-Only-add-iconv-to-the-pc-file-if-needed.patch
new file mode 100644
index 0000000000..c93944f789
--- /dev/null
+++ b/package/libarchive/0001-Only-add-iconv-to-the-pc-file-if-needed.patch
@@ -0,0 +1,44 @@ 
+From 1f35c466aaa9444335a1b854b0b7223b0d2346c2 Mon Sep 17 00:00:00 2001
+From: Peter Pentchev <roam@ringlet.net>
+Date: Thu, 29 Dec 2022 00:04:40 +0200
+Subject: [PATCH] Only add "iconv" to the .pc file if needed (#1825)
+
+Hi,
+
+Thanks for writing and maintaining libarchive!
+
+What do you think about this trivial change that does not add "iconv" to
+the pkg-config file's list of required packages unless it is actually
+needed? On at least Debian GNU/Linux systems, the iconv(3) function is
+part of the system C library and there is no Debian package that
+installs an iconv.pc file, so I had to make this change to the Debian
+package of libarchive.
+
+Thanks again, and keep up the great work!
+
+G'luck,
+Peter
+
+Downloaded from upstream commit:
+https://github.com/libarchive/libarchive/commit/1f35c466aaa9444335a1b854b0b7223b0d2346c2
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+---
+ configure.ac | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 99bff20d1..e2715cfde 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -378,7 +378,9 @@ if test "x$with_iconv" != "xno"; then
+     AC_CHECK_HEADERS([localcharset.h])
+     am_save_LIBS="$LIBS"
+     LIBS="${LIBS} ${LIBICONV}"
+-    LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }iconv"
++    if test -n "$LIBICONV"; then
++      LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }iconv"
++    fi
+     AC_CHECK_FUNCS([locale_charset])
+     LIBS="${am_save_LIBS}"
+     if test "x$ac_cv_func_locale_charset" != "xyes"; then
diff --git a/package/libarchive/libarchive.mk b/package/libarchive/libarchive.mk
index cfc148d01d..cd7c13fbed 100644
--- a/package/libarchive/libarchive.mk
+++ b/package/libarchive/libarchive.mk
@@ -11,6 +11,10 @@  LIBARCHIVE_INSTALL_STAGING = YES
 LIBARCHIVE_LICENSE = BSD-2-Clause, BSD-3-Clause, CC0-1.0, OpenSSL, Apache-2.0
 LIBARCHIVE_LICENSE_FILES = COPYING
 LIBARCHIVE_CPE_ID_VENDOR = libarchive
+# We're patching configure.ac
+LIBARCHIVE_AUTORECONF = YES
+# needed for autoreconf
+LIBARCHIVE_DEPENDENCIES += host-pkgconf
 
 ifeq ($(BR2_PACKAGE_LIBARCHIVE_BSDTAR),y)
 ifeq ($(BR2_STATIC_LIBS),y)