diff mbox series

[1/2] package/x11r7/xdriver_xf86-video-qxl: bump version to 0.1.6

Message ID 20230127192108.341891-1-bernd.kuhls@t-online.de
State Accepted
Headers show
Series [1/2] package/x11r7/xdriver_xf86-video-qxl: bump version to 0.1.6 | expand

Commit Message

Bernd Kuhls Jan. 27, 2023, 7:21 p.m. UTC
Release notes:
https://lists.x.org/archives/xorg-announce/2023-January/003316.html

Removed patch which was applied upstream.

Switched tarball to xz and _SITE to https, added sha512 hash.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 ...1-Fix-a-build-error-with-Xorg-master.patch | 106 ------------------
 .../xdriver_xf86-video-qxl.hash               |   5 +-
 .../xdriver_xf86-video-qxl.mk                 |   6 +-
 3 files changed, 6 insertions(+), 111 deletions(-)
 delete mode 100644 package/x11r7/xdriver_xf86-video-qxl/0001-Fix-a-build-error-with-Xorg-master.patch

Comments

Thomas Petazzoni Jan. 28, 2023, 9:51 p.m. UTC | #1
On Fri, 27 Jan 2023 20:21:07 +0100
Bernd Kuhls <bernd.kuhls@t-online.de> wrote:

> Release notes:
> https://lists.x.org/archives/xorg-announce/2023-January/003316.html
> 
> Removed patch which was applied upstream.
> 
> Switched tarball to xz and _SITE to https, added sha512 hash.
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
>  ...1-Fix-a-build-error-with-Xorg-master.patch | 106 ------------------
>  .../xdriver_xf86-video-qxl.hash               |   5 +-
>  .../xdriver_xf86-video-qxl.mk                 |   6 +-
>  3 files changed, 6 insertions(+), 111 deletions(-)
>  delete mode 100644 package/x11r7/xdriver_xf86-video-qxl/0001-Fix-a-build-error-with-Xorg-master.patch

Thanks, both applied. Please note that the link in the QXL driver
Config.in help text is broken, it would be good to fix it.

Thanks!

Thomas
Bernd Kuhls March 10, 2023, 5:15 p.m. UTC | #2
Am Sat, 28 Jan 2023 22:51:22 +0100 schrieb Thomas Petazzoni via buildroot:

> Thanks, both applied. Please note that the link in the QXL driver
> Config.in help text is broken, it would be good to fix it.

Hi Thomas,

done: http://patchwork.ozlabs.org/project/buildroot/patch/
20230310171407.429975-1-bernd.kuhls@t-online.de/

Regards, Bernd
diff mbox series

Patch

diff --git a/package/x11r7/xdriver_xf86-video-qxl/0001-Fix-a-build-error-with-Xorg-master.patch b/package/x11r7/xdriver_xf86-video-qxl/0001-Fix-a-build-error-with-Xorg-master.patch
deleted file mode 100644
index d3257fba20..0000000000
--- a/package/x11r7/xdriver_xf86-video-qxl/0001-Fix-a-build-error-with-Xorg-master.patch
+++ /dev/null
@@ -1,106 +0,0 @@ 
-From 4e1963a812f2c1777ba5d56ea9e939a3e40a0496 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Zolt=C3=A1n=20B=C3=B6sz=C3=B6rm=C3=A9nyi?=
- <zboszor@gmail.com>
-Date: Sat, 28 Aug 2021 15:38:40 +0200
-Subject: [PATCH] Fix a build  error with Xorg master
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Use xf86ReturnOptValBool() in get_bool_option() instead of
-options[option_index].value.bool to fix a compiler error with
-current Xorg xserver master branch.
-
-Also use xf86GetOptValInteger() in get_int_option() and
-xf86GetOptValString() in get_str_option() for consistency.
-
-The change causes a slight performance drop during option parsing
-because the passed-in index_value is no longer used as an index
-into the options array.
-
-Instead, it's used as a token now for the standard option getter
-functions which works since the index_value to the get_*_option()
-functions are identical to the value of options[n].token in the
-passed-in OptionInfoRec array.
-
-Also rename "int option_index" to "int token" for clarity in all
-three functions.
-
-Signed-off-by: Zoltán Böszörményi <zboszor@gmail.com>
-
-Downloaded from upstream commit
-https://gitlab.freedesktop.org/xorg/driver/xf86-video-qxl/-/commit/4e1963a812f2c1777ba5d56ea9e939a3e40a0496
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
----
- src/qxl_option_helpers.c | 13 +++++++------
- src/qxl_option_helpers.h |  6 +++---
- 2 files changed, 10 insertions(+), 9 deletions(-)
-
-diff --git a/src/qxl_option_helpers.c b/src/qxl_option_helpers.c
-index 2aba677..7707b7c 100644
---- a/src/qxl_option_helpers.c
-+++ b/src/qxl_option_helpers.c
-@@ -10,31 +10,32 @@
- 
- #include "qxl_option_helpers.h"
- 
--int get_int_option(OptionInfoPtr options, int option_index,
-+int get_int_option(OptionInfoPtr options, int token,
-                    const char *env_name)
- {
-+    int value;
-     if (env_name && getenv(env_name)) {
-         return atoi(getenv(env_name));
-     }
--    return options[option_index].value.num;
-+    return xf86GetOptValInteger(options, token, &value) ? value : 0;
- }
- 
--const char *get_str_option(OptionInfoPtr options, int option_index,
-+const char *get_str_option(OptionInfoPtr options, int token,
-                            const char *env_name)
- {
-     if (getenv(env_name)) {
-         return getenv(env_name);
-     }
--    return options[option_index].value.str;
-+    return xf86GetOptValString(options, token);
- }
- 
--int get_bool_option(OptionInfoPtr options, int option_index,
-+int get_bool_option(OptionInfoPtr options, int token,
-                      const char *env_name)
- {
-     const char* value = getenv(env_name);
- 
-     if (!value) {
--        return options[option_index].value.bool;
-+        return xf86ReturnOptValBool(options, token, FALSE);
-     }
-     if (strcmp(value, "0") == 0 ||
-         strcasecmp(value, "off") == 0 ||
-diff --git a/src/qxl_option_helpers.h b/src/qxl_option_helpers.h
-index 7c54c72..66d0a17 100644
---- a/src/qxl_option_helpers.h
-+++ b/src/qxl_option_helpers.h
-@@ -4,13 +4,13 @@
- #include <xf86Crtc.h>
- #include <xf86Opt.h>
- 
--int get_int_option(OptionInfoPtr options, int option_index,
-+int get_int_option(OptionInfoPtr options, int token,
-                    const char *env_name);
- 
--const char *get_str_option(OptionInfoPtr options, int option_index,
-+const char *get_str_option(OptionInfoPtr options, int token,
-                            const char *env_name);
- 
--int get_bool_option(OptionInfoPtr options, int option_index,
-+int get_bool_option(OptionInfoPtr options, int token,
-                      const char *env_name);
- 
- #endif // OPTION_HELPERS_H
--- 
-GitLab
-
diff --git a/package/x11r7/xdriver_xf86-video-qxl/xdriver_xf86-video-qxl.hash b/package/x11r7/xdriver_xf86-video-qxl/xdriver_xf86-video-qxl.hash
index fdf0cc434d..2d728a7c03 100644
--- a/package/x11r7/xdriver_xf86-video-qxl/xdriver_xf86-video-qxl.hash
+++ b/package/x11r7/xdriver_xf86-video-qxl/xdriver_xf86-video-qxl.hash
@@ -1,4 +1,5 @@ 
-# From https://lists.x.org/archives/xorg-announce/2016-December/002753.html
-sha256  b18682e04503c6326f7bf7190f3ee50a3d4d69758a2a3cc9af102a6b3f114c92  xf86-video-qxl-0.1.5.tar.bz2
+# From https://lists.x.org/archives/xorg-announce/2023-January/003316.html
+sha256  2ad39558db47a8fcc036e290e0b084671e58d43344a57b279abd870c4c67965f  xf86-video-qxl-0.1.6.tar.xz
+sha512  f6a42355915d2e8f8a842dc24fe6d012d123aa6d23eedea1a4771fb08f88e0298d76741755b88304d76c66b3aae15f9fca74d062be395e499a82ee8f4507c7e0  xf86-video-qxl-0.1.6.tar.xz
 # Locally calculated
 sha256  83f3bf7be3fbf5e66174b8184bd837a6b44264f8e340126ea4d9e9ce956a1866  COPYING
diff --git a/package/x11r7/xdriver_xf86-video-qxl/xdriver_xf86-video-qxl.mk b/package/x11r7/xdriver_xf86-video-qxl/xdriver_xf86-video-qxl.mk
index ffbac05ec1..db0bbbaf65 100644
--- a/package/x11r7/xdriver_xf86-video-qxl/xdriver_xf86-video-qxl.mk
+++ b/package/x11r7/xdriver_xf86-video-qxl/xdriver_xf86-video-qxl.mk
@@ -4,9 +4,9 @@ 
 #
 ################################################################################
 
-XDRIVER_XF86_VIDEO_QXL_VERSION = 0.1.5
-XDRIVER_XF86_VIDEO_QXL_SOURCE = xf86-video-qxl-$(XDRIVER_XF86_VIDEO_QXL_VERSION).tar.bz2
-XDRIVER_XF86_VIDEO_QXL_SITE = http://xorg.freedesktop.org/releases/individual/driver
+XDRIVER_XF86_VIDEO_QXL_VERSION = 0.1.6
+XDRIVER_XF86_VIDEO_QXL_SOURCE = xf86-video-qxl-$(XDRIVER_XF86_VIDEO_QXL_VERSION).tar.xz
+XDRIVER_XF86_VIDEO_QXL_SITE = https://xorg.freedesktop.org/archive/individual/driver
 XDRIVER_XF86_VIDEO_QXL_LICENSE = MIT
 XDRIVER_XF86_VIDEO_QXL_LICENSE_FILES = COPYING