diff mbox series

[4/4] package/kmemd: new package

Message ID 20221020141412.346992-5-tobias@waldekranz.com
State Accepted
Headers show
Series package/kmemd: new package | expand

Commit Message

Tobias Waldekranz Oct. 20, 2022, 2:14 p.m. UTC
kmemd let's you inspect a live Linux kernel's memory using GDB.

Signed-off-by: Tobias Waldekranz <tobias@waldekranz.com>
---
 package/Config.in        |  1 +
 package/kmemd/Config.in  | 11 +++++++++++
 package/kmemd/kmemd.hash |  5 +++++
 package/kmemd/kmemd.mk   | 20 ++++++++++++++++++++
 4 files changed, 37 insertions(+)
 create mode 100644 package/kmemd/Config.in
 create mode 100644 package/kmemd/kmemd.hash
 create mode 100644 package/kmemd/kmemd.mk

Comments

Thomas Petazzoni Oct. 27, 2022, 6:49 a.m. UTC | #1
On Thu, 20 Oct 2022 16:14:12 +0200
Tobias Waldekranz <tobias@waldekranz.com> wrote:

> kmemd let's you inspect a live Linux kernel's memory using GDB.
> 
> Signed-off-by: Tobias Waldekranz <tobias@waldekranz.com>

I have applied a patch, with a few small changes.

> ---
>  package/Config.in        |  1 +
>  package/kmemd/Config.in  | 11 +++++++++++
>  package/kmemd/kmemd.hash |  5 +++++
>  package/kmemd/kmemd.mk   | 20 ++++++++++++++++++++
>  4 files changed, 37 insertions(+)

I added an entry in the DEVELOPERS file for this package, so that we
know you are the contact. You will receive e-mails if there are build
failures or CVEs affecting this package, and when new releases are made
upstream (even though I suppose you are the upstream maintainer, so you
should already know!)

> diff --git a/package/kmemd/Config.in b/package/kmemd/Config.in
> new file mode 100644
> index 0000000000..2190488b0f
> --- /dev/null
> +++ b/package/kmemd/Config.in
> @@ -0,0 +1,11 @@
> +config BR2_PACKAGE_KMEMD
> +	bool "kmemd"
> +	depends on BR2_PACKAGE_LIBBPF_SUPPORTED

Changed to repeat the dependencies of libbpf.

> +	select BR2_PACKAGE_LIBBPF
> +	help
> +	  Explore a live Linux kernel's memory using GDB
> +
> +	  https://github.com/wkz/kmemd
> +
> +comment "kmemd needs libbpf"
> +	depends on !BR2_PACKAGE_LIBBPF_SUPPORTED

This comment was not correct: you are selecting libbpf, so you don't
need to say that you need it. Instead, I've added our usual comment,
which corresponds to the dependencies inherited from libbpf.

> diff --git a/package/kmemd/kmemd.hash b/package/kmemd/kmemd.hash
> new file mode 100644
> index 0000000000..60b8589dd2
> --- /dev/null
> +++ b/package/kmemd/kmemd.hash
> @@ -0,0 +1,5 @@
> +# Locally calculated
> +md5  9954bf82279eeb0da016654689f69ac2  kmemd-1.0.0.tar.gz
> +sha1  3ae3bdceb70d674f41f56cd489c7497944b9b0f0  kmemd-1.0.0.tar.gz
> +sha256  519ac3cdd367acee5090eec3b7e08400724f9b84486b191f3af534bd7cffca70  kmemd-1.0.0.tar.gz

When we have a sha256, md5/sha1 hashes are not needed, so I dropped them.

Applied with those changes, thanks!

Thomas
Tobias Waldekranz Oct. 27, 2022, 8:27 p.m. UTC | #2
On tor, okt 27, 2022 at 08:49, Thomas Petazzoni via buildroot <buildroot@buildroot.org> wrote:
...
> Applied with those changes, thanks!

Thanks for going the extra mile!

Hopefully the next series won't require as much work from your end.

--
Tobias
Thomas Petazzoni Oct. 27, 2022, 9:32 p.m. UTC | #3
On Thu, 27 Oct 2022 22:27:25 +0200
Tobias Waldekranz <tobias@waldekranz.com> wrote:

> Thanks for going the extra mile!
> 
> Hopefully the next series won't require as much work from your end.

Oh, no worries, your patch series was actually very good! There was not
much to adjust before committing. Looking forward for more
contributions from you!

Best regards,

Thomas
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index e3a34d6e97..ebafe11dea 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -111,6 +111,7 @@  menu "Debugging, profiling and benchmark"
 	source "package/iozone/Config.in"
 	source "package/kexec/Config.in"
 	source "package/kexec-lite/Config.in"
+	source "package/kmemd/Config.in"
 	source "package/kvm-unit-tests/Config.in"
 	source "package/kyua/Config.in"
 	source "package/latencytop/Config.in"
diff --git a/package/kmemd/Config.in b/package/kmemd/Config.in
new file mode 100644
index 0000000000..2190488b0f
--- /dev/null
+++ b/package/kmemd/Config.in
@@ -0,0 +1,11 @@ 
+config BR2_PACKAGE_KMEMD
+	bool "kmemd"
+	depends on BR2_PACKAGE_LIBBPF_SUPPORTED
+	select BR2_PACKAGE_LIBBPF
+	help
+	  Explore a live Linux kernel's memory using GDB
+
+	  https://github.com/wkz/kmemd
+
+comment "kmemd needs libbpf"
+	depends on !BR2_PACKAGE_LIBBPF_SUPPORTED
diff --git a/package/kmemd/kmemd.hash b/package/kmemd/kmemd.hash
new file mode 100644
index 0000000000..60b8589dd2
--- /dev/null
+++ b/package/kmemd/kmemd.hash
@@ -0,0 +1,5 @@ 
+# Locally calculated
+md5  9954bf82279eeb0da016654689f69ac2  kmemd-1.0.0.tar.gz
+sha1  3ae3bdceb70d674f41f56cd489c7497944b9b0f0  kmemd-1.0.0.tar.gz
+sha256  519ac3cdd367acee5090eec3b7e08400724f9b84486b191f3af534bd7cffca70  kmemd-1.0.0.tar.gz
+sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
diff --git a/package/kmemd/kmemd.mk b/package/kmemd/kmemd.mk
new file mode 100644
index 0000000000..902941b981
--- /dev/null
+++ b/package/kmemd/kmemd.mk
@@ -0,0 +1,20 @@ 
+################################################################################
+#
+# kmemd
+#
+################################################################################
+
+KMEMD_VERSION = 1.0.0
+KMEMD_SITE = https://github.com/wkz/kmemd/releases/download/$(KMEMD_VERSION)
+KMEMD_LICENSE = GPL-2.0
+KMEMD_LICENSE_FILES = COPYING
+KMEMD_DEPENDENCIES = libbpf
+
+define KMEMD_LINUX_CONFIG_FIXUPS
+	$(call KCONFIG_ENABLE_OPT,CONFIG_BPF_SYSCALL)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_FTRACE)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_KPROBES)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_PERF_EVENTS)
+endef
+
+$(eval $(autotools-package))