diff mbox series

[4/7] package/python-hatchling: new package

Message ID 20221019215348.3262192-4-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/7] package/python-pluggy: enable host package build | expand

Commit Message

James Hilliard Oct. 19, 2022, 9:53 p.m. UTC
This is a new pep517 based build backend.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 DEVELOPERS                                    |  1 +
 .../python-hatchling/python-hatchling.hash    |  5 +++++
 package/python-hatchling/python-hatchling.mk  | 19 +++++++++++++++++++
 3 files changed, 25 insertions(+)
 create mode 100644 package/python-hatchling/python-hatchling.hash
 create mode 100644 package/python-hatchling/python-hatchling.mk
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 48d2193db6..9e2e7a2b87 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1383,6 +1383,7 @@  F:	package/python-flatbuffers/
 F:	package/python-fonttools/
 F:	package/python-frozenlist/
 F:	package/python-greenlet/
+F:	package/python-hatchling/
 F:	package/python-installer/
 F:	package/python-janus/
 F:	package/python-logstash/
diff --git a/package/python-hatchling/python-hatchling.hash b/package/python-hatchling/python-hatchling.hash
new file mode 100644
index 0000000000..41d7be977e
--- /dev/null
+++ b/package/python-hatchling/python-hatchling.hash
@@ -0,0 +1,5 @@ 
+# md5, sha256 from https://pypi.org/pypi/hatchling/json
+md5  e06cc65ac646f9b01df5406aa1f97022  hatchling-1.11.1.tar.gz
+sha256  9f84361f70cf3a7ab9543b0c3ecc64211ed2ba8a606a71eb6a473c1c9b08e1d0  hatchling-1.11.1.tar.gz
+# Locally computed sha256 checksums
+sha256  7f143a8127ad4873862d70854b5bd2abd0085aa73e64fd2b08704a3b9f5c07fc  LICENSE.txt
diff --git a/package/python-hatchling/python-hatchling.mk b/package/python-hatchling/python-hatchling.mk
new file mode 100644
index 0000000000..13155a20a4
--- /dev/null
+++ b/package/python-hatchling/python-hatchling.mk
@@ -0,0 +1,19 @@ 
+################################################################################
+#
+# python-hatchling
+#
+################################################################################
+
+PYTHON_HATCHLING_VERSION = 1.11.1
+PYTHON_HATCHLING_SOURCE = hatchling-$(PYTHON_HATCHLING_VERSION).tar.gz
+PYTHON_HATCHLING_SITE = https://files.pythonhosted.org/packages/24/20/3e21d2bc57229822ac9fb9b314d7892c16f829f34a0eb247c55fc11e09a8
+PYTHON_HATCHLING_LICENSE = MIT
+PYTHON_HATCHLING_LICENSE_FILES = LICENSE.txt
+PYTHON_HATCHLING_SETUP_TYPE = pep517
+HOST_PYTHON_HATCHLING_DEPENDENCIES = \
+	host-python-editables \
+	host-python-packaging \
+	host-python-pathspec \
+	host-python-pluggy
+
+$(eval $(host-python-package))